M.2 Drive Not Found By Bios Solved

  1.    #1

    M.2 Drive Not Found By Bios


    I bought a Samsung 970 EVO Plus NVMe M.2 drive and when I install it into my system the bios does not find it. Windows 10 PRO finds it and I am able to format and use it. I think it is a motherboard bios issue because my old Samsung 950 PRO NVMe M.2 drive is found by the bios and I am able to boot from it. I don't expect Asus to provide a bios update for my old Maximus Hero VI.

    Time to go shopping for a new motherboard?

    Ak
      My ComputerSystem Spec

  2.    #2

    I don't see an M.2 slot on the Maximus Hero VI.
      My ComputerSystem Spec

  3.    #3

    NavyLCDR said: View Post
    I don't see an M.2 slot on the Maximus Hero VI.
    You are right but a PCIe M.2 adapter has worked for me with the Samsung 950 PRO as a boot drive and it still does.

    Ak
      My ComputerSystem Spec

  4.    #4

    I think I have found out why this 970 EVO Plus M.2 is so much slower than my older 950 PRO M.2, the PCIe slot that it is using is Gen 2.0. It is still way faster than a hard drive so I am sort of happy for now. I still don't know why the bios sees the 950 PRO and not the 970 EVO.

    Ak
      My ComputerSystem Spec


 

Related Threads
My SSD hardrive failed in my Dell Inspiron 15 laptop a few weeks ago with a "No Bootable Devices Found" error message at startup BIOS. I was hoping some of you have experience salvaging data in these type of situations. What I've tried I...
Drive C: not found on reboot in General Support
Hi My PC seems to be developing a problem whereby I'm working on it and something happens that makes me feel I need to reboot. This could be anything but NOT games - I don't play games at all (unless you call doing jigsaws playing a game). Since...
Trying to install a new Samsung 960 EVO M.2 1 Tb hard drive on my Dell Latitude E7470 laptop with Windows 10, but my Dell won't recognize the old drive in an external USB 3.0 case. I intended to boot up with the old drive in the USB case, then...
Internal hard disk drive not found in Drivers and Hardware
Hey all I have an Alienware X51 R3 and I was messing with my command prompt and accidentally changed what I believe is the path too boot my hard drive... In the command prompt I said  bcdedit /set {bootmgr} path \EFI\ I then reset my computer...
My Seagate external drive no longer shows up in File Explorer. I'm running Windows 10 for some time now, and it initially showed up until just recently. My local Tech Support guy says there is a known Windows 10 issue with external drives. Do you...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 09:03.
Find Us