Epson XP-6000 driver won't install on latest 19H1 build Solved

  1. jimbo45's Avatar
    Posts : 7,668
    Windows / Linux : Centos, Ubuntu, OpenSuse
       #1

    Epson XP-6000 driver won't install on latest 19H1 build


    Hi folks

    even in "Test mode" I can't get Epson XP-6000 printer driver to install on latest Windows build (19H1) -- keep getting fail due to unsigned drivers -- even in Test mode where you should be able to install anything even if it breaks the system.

    Strangely enough I had no problm using the same printer on a Virtual Machine running latest 20H1 skip ahead build / fast ring or whatever its called these days !!!! and I also got the firmware to update as well. Linux Host using VMWare workstation with 20H1 - printer working fine in Windows VM - printer in Network mode rather than via USB connection --100% working !!!

    What do I have to do to get this printer to work on a Physical machine !!!! -- I can go back zillions of Windows releases and then go via upgrade but I shouldn't have to do it !!! --Even the epson software updater couldn't find the printer on the real machine !!!.

    On the VM : Windows is 20H1 Host Linux Centos 7.6 VMWare workstation pro



    Click image for larger version. 

Name:	snapshot8.png 
Views:	0 
Size:	476.3 KB 
ID:	239739

    Cheers
    jimbo
    Last edited by jimbo45; 09 Jul 2019 at 10:43.
      My ComputerSystem Spec

  2. jimbo45's Avatar
    Posts : 7,668
    Windows / Linux : Centos, Ubuntu, OpenSuse
    Thread Starter
       #2

    Hi there

    I logged on then to US Epson support rather than UK -- downloaded software from that site -- all then worked OK -- maybe the UK sites are as confused as their Brexit thingies currently -- OK that's their problem / choice so not getting into that - but it does seem strange where essentially the same driver downloaded from USA or UK site gives different results. !!

    Marking now as solved as it's working fine on current 19H1 release on a physical machine.

    Solution : Get drivers from US site.

    Cheers
    jimbo
      My ComputerSystem Spec


 

Related Threads
I can't seem to be able to install to the current slow ring cause of this: 2019-03-13 19:34:53, Error CONX 0xd0000034 Failed to add user mode driver My googling didn't yield much info other than knowing it's Paragon...
Solved Epson photo 900 driver for windows 10 in Drivers and Hardware
Hi, I have just joined and this is my 1st thread. I have bought an Epson Stylus Photo 900 printer but cannot find the driver for it on the Epson sites, can anybody out there help please? Thanks, Barnabylad
Hi folks For current drivers for Epson XP-6000 series printers logon to epson US site as the european site one doesn't seem to have decent support page. Windows 10 version works fine. Unusually for Epson they provide Linux drivers too so no...
This latest build will not install on my machine. It downloads and appears to install but on reboot i get an error message saying its ran into problems and rolls back to the previouse build. I have uninstalled malwarebytes and tied to install build...
epson printer driver wont install in Drivers and Hardware
i've updated to windows 10 on my pc and i'm unable to download the driver for my epson sx235w printer to my pc. i've tried the install disc and also via the drivers online. each time it starts to download the drivers it gets stuck on the download...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 00:22.
Find Us