Unusual HDD fault

Page 2 of 3 FirstFirst 123 LastLast
  1. jumanji's Avatar
    Posts : 2,289
    Windows 10 Home 64bit Version 1909
       #11

    @Megahertz,
    You seem to have missed Bree's post at #8
    .

      My Computer

  2. Bree's Avatar
    Posts : 15,378
    10 Home x64 (2004) (10 Pro on 2nd pc)
    Thread Starter
       #12

    jumanji said:
    ... I was scratching my head trying to reason out a cause for this unusual problem.....
    Thanks for your contribution, an interesting read. But if this was puzzling even you then I have no hope of getting to the bottom of this conundrum

    I'll mark this solved for now, but I'll leave the original disk in place and come back if/when it fails again.
      My Computers

  3. Bree's Avatar
    Posts : 15,378
    10 Home x64 (2004) (10 Pro on 2nd pc)
    Thread Starter
       #13

    Postscript:


    It is perhaps serendipitous that this disk played up at this time. In testing it I connected it by usb to another of my machines in order to test it with CrystalDiskInfo. Alarm bells rang

    The alarm bell was for this other machine's own HDD. Its SMART data showed over 300 reallocated sectors. Now, some 12 hours disk use later, that number has grown to 1,568. The use the disk was being put to was taking a Macrium image of it. I'm treating it to a Samsung 860 Evo as a replacement.

    We have a saying here in the UK (not sure if it's used internationally). "You wait all day for a bus, then three come along at once". In all my years I've never had an HDD die on me, today I had two (and am hoping there won't be a third).


    The puzzling HDD (still working, by the way) had recorded 24,148 power-on hours in its SMART data (that's 1,006 days, or nearly three years). A good life for an HDD by any measure. The other terminally failing drive had been powered on for just 7,008 hours.
      My Computers

  4. SoFine409's Avatar
    Posts : 1,084
    Win10 Pro
       #14

    Bree said:
    We have a saying here in the UK (not sure if it's used internationally). "You wait all day for a bus, then three come along at once".
    In fact, that is exactly how Metro busses operate in Washington, DC.
      My Computer

  5. Techymike's Avatar
    Posts : 113
    10 64bit Version 1909
       #15

    I understand this is solved.
    SIW2 , I bought two of the same MB's as my son wanted an upgrade for his birthday. After using all his same modules off his MB, then installing his components on my MB was proof that my MB was bad.
      My Computers

  6. Compumind's Avatar
    Posts : 2,180
    Windows 10 Pro x64, Various Linux Builds, Networking, Storage, Internet Security Specialty.
       #16

    Thermal issue?

      My Computer


  7. Steve C's Avatar
    Posts : 5,274
    Windows 10 Pro 64 bit
       #17

    I suspect BIOS problems. I would remove the laptop's battery if you are able to do so for a few minutes to clear the BIOS then load the BIOS defaults. Change the BIOS settings to what you need after a successful boot. You may also want to reflash the BIOS with the latest version.
      My Computers

  8. jumanji's Avatar
    Posts : 2,289
    Windows 10 Home 64bit Version 1909
       #18

    Mystery demystified or so I would think :)


    After doing some further research on HPA, I am more than ever convinced now that marginally bad sector/s in the HPA/DCO area of the HDD prevents the BIOS from booting. (OK, decades back I had done some research on HPA ( Host Protected Area ) and DCO ( Device Configuration Overlay) but had forgotten all about it since I had had no occasion to use it - I am neither a data recovery professional nor a HDD guru as I have been stamped) My advice in all these forums was limited to restoring hard drive capacity Restoring Factory Hard Drive Capacity where HPA/DCO is involved.

    Now your problem gave me a chance to refresh myself. On my re-research
    "The HPA is useful only if other software or firmware (e.g. BIOS) is able to use it. Software and firmware that are able to use the HPA are referred to as 'HPA aware'. The ATA command that these entities use is called READ NATIVE MAX ADDRESS. This command accesses a register that contains the true size of the hard drive. To use the area, the controlling HPA-aware program changes the value of the register read by IDENTIFY DEVICE to that found in the register read by READ NATIVE MAX ADDRESS. When its operations are complete, the register read by IDENTIFY DEVICE is returned to its original fake value."

    For more Host protected area - Wikipedia

    Most/all OEM PCs incorporate HPA/DCO.

    I now believe that the data returned during the pre-BIOS run is defective ( you always get a beep - in most Desktop PCs - if all connected devices are Ok before you see the visible BIOS run) due to the marginally defective bad sectors in that HPA/DCO area and so the PC/s are unbootable.

    Connect it after the BIOS run, everything is fine. The OS sees and reads the non-HPA/DCO area. CheckDisk runs and sees no bad sectors.Everything is perfect
    .

    Intermittent problems like this can occur in succession or over an unpredictable time interval. ( Intermittent problems by this very nature are difficult to diagnose and require a longtime continuous monitoring or one has to make some intelligent guess to determine the faulty area)

    I will now categorically rule out any controller problem or thermal runaway as causing this problem. Your HDD sure is going bad. The process has started. Now it is only time for eventual total failure. When it will happen is again unpredictable.


    Last edited by jumanji; 04 Jul 2019 at 09:36. Reason: Too many typos. Time to retire ;)
      My Computer

  9. Bree's Avatar
    Posts : 15,378
    10 Home x64 (2004) (10 Pro on 2nd pc)
    Thread Starter
       #19

    jumanji said:
    After doing some further research on HPA, I am more than ever convinced now that marginally bad sector/s in the HPA/DCO area of the HDD prevents the BIOS from booting....

    ...I will now categorically rule out any controller problem or thermal runaway as causing this problem. Your HDD sure is going bad. The process has started. Now it is only time for eventual total failure. When it will happen is again unpredictable.
    Thank you again for your input. It does sound the most likely explanation.

    I now have the luxury of not only Macrium images but also a cloned HDD ready to swap at a moments notice. I am minded to follow HAL9000's advice to "...put the unit back in operation and let it fail. It should then be a simple matter to track down the cause".

    Apart from anything else, I'm intrigued to see just how long I can push this HDD before it falls over. It has already clocked up 24,150 Power On hours, of which 19,211 were Loaded Hours.
      My Computers


  10. Posts : 816
    Windows 10
       #20

    ok here is something i suggest you try since you have spare machines and hard drives , would you bother running HDD Re-generator on all disks showing allocated sectors (might take a day or two to complete) then test them again ? please do not bother debate that this program has bad reviews or being slandered a fake on some forums , just give it a go .
      My Computer


 

Related Threads
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 22:01.
Find Us




Windows 10 Forums