Convert RAID 0 array to regular drives? Solved

Page 1 of 2 12 LastLast
  1.    #1

    Convert RAID 0 array to regular drives?


    After installing Win 10 Pro 64-bit, my internal HDD RAID 0 array began to show an error on one of the 2 drives at start up (Listed as "error occurred" in red text on the screen that usually has all white text on a black screen), and also it's been acting funny, intermittently not letting me open folders and other times acting normal. I don't know whether the drive showing an error is actually bad or if something happened to the RAID controlling software on installing Win 10, but I think I'd like to just convert them to two separate drives, find out if the one drive really is bad, and if so, just replace the bad drive as an individual drive. Could anyone point me in the right direction as to how to go about converting this pair of drives from RAID 0 to two completely separate drives? Also, is there any reason why this might not be the best way to go? Thank you for your help!
      My ComputerSystem Spec

  2. bro67's Avatar
    Posts : 6,495
    Mac OS High Sierra 10.14.3 Beta (18D21c)
       #2

    Back up your install, then take the system out of RAID and then reinstall not as a RAID setup.
      My ComputerSystem Spec

  3. Megahertz's Avatar
    Posts : 278
    Windows 7 HP 64 - Windows 10 Pro
       #3

    First thing to do is to Create a disk image using Macrium Software | Macrium Reflect Free.
    Down load a disk test from the disk manufacture (WD, Seagate has their own) and run on it.
    If your RAID 0 has less free space than a single disk, you will need a bigger disk.
    RAID is a very low level feature.
    Once in Windows it shows as one unique disk.
    Go into BIOS and un Mount the array.
    Set the SATA mode as AHCI.
    Boot from the Macrium rescue disk and restore the image to one of the disks.
      My ComputerSystem Spec

  4.    #4

    Thank you for your reply, Megahertz. I'm sorry, I didn't explain that this isn't a start up drive. My start up drive is an internal SSD, and the drives that are RAID 0 are internal HDDs that I use to work on. I have already backed up the data, so I'm not concerned about the data.
    I downloaded WD Data LifeGuard Diagnostics, and it shows the array as "Intel Raid 0 Volume (SCSI Int)" and SMART Status as Not Available, even though it currently appears to functioning normally. It doesn't show the two drives or any data about them, but I know they're WD drives. The Logical Drive list, the RAID array is listed by it's drive letter, correctly showing total space and free space.
    I think that brings me up to the part of your instructions about resetting the drive in BIOS, after which, I think I'll be able to just reformat them or use them? I don't know from looking at them which drive is the bad one, but at that point, I could use process of elimination by disconnecting one or the other. Is my thinking correct?
      My ComputerSystem Spec

  5. Megahertz's Avatar
    Posts : 278
    Windows 7 HP 64 - Windows 10 Pro
       #5

    I had same problem on a RAID 0 array I had for data.
    I unmounted the array, formatted the drives and ran WD diagnostics. It said the disks were healthy.
    Mounted the array and restored data from a backup. Worked for a while and then same error, so I gave up on using RAID and bought a new disk (WD gold).
    My Windows disk is also a SSD.
      My ComputerSystem Spec

  6.    #6

    Thank you for sharing your experience. That really helps. Are you happy with the WD Gold? I'm deciding what disk to get to replace the bad one.
      My ComputerSystem Spec


  7. Megahertz's Avatar
    Posts : 278
    Windows 7 HP 64 - Windows 10 Pro
       #7

    So far so good.
    I always had fist class HDD (WD Black)
    Gold is a WD Enterprise Class with 128M cache.
    It does make some noise (moving arm) but I think is the best you can buy.
    Western Digital Ultrastar 1TB DC HA210 7200 RPM SATA 6.0Gb/s 3.5" Data Center Internal Hard Drive - 1W10001 - Newegg.com
    The 9 Best SATA Hard Drives of 2019
    Last edited by Megahertz; 15 Jun 2019 at 13:38.
      My ComputerSystem Spec

  8.    #8

    Thanks for the advice :)
    I went into the BIOS, and it wasn't obvious to me where to unmount the array. Might you be able to detail how to do this, or let me know what the menu item might be called in BIOS? Thank you!
      My ComputerSystem Spec

  9. Megahertz's Avatar
    Posts : 278
    Windows 7 HP 64 - Windows 10 Pro
       #9

    As it's an Intel MB it may be iRST (intel rapid storage)
    If you have the RST administration software you can also unmount with it.
      My ComputerSystem Spec

  10.    #10

    I found it in BIOS, but after changing to AHCI, my computer wouldn't start, so I set it back to RAID. Maybe because the start up SSD is in the SATA chain or something, because I see that drive listed at SATA 0, although it's not part of RAID. I guess I'll wait until the manufacturer tech support is open, since they'll know my exact build. But thank you very much for your help! Also, thank you bro67, I didn't notice your post at first. I appreciate both of you for helping out!
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
Solved M.2 NVMe SSDs in Raid 0 array? in Drivers and Hardware
ASRock Z370 Professional Gaming i7 LGA 1151 mobo Samsung 960 PRO M.2 NVME PCIe SSDs M.2 drives in M.2 slots 1 and 3 on mobo Can a RAID 0 array be created with the 2 drives? Is it advisable to do so? (I have learned over the years that...
Hi folks I've been using a server for a few years now running 24/7 (OS on SSD and data on a RAID 0 arrary of 4 X 5 TB HDD's) -- I know if I get a fail I lose the whole array but a lot of data is multi-media etc which isn't changed a lot and I...
Solved Recreating RAID 5 Array AMD in Drivers and Hardware
I updated to Windows 10 Pro with a clean install and had issues with my RAID array showing up as raw format. I was able to take a backup of it from my W7 drive then rebooted into W10 deleted the array in Disk Management, deleted the array in the...
Hi Guys, I had 3 x 2TB drives in RAID 5. Added a 4th 2 TB drive to the Archive R: array and migrated the data using Intel Rapid Storage. Expanded the volume in Disk Managment. But windows doesn't seem to see the new size?.How do I get Windows to...
Having gone from windows 7, to 8 to 8.1 to 10 without a reinstall I've started to have a few issues so I've just reinstalled windows to a new drive. Trouble is, I didn't think too much and left the old RAID array connected so the recovery and EFI...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 15:23.
Find Us