Lenovo X380 Fingerprint reader showing "disconnected": any fixes?

  1.    #1

    Lenovo X380 Fingerprint reader showing "disconnected": any fixes?


    Here's my situation. I've got a Lenovo X380 Yoga with a built-in fingerprint reader. After recent Windows updates, the fingerprint reader disappeared. After digging into DevMgr, I find that this Biometric device is only viewable when I click the "Show hidden devices" option, and it shows the following status when I do that:
    Click image for larger version. 

Name:	image.png 
Views:	1 
Size:	72.1 KB 
ID:	234179
    I've tried updating/reinstalling the drivers (and the Intel SGX device that bridges from the peripherals bus to the system circuitry apparently) and the status remains disconnected. I have not even moved the machine around much since I got it about six weeks ago. I'm inclined to believe that the fingerprint reader has failed. Can anyone offer an alternate diagnosis or a different repair strategy?

    TIA for your input and suggestions.

    --Ed--

    PS: the unit is under warranty and I can ship it back to Lenovo for repair and diagnosis for the cost of shipment. Curiously that's about the same cost as that for purchasing a new replacement fingerprint reader. I'm wondering further if I shouldn't just order a replacement and do the repair myself. Thoughts?
      My ComputersSystem Spec

  2.    #2

    Here's a Lenovo forums post that confirms my suspicions:
    Click image for larger version. 

Name:	image.png 
Views:	1 
Size:	121.8 KB 
ID:	234182
    Unless somebody has other ideas, I think I know what I need to do next. Again: please share your thoughts and suggestions.
    TIA,
    --Ed--
      My ComputersSystem Spec

  3. Callender's Avatar
    Posts : 1,338
    Windows 10 Home 1809 32-bit
       #3

    If you have a Macrium Reflect system image backup mount it and use Device Manager to update driver but choose to install by browsing your system image backup for the driver.
      My ComputerSystem Spec


 

Related Threads
So, I've got a Computer with GT630. I've installed windows 10 and I tried installing the drivers for my Nvidia GT630, and it gave me an error that says I don't have an NVIDIA GPU. I've used DXDIAG to look at my specifications and it showed me...
I am getting weird problem where random popup windows about "The directory name is invalid" for many of the drives from my external USB card reader These drives error messages are related to my external USB card reader which does not currently...
Hello everybody I have a Lenovo W540 laptop (i7, 32GB, FPR sensor, Pantone colorimeter) and I just upgraded to Windows 10. In Hello setup I created PIN and then I tried to create fingerprint. (Accounts / Sign-in Options) When I click "Set...
My hard drive not showing in "my computer" or "Disk Management" but is showing under device manager. I got the hard drive from a friend and his dad had put a Password encryption on it. Any Ideas?
Every night I turn my computer off using the shut down function, and most mornings I wake up to find it is on. I have tried to fix this by finding out what programs are turning it on in command prompt. When I type, powercfg -lastwake I get: ...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 03:22.
Find Us