NVME wont link up at pcie x4 speeds, only at pcie x2 speed


  1. Posts : 1,168
    win10 PRO on 5 PC's and Linux mint
       #1

    NVME wont link up at pcie x4 speeds, only at pcie x2 speed


    Device is x4 capable. But it seems this notebook only allocates 2 pcie lanes to the nvme slot. Which cuts the maximum read write times to 1729 mb/s and 1628 mb/sec according to crystal disk info. Otherwise would be close to double those speeds. But practically i dont notice it being slow, boots in about 6 seconds max.
    Of course when i ran the speed read - write test and noticed it was half my expectation I went looking for a reason, and I think I found out why.

    hwinfo screen shot shows the link up speed. I updated bios, but there is no speed setting.
    Notebook is Asus q525ua and seems decent, its not the greatest, but its still good enough.
    Any thoughts on this?
    Attached Thumbnails Attached Thumbnails NVME wont link up at pcie x4 speeds, only at pcie x2 speed-nvme-1.png   NVME wont link up at pcie x4 speeds, only at pcie x2 speed-cdm-1-500-wd.png   NVME wont link up at pcie x4 speeds, only at pcie x2 speed-wdc-2.png  
      My Computer

  2. Clintlgm's Avatar
    Posts : 1,096
    Win 10 pro Upgraded from 8.1
       #2

    yes last generation had only 2 lanes, later higher end models have 4 lanes you'll find that in your user manual.
      My Computers


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 18:56.
Find Us




Windows 10 Forums