Windows 10: Intel RST, RAID and Write Cache Settings

  1.    05 Aug 2015 #1

    Intel RST, RAID and Write Cache Settings

    I upgraded to Win 10 from 8.1 with RST version I have two RAID arrays on the Intel MB controller, a 2-SSD RAID 0 for the system and a 4-SSD RAID 10 for data. I sometimes experienced system freezing when mucking with the write cache settings in the RST app, but otherwise worked fine.

    I recently updated to the new generic on the Intel site (not the previously available one for NUC), which has been working fine for a couple of days surviving several restarts and hibernations. I had a freeze during restart again after playing with the caching mode, but after resetting the system came up with no problems.

    I noticed that the write caching setting in the device manager disk properties does not match the setting I have in the RST app. Windows says write caching is on but I have it turned off in RST. Buffer flushing is enabled.

    Anybody know if these two settings are for different aspects of the caching mode, are they not mutually exclusive with the device-level taking precedence, or is this a buggy conflict which mighty explain the occasional weirdness? For now I'm leaving caching off, as it still runs nicely quick.
      My ComputerSystem Spec

  2.    05 Aug 2015 #2

    Windows write caching and intels are two different beasts. The Windows setting enables write caching in the drive itself. The Intel were caching is done uses system memory at the is level.
      My ComputerSystem Spec

  3.    05 Aug 2015 #3

    Thanks, Geneo. So Windows is managing the caching on the individual drives in the RAID array, while the RST app manages the caching on the RAID array itself. That makes perfect sense. Sounds like the weirdness is probably an early release feature of RST.

    Has anybody else experienced this?
      My ComputerSystem Spec


Related Threads
Solved Recreating RAID 5 Array AMD in Drivers and Hardware
I updated to Windows 10 Pro with a clean install and had issues with my RAID array showing up as raw format. I was able to take a backup of it from my W7 drive then rebooted into W10 deleted the array in Disk Management, deleted the array in the...
Hi, I have a PC with Asus P9X79 Deluxe motherboard. It has Intel chipset and Intel BIOS RAID (RSTe) and 6 SATA ports connected to it. The chipset IDE controller lists in Linux as: Intel Corporation C600/X79 series chipset SATA RAID Controller...
I used the upgrade tool to install w10x64. Installation went fine, I can use my computer and all. Problem is that both of my LAN ports don't work. I get the usual red icon in the taskbar that shows no internet. I went into networking and it doesn't...
I use an old kvm switch without active ddc so I am always having to open screen resolution settings and click detect. I would like to make a script file and then a shortcut to the file to do this for me but I have never written a script and can't...
1 SSD or 2 SSD RAID-0 in Drivers and Hardware
In preparation for Windows 10 I plan on completely resetting my hard drive configuration since I currently have it spanning four hard drives. Right now my OS sits on a 128GB SSD while all the programs, games, photos, family videos, etc. sit on a...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 20:17.
Find Us