Windows 10: CPU Running High Freq... Constantly??

  1.    04 Aug 2015 #1

    CPU Running High Freq... Constantly??


    Since installing 10, my CPU seems to be running ~130% frequency continuously. This isn't necessarily awful, but it is running my temps ~18°C higher than idle should be (mid 50s vs high 30s). Checked power options, all is as it should be. CPU utilization is around 2% at idle.

    Thoughts?
      My ComputerSystem Spec

  2.    04 Aug 2015 #2

    Are you in the insider program ?
      My ComputersSystem Spec

  3.    04 Aug 2015 #3

    If you are, go to the feedback section > Categories > Power and Battery > Overheating.

    You will see lot's of complaint's like yours. High CPU usage, fan's running on high and battery draining at a fast rate.

    My lappy is also doing some of this.

    Hopefully M$ will come out with a update for this.
      My ComputersSystem Spec

  4.    04 Aug 2015 #4

    COMPUTIAC said: View Post
    If you are, go to the feedback section > Categories > Power and Battery > Overheating.

    You will see lot's of complaint's like yours. High CPU usage, fan's running on high and battery draining at a fast rate.

    My lappy is also doing some of this.

    Hopefully M$ will come out with a update for this.
    Not sure what the insider program is. The CPU usage itself isn't high; it's just running high freq all the time. Again, I don't mind so much but it's just another annoyance on top of my laggy boot.

    Hopefully... Hopefully...
      My ComputerSystem Spec

  5.    04 Aug 2015 #5

    I looked again in the insider program and some said Edge was causing problem's also.
    Are you using Edge at all ?
      My ComputersSystem Spec


  6. Posts : 4,333
    Win 10 Pro x64
       04 Aug 2015 #6

    kbronski said: View Post
    Not sure what the insider program is. The CPU usage itself isn't high; it's just running high freq all the time. Again, I don't mind so much but it's just another annoyance on top of my laggy boot.

    Hopefully... Hopefully...

    What CPU and motherboard is that? Turbo was probably enabled after the upgrade ( if it applies to your system).
      My ComputerSystem Spec

  7.    04 Aug 2015 #7

    COMPUTIAC said: View Post
    I looked again in the insider program and some said Edge was causing problem's also.
    Are you using Edge at all ?
    Nah. The only native app I've tried is Groove, but I didn't care for it.

    badrobot said: View Post
    What CPU and motherboard is that? Turbo was probably enabled after the upgrade ( if it applies to your system).
    See system specs in signature.
      My ComputerSystem Spec


 

Related Threads
Hi I've just installed windows 10 on my laptop. Initially a box on the left hand side telling me about cortana kept popping up so I switched cortanat off. Now the box just keeps popping up constantly, asking me to start typing to search the web...
How to stop "Runtime Broker" from running constantly in the background. Running win 10 Home 32 bit upgraded from Win 7 Home Premium
Yesterday I upgraded my PC from Windows 7 to windows 10, and today I started having problems running games where everything was getting very hitchy. I checked my memory and CPU usage and noticed that my memory is now constantly at 90% or greater....
I upgraded to Windows 10 from Windows 7. Now Onedrive will not sync new files to the cloud. In addition the Cloud icon is constantly "looking for changes".
Hi, doesn't matter if it's IE or Opera. I never had this problem until after updating to the preview yesterday. Anyone else? Is there some kind of fix? I even get it on this site when refreshing or changing pages, sometime a refresh works and...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Š Designer Media Ltd
All times are GMT -5. The time now is 07:47.
Find Us