Safely Remove Hardware and Eject Media not working

Page 2 of 3 FirstFirst 123 LastLast
  1. FunkMaster's Avatar
    Posts : 183
    Windows 10 Home
    Thread Starter
       #11

    Looks like it is not there. I wonder if I should chance Installing it? Doesn't even seem that I need it with my current build? I am completely up-to-date with my 1809
    PS C:\Users\Work7> get-hotfix


    Source Description HotFixID InstalledBy InstalledOn
    ------ ----------- -------- ----------- -----------
    DESKTOP-TH... Update KB4486553 NT AUTHORITY\SYSTEM 3/20/2019 12:00:00 AM
    DESKTOP-TH... Security Update KB4470788 NT AUTHORITY\SYSTEM 1/23/2019 12:00:00 AM
    DESKTOP-TH... Update KB4480056 NT AUTHORITY\SYSTEM 1/23/2019 12:00:00 AM
    DESKTOP-TH... Security Update KB4487038 NT AUTHORITY\SYSTEM 2/13/2019 12:00:00 AM
    DESKTOP-TH... Security Update KB4489907 NT AUTHORITY\SYSTEM 3/12/2019 12:00:00 AM
    DESKTOP-TH... Security Update KB4489899 NT AUTHORITY\SYSTEM 3/12/2019 12:00:00 AM
      My Computer

  2. FunkMaster's Avatar
    Posts : 183
    Windows 10 Home
    Thread Starter
       #12

    KB4476976 Is associated with an older Build, so I don't know why I would need it, and worried it will cause me more problems than it is worth? It also does not say that it solves this issue, but why would MS be so nice to tell us anything is beyond me.

    https://support.microsoft.com/en-us/...date-kb4476976
      My Computer

  3. FunkMaster's Avatar
    Posts : 183
    Windows 10 Home
    Thread Starter
       #13

    I see now what was going on, but don't know why, and still don't understand how, why, or who would design such a cluster of an OS, that makes everything so hard to find and fix. Things that should really be more clear.

    I ended up doing the same thing again, kinda. I finally saw that there was a Notification stuck and "Focus assist" needed to be Turned Off again from Notifications. Weird, I'll need to keep an eye on this in the future.
      My Computer

  4. Callender's Avatar
    Posts : 2,889
    Windows 10 Home 1903 64-bit
       #14

    From Admin Powershell

    get-hotfix -id KB4476976

    Safely Remove Hardware and Eject Media not working-get-hotfix-id-kb4476976.jpg

    Microsoft Update Catalog

    To install.
    Open an elevated command prompt.Type the following command:wusa.exe "C:\Full Path To.msu"

    Replace

    C:\Full Path To

    in the above command with the full path to the downloaded .msu file.
      My Computer

  5. Callender's Avatar
    Posts : 2,889
    Windows 10 Home 1903 64-bit
       #15

    Ignore that. If you've got the latest cumulative update - it would include earlier fixes.
      My Computer

  6. Callender's Avatar
    Posts : 2,889
    Windows 10 Home 1903 64-bit
       #16
      My Computer



  7. Posts : 32,877
    windows 10 professional version 1607 build 14393.969 64 bit
       #17

    What had happened with the in place upgrade repair?

    Download Windows 10 ISO File | Tutorials
    Download Windows 10
    Repair Install Windows 10 with an In-place Upgrade | Tutorials

    If the in place upgrade repair fixes the underlying problems then you are set.
    If the in place upgrade repair fails to fix the underlying problems then they are likely in the registry.
    Then repeating the in place upgrade repair with Windows 1903 should fix registry problems.
      My Computer

  8. FunkMaster's Avatar
    Posts : 183
    Windows 10 Home
    Thread Starter
       #18

    Callender said:
    Ignore that. If you've got the latest cumulative update - it would include earlier fixes.
    That's the way I took it too Callender, and all is fixed now. Just a lack of Windows 10 knowledge on my part. I don't use it all that much to be honest, use Windows 7 more. I like W10 on my i5, with 16GB of RAM for sure, but it's a little ADD for me lol. I can never find what I'm looking for in that mess of windows.

    zbook, I will try that also if this persists.
      My Computer

  9. FunkMaster's Avatar
    Posts : 183
    Windows 10 Home
    Thread Starter
       #19

    Here's the answer guys:
    https://support.microsoft.com/en-us/...external-media

    The Policy changed but I didn't know about it. Once I removed the Notifications it worked fine, but Performance was not Enabled, and I wan't performance! haha
      My Computer

  10. Brink's Avatar
    Posts : 49,694
    64-bit Windows 10 Pro for Workstations build 20161
       #20
      My Computers


 

Related Threads
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 00:41.
Find Us




Windows 10 Forums