JMB38X SD/MMC Host Controller - Win 10 driver needed Solved

Page 4 of 4 FirstFirst ... 234
  1.    28 Jan 2018 #31

    HBHB said: View Post
    sorry for the delay,this package installed fine on my asus lappy
    I know that I'm necroing an old post, just wanted to say my thanks! This worked for me as well.
      My ComputerSystem Spec

  2.    29 Jan 2018 #32

    And HP still remains problematic!
      My ComputerSystem Spec

  3.    05 Feb 2018 #33

    Thanks for the driver
      My ComputerSystem Spec

  4.    05 Feb 2018 #34

    Glad this is of help
      My ComputerSystem Spec

  5.    24 Aug 2018 #35

    Spent about an hour surfing and trying to find this driver or help figuring it out! thank you!
      My ComputerSystem Spec

  6. jimbo45's Avatar
    Posts : 6,352
    Windows / Linux : Centos, Ubuntu, OpenSuse
       25 Aug 2018 #36

    Hi folks

    If you run into this sort of problem again you can do what I suggested in another post using the device manager-->properties-->events This will lead to the actual hardware id of the piece of kit itself and you can then google for that exact driver

    Read my post in this thread should be post #5 screen shot shows what I mean.

    Forget the Driverpack solutions solution - just read the post.

    DriverPack Solutions is NOT a solution - Windows 10 Forums

      My ComputerSystem Spec

  7.    25 Aug 2018 #37

    Another good source for device drivers is the French website Here's their link to the JMB38X WHQL driver: JMB38x Card Reader Controller.
      My ComputersSystem Spec

  8.    20 Sep 2018 #38

    Thanks so much ..worked on a Sony vaio upgraded from 7 to 10
      My ComputerSystem Spec

Page 4 of 4 FirstFirst ... 234

Related Threads
Solved SM Bus Controller Driver in Drivers and Hardware
I have a driver problem with SM Bus Controller with the driver not being correctly installed, but how do I find out what are the details I need to update the driver. I need to know the manufacturer (I think) and Model (I think) but how do I find...
I have a gigabyte GA-Z77X-UD3H which uses the via chipset for USB (VIA VL800 chip) I have an error in system device for Usb xHCI Compliant host controller I am just wondering what drivers I can use for this? Also I didn't load any other...
Okay, I upgraded from Windows 7 64Bit to windows 10 Home 64bit. Everything ran smooth and fine. I first get into windows (after the "Hi" screen and setting up apps screen) and I see my desktop. I install the latest video drivers first thing. I go...
I have a Broadcom NetXtreme 57xx Gigabit Controller but does not work in Windows 10 i use the latest driver version from Broadcom i got error: Broadcom NetXtreme 57xx Gigabit Controller: Driver initialization failed. bron:b57nd60x id...
I have a Aśus Maximus V Gene mob that has two Sata mob inputs not controlled by the Intel Sata driver. I am having difficulty installing the latest Asmedia driver downloaded from the Aśus support site. With Win 7 there isn't a problem, but win 10 TP...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 15:18.
Find Us