Dual boot: chkdsk errors & missing files when writing to shared slave


  1. Posts : 2
    Windows 10
       #1

    Dual boot: chkdsk errors & missing files when writing to shared slave


    So I am dual-booting between two physical drives: A host drive with Windows10 1803 (SSD/GPT), and a host drive with Windows10 1607 (HDD/MBR). The 1803 is a fresh install via M$ Creation Tool, and the 1607 is my daily driver. I have a SSD/GPT slave shared among the two for data storage. I dual boot by only connecting the SATA0 cable to the host drive I intend to boot from (I never have both connected to the system at once).

    Here's what's going on: When I boot from one Windows10, write/delete files to the slave, then boot up using the other Windows10, some or all the files I just copied are missing. This only happens when accessing the drive from the other OS, if I reboot using the same OS after writing to the slave, everything is there.

    All drives pass SMART, show no error values/counts in the SMART data, benchmark as expected, and otherwise exhibit no problems.

    Other details:
    • System host drives never have problems with data or corruption, problem seems isolated to a shared slave. It does not seem to matter which drive I use as the slave, and at least once I observed it occur on my external WD Passport (usb3, mbr) when using it as shared storage for the dual boot.
    • Wiping/reformatting the slave does not solve the problem.
    • Sometimes when files do show up, some will prompt me for Admin privileges when accessing. If I look at the permissions, they have no owner (says something similar to owner cannot be determined).
    • Chkdsk will usually find filesystem errors, typically being index errors (missing/unused/mismatched etc), but I've also seen security descriptor errors, index pointers to files beyond mft, bitmap errors, and free space marked allocated.
    • At one point, I modified a text file's content, and upon booting into the other Windows, only the old file contents were visible as if I had done nothing.
    • If I do not allow chkdsk to make fixes and I reboot with a WinPE thumbdrive, the missing files in question are clearly visible and readable. I can also copy anything I want to the slave using WinPE and the files show up just fine in the other OS's

    I haven't had much luck googling, as most results pertain to people who hibernate between dual boots or don't shut down properly. It really does feel like that tho, except I do not hibernate and always shut down through Windows before dual booting. Event manager shows no log of unexpected power loss either.

    I've just tried disabling search indexing & fast boot from both Windows versions, and for the past couple of dual boots I haven't seen it happen again... Don't know yet if that fixed it or if this is just by chance.

    Any ideas?
    Last edited by shortbit; 13 Nov 2018 at 21:25.
      My Computer


  2. Posts : 2
    Windows 10
    Thread Starter
       #2

    I guess I can't edit a post when it's too old. Anyway just in case anyone comes across this, I'm a dummy. Fast boot was ultimately the culprit due to how it caches/schedules writes. Had to disable it on both OS's to get rid of the problem.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 08:27.
Find Us




Windows 10 Forums