USB ports not detected Gigabyte Z370 hd3

Page 1 of 2 12 LastLast

  1. Posts : 12
    Windows 10 64
       #1

    USB ports not detected Gigabyte Z370 hd3


    I have a custom pc I built a few months ago; had a prior issue with the onboard Lan not being functional d/t a driver problem; I bought a usb ethernet adapter, which allowed internet access and the pc was functioning normally, including all usb ports 3 days ago.

    I had 2 drives on the pc; one for daily/ productivity apps with Linux; and one with Windows 10 for gaming; each drive had own boot manager and I would use Bios to change bootable drive when switching from one to the other.

    3 days ago I had been using the Linux drive, and logged out, intending to switch to the Windows drive and do some gaming. Something happened during Linux shutdown as I was pressing the delete key to bring up the Bios menu, and I had to do a hard reset to get into Bios.

    Ever since then, whenever I boot into either Operating system, all usb ports are non functioning, including the above mentioned usb ethernet adapter, which means I can't get online either.

    At first I thought issue was software related and tried the usual fixes, including among other things updating the Bios and resetting Cmos by removing battery; but finally realized that the problem persisted with my usb mouse and keyboard even in the Bios menu itself, which seemed to indicate the problem was a hardware failure rather than a software issue.

    Since I built the machine for gaming, a motherboard without usb functionality is nearly useless and I suspect I need to get a new motherboard. But before spending money on a new board, I thought I should check with wiser heads than my own and see if there is any way to reset motherboard usb ports with hardware failure and get them working again.

    Sorry for the long explanation; any suggestions appreciated
      My Computer


  2. Posts : 810
    Win10
       #2

    When you unplugged the system and removed the CMOS battery, how long did you leave it removed?

    Does the USB controller (Intel USB 3.0 eXtensible Host Controller) show up in Device Manager? Can you run USB Device Tree Viewer and attach the output of File->Save full report?
      My Computer


  3. Posts : 12
    Windows 10 64
    Thread Starter
       #3

    PolarNettles,

    Thanks for the reply.

    I left the cmos battery out for around 4 minutes or so.

    In the Windows o/s, device manager, ever since the problem originally occurred, I have only one controller, the USBxHCI Host Controller- no other generic, hub or root controller show up at all.

    The Usbxhci shows in device manager with a yellow warning flag- and when right clicked, gives a code 10 device cannot start error. Tried multiple times disabling or uninstalling it and trying to reinstall that driver.

    I have a working Windows 10 laptop that had a newer usbxhci driver than the one on the affected machine; tried copying the dll, inf and sys files for that driver over to the affected machine, but it would not install. And every time I reboot after uninstalling the faulty driver, Windows simply autodetects it again, with the same code 10 warning.
    USB ports not detected Gigabyte Z370 hd3 Attached Files
      My Computer


  4. Posts : 810
    Win10
       #4

    Does Linux show any error messages when it tries to initialize the controller?
      My Computer


  5. Posts : 12
    Windows 10 64
    Thread Starter
       #5

    Polar Nettles


    Yes, but I'm not sure they're helpful. Back before I realized that the usb ports weren't working in Bios and I thought that the faults might be software related, I deleted the original Linux o/s that I had, which had just been backed up recently, thinking that a fresh o/s install might pickup the correct drivers.

    The linux o/s is on a 250gb ssd, the original system was Ubuntu based- Linux Mint 19. When attempting to do a fresh install, I reformatted the drive and tried to reinstall Mint again; but got a message that install could not continue without working internet connection. I downloaded a different Linux distro just to test whether that would give the correct drivers, and successfully installed Manjaro 17, which is Arch based.

    When I run hardware detection, I get message 'No Installed USB configs!'

    Using the Bash terminal and running the lsusb command returns nothing, as no usb devices are detected, though the usb mouse, a known working usb flash drive and the usb network adapter are all plugged in to ports that were working prior to the original crash.
      My Computer


  6. Posts : 810
    Win10
       #6

    How about the output of dmesg | grep -i -E "(usb|hci)"

    Have you tried unplugging all USB devices - including the front panel connector on the motherboard?
      My Computer


  7. Posts : 12
    Windows 10 64
    Thread Starter
       #7

    Polar Nettles


    I'm afraid that I'm much more adept at Windows command line usage from the old DOS days than with Bash shell. It's probably a syntax error on my part, but I couldn't get the command you gave me to work.

    I tried egrep -i and it returned the following:

    usbcore: registered new interface driver hub
    usbcore: registered new device driver usb
    xhci_hcd 0000:00:14.0: xHCI Host Controller
    xhci_hcd 0000:00:14.0: new USB bus registered, assigned bus number 1

    xhci_hcd 0000:00:14.0: can't setup: -110
    xhci_hcd 0000:00:14.0: USB bus 1 deregistered
    xhci_hcd 0000:00:14.0: init 0000:00:14.0 fail, -110
    xhci_hcd 0000:00:14.0 probe of 0000:00:14.0 failed with error -110

    I had previously tried in both Windows and Linux unplugging all usb peripherals and rebooting, and in Windows had tried also disconnecting motherboard usb cables, but had not tried that in Linux.

    I unplugged all usb devices, disconnected the main usb cable and front panel connector from motherboard, and rebooted into Linux, then ran egrep again for the same string- the resulting output was same as above.

    Right now I have an old ps2 keyboard, and with mouse keys it allows slow navigation in both Windows and Linux. PCI and Sata connections still work- only way I have to transfer files between affected pc and working laptop is via sata connected spare ssd drive.

    It is somewhat off topic, but I have three old add on cards; one with ethernet, one with a wireless antenna and one with extra usb 2.0 ports, but they are all for older full size pci connections not pci express. I don't have a pci express to pci adapter card.

    But even if the additional ports card was the right size, I don't think the usb ports on it would work without a functioning usb host controller at the software level- correct?
      My Computer


  8. Posts : 810
    Win10
       #8

    Error -110 indicates some sort of timeout with the controller. At this point I'd start looking at getting a warranty replacement.

    Just to make sure, you can try disconnecting absolutely everything from the motherboard except power, video cable, and power switch. Then clear CMOS again and see if the USB keyboard works in the BIOS.
      My Computer


  9. Posts : 12
    Windows 10 64
    Thread Starter
       #9

    Polar Nettles


    I'll try that as a last resort before giving up, but it seems as though I managed to brick a new motherboard within 2 months, which is pretty much what I had feared.

    Thank you so much for your assistance!

    One last question, though it may belong in another forum group- if I replace only the motherboard (since the cpu is still working), does my Windows license cover re-activation, or do I need to buy another license? I used a Windows 10 Pro _64 OEM physical disc to install/activate the o/s on the existing system.
      My Computer


  10. Posts : 38,347
    windows 10 professional version 1607 build 14393.969 64 bit
       #10

    1) See this Microsoft link for a major hardware change:
    https://support.microsoft.com/en-us/...ardware-change

    2) As a backup strategy create a Microsoft account if you do not already have one and see this link:
    Activation troubleshooting - Windows 10 Forums

    3) Run the BETA log collector and post a zip into this thread:
    There are two log collectors: DM and BETA.
    The BETA log collector will replace the DM log collector and collects more useful folders and files.
    The BETA log collector link is in the lower half of this web page:
    BSOD - Posting Instructions - Windows 10 Forums
    https://www.tenforums.com/attachment...-v2-beta15.zip
    (extract all > open)
      My Computer


 
Page 1 of 2 12 LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 21:59.
Find Us




Windows 10 Forums