"Hot swap" does not work


  1. Posts : 12
    Windows 10 Home
       #1

    "Hot swap" does not work


    Hello
    I built a new PC with Windows 10 - 64 Bits
    For the hard drives, I use "extractable racks", so I could change the data disks when needed (thats what I hoed, as it worked fine on the previous Windows 7 PC)
    But, it seems this does not work
    If I boot the system with some choosen disks, it works fine, but when I remove some of them and replace them with different disks, they are not recognized

    In order to get access to the "new" disks, i have to close the system, change the disks and reboot

    Is that normal ? Did I forget to tweak some parameters ?

    Thanks for any help Have a good day
      My Computer


  2. Posts : 2,790
    Linux Mint 20.1 Win10Prox64
       #2

    Access the BIOS then set the option to enable Hot Swap on the Sata port connected to the removable rack.
      My Computer


  3. Posts : 7,710
    3-Win-7Prox64 3-Win10Prox64 3-LinuxMint20.2
       #3

    Hi,
    Not sure if it applies here but win-10 does auto mount disks/ drives...
    So if you haven't changed that I ran across @Brinks tutorial a little while back
    Enable or Disable Automount of New Disks and Drives in Windows | Windows 10 Tutorials
      My Computers


  4. Posts : 12
    Windows 10 Home
    Thread Starter
       #4

    Thanks for the answers
    Sorry to be late, but I've been out of home
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 06:22.
Find Us




Windows 10 Forums