Doubt about "Safely remove hardware" icon.

  1. Ghost82's Avatar
    Posts : 197
    Windows 10 Pro x64
       #1

    Doubt about "Safely remove hardware" icon.


    Hi everyone.

    A few months ago I had this problem. My "safely remove hardware" icon was missing. Some members tryed to help and, somehow, I figured out to solve that uninstalling USB devices.

    Well, since October Update 2018 this happened again. That icon is missing... BUT, its behaviour is different and that makes me doubt about it all. Let me explain. The icon, when I have not any USB device plugged, is not showing, but once I plug one into my USB ports, then appears. As long as I safely remove it, it dissapears.

    It's surprising because the configuration of my systray is exactly the same than before, so the icon should be visible in any situation, no matter if I have any USB device plugged in or not. So I've tryed every sollution that was posted at that thread, but nothing works.

    So here's my question: how it's supposed this icon has to behave? Has to be visible with and without external USB devices plugged in, or it only has to be there when you plug one of those?

    Thanks in advance!
      My Computer

  2. dalchina's Avatar
    Posts : 29,832
    Win 10 Pro (1903)
       #2

    I would only expect it to be present when there are devices that can be removed.

    If you are continually concerned about this, you may wish to try one of the 3rd party safely remove tools.
      My Computers

  3. Ghost82's Avatar
    Posts : 197
    Windows 10 Pro x64
    Thread Starter
       #3

    dalchina said:
    I would only expect it to be present when there are devices that can be removed.

    If you are continually concerned about this, you may wish to try one of the 3rd party safely remove tools.
    Thank you, dalchina.

    Well, I'm not that concerned, hehe. It's only that I didn't understood why it always was shown, no matter if there was any USB device plugged in, and why now it only shows when there's a USB device plugged in. That's what made me wonder how it's supposed to behave.

    If this is not a 'real' problem, I'm fine. I suspect that there's something to do with the smart card reader. Depending on how the system detects it, it can be 'activating' the icon or not.
      My Computer


  4. Posts : 668
    Win 10 pro
       #4

    Ghost82 said:
    So here's my question: how it's supposed this icon has to behave? Has to be visible with and without external USB devices plugged in, or it only has to be there when you plug one of those?

    Thanks in advance!
    I have win 8.1 and there is no icon with no external drive, so it seems totally normal behaviour to me.
      My Computer

  5. dalchina's Avatar
    Posts : 29,832
    Win 10 Pro (1903)
       #5

    Seems as though it's working properly to me too...
      My Computers

  6. Bastet's Avatar
    Posts : 1,711
    Windows 10 Pro 64bit
       #6

    The icon only appears on my Win 10 1809 when I have a USB device plugged in.
      My Computer

  7. Ghost82's Avatar
    Posts : 197
    Windows 10 Pro x64
    Thread Starter
       #7

    Alight then! So everything is OK!

    Thank you all :)
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 21:04.
Find Us




Windows 10 Forums