Installing Win 10 Update 1803 creates fictitious “Unknown Device"

  1. Posts : 1
    Windows 10 Home

    Installing Win 10 Update 1803 creates fictitious “Unknown Device"

    My (Dell XPS 8920) computer operated perfectly before installing Win 10 Home feature update 1803 but after installing it a fictitious (no physical existence) Unknown Device appeared on the Device Manager list, located on the (single) USB 3.1 port which, as a result, becomes unusable.

    Initially, update 1803 was installed automatically by Windows Update. But after the update I noticed that a (HP Laserjet 1018) printer connected to the USB 3.1 port no longer worked . Investigation revealed the appearance of this Unknown Device. I rolled back update 1803 to prior Windows version 1709 and the problem disappeared. My printer worked fine again. I then reinstalled update 1803 and voila, the Unknown Device reappeared and my printer no longer worked.

    The Unknown Device is listed on Device Manager under a new heading “Other Devices”. It is located on USB 3.1 Port (ASMedia USB3.1 eXtensible Host Controller) which, according to the relevant entry in the USB section of the Device Manager, is “working properly”. So the problem appears to be not the USB 3.1 port itself, but the fictitious “Unknown Device” that Update 1803 thinks is connected to it. Device Status for the Unknown Device provides this not very useful information:

    - The drivers for this device are not installed. (Code 28)
    - There are no compatible drivers for this device.
    - To find a driver for this device, click Update Driver.

    Clicking Update Driver produces no result; nothing is updated.

    In Details, The unknown device Value is USB\ASMEDIAROOT_HUB\5&1E39D504&0&0a and Hardware IDs are (also not very helpfully) as follows:

    - USB\ASMEDIAROOT_Hub&VID1B21&PID1242&VER0001001600420001

    “Problem Code” (whatever that means) is 0000001C.

    If I uninstall or remove the Unknown Device from Device Manager or Start/Settings/Devices/Bluetooth and other devices, things do not improve, as each time the machine is restarted the uninstalled/removed Unknown Device reappears and the port remains unusable.

    Repeated attempts to install 1803 produced the same result. Also the Unknown Device is clearly not a physical device and it is not a matter of installing a missing or outdated driver for a physical device connected to the computer, as it made no difference whether or not a physical device was connected to the USB 3.1 port at the time the 1803 reinstall was done. For the last attempt I disconnected all physical devices from the computer and still got the same result. All other USB ports (2.0 and 3.0) work fine.

    I get the same problem whatever method is used to install 1803. Thinking it could be in some way due to a problem within the Windows Update process I reinstalled 1803 using Microsoft’s “Media Creation Tool 1803” but again got the same result.

    Googling the problem and the arcane diagnostic messages mentioned above produced no helpful hints so eventually I called Dell support as the machine is still under warranty. After an unfruitful half hour involving firstly one agent who showed no interest and after a short while left the phone not to return, and a second agent who was more helpful, I learned that Dell General Support could not help because Dell XPS has its own separate department and support organization and he connected me to it. After a lengthy wait I was connected to an XPS department agent who ran a number of standard (Dell) diagnostic tools that I regularly run myself, with no result. After a half hour or so he left to consult with a colleague. When he returned he reinstalled/repaired several drivers already installed on the machine but with no positive result. Finally, after about an hour, he concluded that the problem is a hardware issue in the motherboard, which requires replacement. He ordered one and told me a technician would come to install it in the next day or so.

    So it now remains to be seen whether a new motherboard will solve the problem. I have no technical expertise myself so must assume Dell technicians know whereof they speak. However in the back of my mind a sceptical thought remains. If the computer worked perfectly with update 1709 why/how would a software update create a hardware problem, that disappears when the software update is rolled back? Time will tell, but I am posting this story to see if any tech savvy folks out there have any other ideas, and maybe to save some time for anyone else who may have encountered a similar experience.
      My Computer

  2. dalchina's Avatar
    Posts : 33,776
    Win 10 Pro (1903) (2nd PC is 21H2)

    Access Denied
    - definitely rated as tested with 1803...
    (The link has been allocated a strange name but works for me- Dell site)
      My Computers

  3. Posts : 482
    Windows 10 Home

    There is an Asmedia USB driver on the Dell site for that computer. You may have to click "View more" at the bottom to see it.

    Access Denied

      My Computer


  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 16:08.
Find Us

Windows 10 Forums