USB Keyboard/Mouse Fails when USB 3.0 Hub Installed in Adjacent Port

  1.    12 Aug 2018 #1

    USB Keyboard/Mouse Fails when USB 3.0 Hub Installed in Adjacent Port


    I'm not sure what the issue is...just started now...but I may just have noticed it now:

    - I just moved and set up my computer in the new home. I'm not sure if I installed USB devices in same places they were at previous home but, regardless, I've encountered an issue with a Microsoft Keyboard/Mouse USB combo when my Anker 7-port USB 3 hub is installed in the adjacent port. As follows:

    - When both are installed and active, no issues until I plug in an external USB hard drive. Then the mouse and keyboard freeze until the drive is unplugged. Then everything returns to normal. Some devices installed on the hub (e.g. BT adapter) don't interfere at all.
    - My mothernoard (Asus Z270-A) has 2 rows of 2 USB 3.0-A each. When I have the keyboard and mouse adapter and Hub plugged in on different rows, everything works find...drives plugged in don't freeze anything. Likewise, I tried another device in the port adjacent to the keyboard/mouse and it didn't cause freezing.

    Does anyone know why the certain configuration of hub plugged in next to keyboard/mouse causes it to freeze when an external drive is plugged into the hub?
      My ComputerSystem Spec

  2.    12 Aug 2018 #2

    Is the HDD self powered ( brick adaptor ) or USB Powered ? , if it is a 3.5" HDD it is likely drawing too much power through the Hub,
    try with it plugged direct to the MB or put the mouse and Keyboard Direct into the MB USB2 Ports since they don't need USB3

    KB
      My ComputerSystem Spec

  3.    12 Aug 2018 #3

    Thanks for the quick response...answers to your questions:

    - 1 HDD was self-powered (AC brick adapter) and 1 HDD was USB Powered. Both (independently and when plugged in together) caused the keyboard and mouse to freeze until removed.
    - Both worked when plugged into the front ports on my tower. I was able to accomplish original task of moving files from one to the other. No issues with the keyboard/mouse/transceiver.
    - Both work fine with the hub as long as it is in a port that is not adjacent to the mouse/keyboard transceiver.
    - My motherboard doesn't have USB 2 ports. It has 4 x USB 3.0 and 1 x USB 3.1 (Type-A) and 1 x USB 3.1 (Type-C).
    - The hub is a Anker 7-port hub with it's own power supply (i.e. brick AC adapter).
      My ComputerSystem Spec

  4. Clintlgm's Avatar
    Posts : 874
    Win 10 pro Upgraded from 8.1
       12 Aug 2018 #4

    Yes if you read the user manual on the Anker 7 port hub you will find out that while the hub is powered is still requires the 500mA from the port it is plugged into or in the Case of USB 3.0 1000mA. So your paired usb ports may not be supplying enough power for whatever reason so I would just move my keyboard and mouse

    This lack of power supplies is not unusual Asus Notebook have had this issue with the left side port for years now. I have never found the issue on a Motherboard but then I use eSATA external drives for my backups
      My ComputersSystem Spec

  5.    13 Aug 2018 #5

    mccnavy said: View Post
    Thanks for the quick response...answers to your questions:

    - My motherboard doesn't have USB 2 ports. It has 4 x USB 3.0 and 1 x USB 3.1 (Type-A) and 1 x USB 3.1 (Type-C).
    .
    The Prime Z270-A ? strange......most MB's still have both and some USB 3.1 too .....

    took a quick look and you are right, the IO plane doesn't have USB2.....1st time I have seen that..... there are 2 USB2 connectors for the Front Panel USB or an Add-on Port though (no#12 in the manual layout page) but I guess they didn't supply one? you could add a PCIe USB card too though for more ports.... or perhaps a Card Reader with USB Ports for a 5" Bay.

    PRIME Z270-A | Motherboards | ASUS Canada


    • USB PortsASMedia® USB 3.1 controller :
      1 x USB 3.1 Gen 2 port(s) (1 at back panel, teal blue, Type-A, Support 3A power output)
      ASMedia® USB 3.1 controller :
      1 x USB 3.1 Gen 2 port(s) (1 at back panel, , USB Type-CTM, Support 3A power output)
      Intel® Z270 Chipset :
      6 x USB 3.1 Gen 1 port(s) (4 at back panel, , 2 at mid-board)
      Intel® Z270 Chipset :
      6 x USB 2.0 port(s) (6 at mid-board)
      My ComputerSystem Spec

  6.    13 Aug 2018 #6

    I briefly talked to Asus Support earlier today and you may be right. He didn't explain why but went right to power draw being the likely culprit. Everything seems to be working now that I moved the hub. A smart card reader is now installed in the port adjacent to the hub and works fine. Maybe the keyboard/mouse transceiver requires more power than you'd think?
      My ComputerSystem Spec

  7.    13 Aug 2018 #7

    USB 3 can cause radio interference on the 2.4ghz range so the increased power draw by the HDD maybe be enough to effect or freeze the mouse receiver until the higher power draw stops again..... It's why I suggested moving the receiver to a USB 2 port if possible...does your monitor have a USB hub/ports perhaps?

    Anker notes this in some of their USB3 product descriptions.....

    Some USB 3.0 devices require direction connection to host ports. 2.4Ghz wireless devices (keyboards, mice, etc.) may not work around USB 3.0 ports. Try using a USB 2.0 connection.
      My ComputerSystem Spec


 

Related Threads
Keyboard & Mouse: Acer Desktop Ever since I would say, the past upgrade for Windows 10, my mom's Acer desktop's keyboard has been really laggy. For example, when I go to wake it from sleep to unlock it, the keyboard's Number lock and Caps lock...
W10 Eng + Port Keyboard = Bug in Drivers and Hardware
Hi. This is the problem. With Windows 10 and Portuguese (Brazilian) keyboard (ABNT2) things doesn't work properly. For example: Typing SHIFT+^ to have the mark ^ after hit the SPACE BAR comes like this ~ And twice SHIFT+^ before SPACE BAR, like...
Ever since I have taken this Dell notebook out of the box or not long after that, it has been giving me trouble with the keyboard, touchpad, and mouse. When I go to wake the computer from sleep or even turning it on after a night's rest, the...
PCI Serial Port not installed Code 28 in Drivers and Hardware
I have a refurbished HP Compaq 6000 Pro SFF 32-bit desktop. The original OS was Windows 7 Pro, I upgraded to Windows 10 Pro in Feb 2016. In June I upgraded the original ST3160318AS 160GB HDD with a Crucial MX200 250GB SSD On Wed July 20, did a...
I use left handed mouse, and swapping left / buttons works OK. I also set the wheel button to be "double click". But the wheel button brings up the context menu instead of double click. If I change to right hand mouse, the wheel button gives double...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 10:49.
Find Us