Did I just fry my front USB ports - How can I test? Solved


  1. Posts : 403
    Windows 10 64-bit home
       #1

    Did I just fry my front USB ports - How can I test?


    I tried charging a new el cheapo bluetooth speaker on my front USB 3.0 port on my PC. It didn't seem to be charging correctly, as the charge light brightness varied if you wiggled the cord. I moved it to the other front USB 3.0 port, and it was doing the same thing, so I left it in to charge and see what happened, and at some point the light went off indicating it was fully charged so I unplugged it.

    Now, neither front USB 3 port will work - I tried plugging in my USB 3 thumb drive and nothing is detected. A trip to the device manager says this for the "Generic Superspeed USB Hub" - with an orange exclamation:

    "Windows has stopped this device because it has reported problems. (Code 43)
    The USB hub failed to reset."


    I right-clicked Properties>Driver>Uninstall Device, then scanned for hardware changes, but it comes right back up highlighted orange again with the same message.

    So are they both fried, or is there something else I can do? If fried, is it just the front ports themselves, or could it have fried the actual motherboard ports where the front USB is connected? Is there a way to test this?

    Under events it says "Device was not migrated due to partial or ambiguous match."
      My ComputerSystem Spec

  2.    #2

    Given that you have a report about your USB hub, you could try uninstalling that in Device Manager (also look for any yellow triangles) and then restart (unless that's what you've already done when you mention uninstalling). Check Device Manager again.

    Check your USB ports with a known good device.

    If you are lucky, perhaps all will be well. However, sounds suspicious.
      My ComputersSystem Spec


  3. Posts : 403
    Windows 10 64-bit home
    Thread Starter
       #3

    Thanks for the suggestion, but that's exactly what I already did - uninstalled in device manager and then restarted. Tested with a good thumb drive and nothing.

    However, I did mange to fix it. For anyone else who finds this thread in the future and needs a tip, I read this on another forum and it worked:

    Reset the CMOS on the motherboard, or try unplugging it. My motherboard has a CMOS reset button, but before trying that, I tried simply unplugging my PC for 1 minute, then plugging it back in and rebooting. Sure enough, the front ports work again, and a trip to the device manager shows no issues. That's all it took.

    Close call though, and I'll never plug another el cheapo device into my PC for charging. For now on I'll use my AC power USB charger. Just gotta make sure the AC charger doesn't exceed the max charge voltage of the device.
      My ComputerSystem Spec

  4.    #4

    Hmm, sounds like you somehow generated a power spike- with surprising consequences.

    We have a TV program called 'Fake Britain' - typically all about the dangerous and non-spec products imported, often sold on-line.
      My ComputersSystem Spec

  5.    #5

    USB ports are generally protected by a resettable fuse. Depending on the design of the protection circuit, the fuse may or may not fully reset itself after the offending device is removed. There may be enough trickle current to keep the fuse in the high resistance state until power is completely turned off.
      My ComputerSystem Spec


  6. Posts : 403
    Windows 10 64-bit home
    Thread Starter
       #6

    Yeah, scary. It was just a cheap Polaroid speaker from Big Lots. Pretty decent sound for a cheapo speaker, and quite loud, with a really cool LED light show on the front, but yeah - I'll never plug it into my PC to charge again. AC charging only.
      My ComputerSystem Spec


  7.    #7

    rivre: Thanks for your post. Unplugging my PC and plugging it back in after a couple of minutes fixed the problem for me too. The same thing, I was fiddling with the USB connectors and must have shorted something. In any case, I've been trying to resolve for a week as I kept getting BSOD windows. Thanks so much again for posting.
      My ComputerSystem Spec


  8. Posts : 403
    Windows 10 64-bit home
    Thread Starter
       #8

    Glad I was able to help somebody else out with this.
      My ComputerSystem Spec


 

Related Threads
I'm running Windows 10 1703. I've attached all my system information, which I gathered due to a recent BSOD problem I was having. That seems to have been resolved - issue between Nvidia drivers and Firefox Quantum. However, I've been having...
This started this morning. Running Windows 10 Pro. I can run the browser (Chrome), luckily. Word also. But I cannot most other apps (I think), like WinSCP, but not Calc, not Notepad++, not Notepad. If I try to run Calc, it loads in the task try and...
Connecting to Front USB Ports Freezes the computer in PC Custom Builds and Overclocking
Hello. First of all, my specs: *Motherboard: ASUS M5A97 r2.0 *Chassis: Fractal Design R5 (Black, no window) *The front USB ports are two USB 2.0 and two USB 3.0 (There's also Audio In/Out, but I don't use those) My issue: Sometimes...
Hello all, I just upgraded to Windows 10 recently, and so far (for the most part) it's working great! The only issue I have is that some windows won't focus and stay on top when I alt-tab to it or click it, like it did in all other versions of...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 09:40.
Find Us