Windows 10: New Mouse Doesn't Work In Windows 10 (Buttons Work, But Cursor Won't) Solved

  1.    25 Jun 2018 #1

    New Mouse Doesn't Work In Windows 10 (Buttons Work, But Cursor Won't)


    Hello all, I'm coming here because I'm having an issue with a mouse. I've gone through most steps I've seen online (uninstalling the driver and then retrying it), but alas none of that works.

    The weird buggy thing about it is, it worked at first - then one time when the system was shut-off, the aura was continuing to shine anyway (and now it does that all the time - aura shining even if the system is turned off) and upon booting, the mouse buttons work, but the cursor will not move (in fact, the cursor doesn't even display until I plug-in another mouse).

    Most guides would tell you to "Go to the manufacturer's website and get updated drivers", but this is just a cheap Chinese mouse off Amazon and the oddly enough "TechZone" isn't on the mouse anywhere - "Hemzone" and "Gamestart" are.

    But regardless, searching any of these companies is a fruitless endeavor anyway. None of them seem to really be established companies or anything. I mean yeah I found this but I doubt chinglish-named drivers from 2012 are going to help me (not to mention I'm suspicious to even download them).

    So yeah - I have a mouse that the buttons work but nothing else does. Also, it's aura shines the moment it's plugged-in even if the computer is turned off (as long as the PSU is turned on, of course).

    I have no idea what is wrong with this mouse. All it came with in terms of instructions was a tiny square piece of paper telling you what it's four buttons do and what OSes are supported, that's literally it:

    Click image for larger version. 

Name:	sQg0Ink.jpg 
Views:	3 
Size:	520.6 KB 
ID:	193497

    Yeah, it says only up to Windows 8 is supported, but the Amazon listing deceptively listed Windows 10 as being supported. So I'm just a little peeved, even though this was just a $10 mouse. It's also very disappointing because it matches my build design quite nicely, but now it's looking like I may not even be able to actually use it.

    Any ideas?


    Thanks in advance.
      My ComputerSystem Spec

  2. f14tomcat's Avatar
    Posts : 37,170
    Triple boot - Win 10 Pro, Win 10 Pro Insider (2) - (and a sprinkling of VMs)
       25 Jun 2018 #2

    AlexanderM13 said: View Post
    Hello all, I'm coming here because I'm having an issue with a mouse. I've gone through most steps I've seen online (uninstalling the driver and then retrying it), but alas none of that works.

    The weird buggy thing about it is, it worked at first - then one time when the system was shut-off, the aura was continuing to shine anyway (and now it does that all the time - aura shining even if the system is turned off) and upon booting, the mouse buttons work, but the cursor will not move (in fact, the cursor doesn't even display until I plug-in another mouse).

    Most guides would tell you to "Go to the manufacturer's website and get updated drivers", but this is just a cheap Chinese mouse off Amazon and the oddly enough "TechZone" isn't on the mouse anywhere - "Hemzone" and "Gamestart" are.

    But regardless, searching any of these companies is a fruitless endeavor anyway. None of them seem to really be established companies or anything. I mean yeah I found this but I doubt chinglish-named drivers from 2012 are going to help me (not to mention I'm suspicious to even download them).

    So yeah - I have a mouse that the buttons work but nothing else does. Also, it's aura shines the moment it's plugged-in even if the computer is turned off (as long as the PSU is turned on, of course).

    I have no idea what is wrong with this mouse. All it came with in terms of instructions was a tiny square piece of paper telling you what it's four buttons do and what OSes are supported, that's literally it:

    Click image for larger version. 

Name:	sQg0Ink.jpg 
Views:	3 
Size:	520.6 KB 
ID:	193497

    Yeah, it says only up to Windows 8 is supported, but the Amazon listing deceptively listed Windows 10 as being supported. So I'm just a little peeved, even though this was just a $10 mouse. It's also very disappointing because it matches my build design quite nicely, but now it's looking like I may not even be able to actually use it.

    Any ideas?


    Thanks in advance.
    Well..... I see it states in the specs it is USB 2.0/3.0. Mice(mouses?) can get quirky in a 3.0 port, so if you have it in one, change it back to 2.0. May also just be DOA, bad cable, bad port, etc.

    Mice usually work just fine with the generic MS driver, unless it's a fancy Logitech or other multi-function device,it does seem to have programmable buttons.

    Is there software with it? Or are the functions suppose to be in a specialized driver?
      My ComputersSystem Spec

  3.    25 Jun 2018 #3

    First of all, sorry for the extra images, I removed them. Those were mistakes made while trying to correct the rotation of the image.

    I typically keep things in the type of port they're really made for - mostly just because there's no sense in populating a 3.0 with a 2.0 device anyway, but also potential compatibility things like that and avoiding inefficiencies. My mouse and keyboard are USB 2.0 so they're in the two USB 2.0 ports on my system.

    I DID try to plug it into USB 3.0 ports, but that doesn't fix anything. There's also a red USB 3.1 port on the system but I don't think that'd help anything and I really don't want to populate it with a crummy USB 2.0 mouse anyway.

    My system has two USB 2.0 ports and four USB 3.0 ports. I tried all of them. None of them work with the mouse, but work fine with my old Razer Taipan, which tells me it's the mouse or a driver issue.

    Nope. No software or anything. Just came naked in a box with that paper slip. Nothing else.
      My ComputerSystem Spec

  4. f14tomcat's Avatar
    Posts : 37,170
    Triple boot - Win 10 Pro, Win 10 Pro Insider (2) - (and a sprinkling of VMs)
       25 Jun 2018 #4

    AlexanderM13 said: View Post
    First of all, sorry for the extra images, I removed them. Those were mistakes made while trying to correct the rotation of the image.

    I typically keep things in the type of port they're really made for - mostly just because there's no sense in populating a 3.0 with a 2.0 device anyway, but also potential compatibility things like that and avoiding inefficiencies. My mouse and keyboard are USB 2.0 so they're in the two USB 2.0 ports on my system.

    I DID try to plug it into USB 3.0 ports, but that doesn't fix anything. There's also a red USB 3.1 port on the system but I don't think that'd help anything and I really don't want to populate it with a crummy USB 2.0 mouse anyway.

    My system has two USB 2.0 ports and four USB 3.0 ports. I tried all of them. None of them work with the mouse, but work fine with my old Razer Taipan, which tells me it's the mouse or a driver issue.

    Nope. No software or anything. Just came naked in a box with that paper slip. Nothing else.
    well...... may not be worth your time and effort to try and return it, but you can try. You got it thru Amazon? They're pretty good about returns, especially when it smells DOA. They get too many of them for anything, they will drop it from their site.

    You can try Troubleshooting it:

    Click image for larger version. 

Name:	2018-06-25_14h56_37.png 
Views:	2 
Size:	92.9 KB 
ID:	193502
      My ComputersSystem Spec

  5.    25 Jun 2018 #5

    Yeah I'm starting to think this is just a piece-of-crap mouse. I would only have myself to blame if I failed to check what versions of Windows it supported, but I'm a bit peeved that the Amazon listing clearly mentions Windows 10. It does kind-of raise the question in my head as to why any standard mouse would be compatible with older Windows but not newer versions to begin with, unless it had fancy drivers which this one doesn't...

    But I'm experiencing a strange phenomenon - upon plugging the mouse into my other computer (also a Windows 10 system, though it was a Windows 7 system back in 2011), that computer worked fine with it. Then, bringing it back to my new computer and plugging it in - it works!

    Something's wonky here. It's like plugging it into my other computer reset it or something, and then it started working on my new computer. But who knows how long it'll last until it stops working again and I'll have to repeat these steps? I notice it ceased to work after a reboot and then started having these "aura even when the system is off" stuff going on too. I think that perhaps it's an issue of the mouse not sleeping / waking-up when told to? And perhaps being plugged into another machine reset it?

    Both systems run Windows 10, but my old laptop is 2011 (second-generation / sandybridge) hardware inside. I wonder how different hardware would be able to make a difference like this.
      My ComputerSystem Spec

  6.    25 Jun 2018 #6

    Well regardless, I found a way to piddle with it to make it work. It's pretty apparent to me that it's going to be a finnicky mouse in any case, but given it only costed $10 I really don't feel like pissing with Amazon and shipping about returning it.

    Plus it matches my system's RGB cosmic theme. I'd be really disappointed if I can't make this work somehow.

    I'll go ahead and mark this issue as solved since I think we've covered pretty much all there is to do about it anyway. I'll keep your last suggestion in-mind if the problem resurfaces (something I bet will happen after a few reboots or power cycles). I've seen that suggestion elsewhere and I think it's the only thing I haven't tried.

    After that I figure I'm out of options and will have to simply keep trying this "plugging it in to another computer to reset it" thing whenever it happens.

    I really think it has something to do with how the computer tells external devices to either turn-off or "go to sleep" upon shutdown and turn-on upon startup. It's muddled in receiving those commands or something.

    Thanks.
      My ComputerSystem Spec

  7. f14tomcat's Avatar
    Posts : 37,170
    Triple boot - Win 10 Pro, Win 10 Pro Insider (2) - (and a sprinkling of VMs)
       25 Jun 2018 #7

    AlexanderM13 said: View Post
    Well regardless, I found a way to piddle with it to make it work. It's pretty apparent to me that it's going to be a finnicky mouse in any case, but given it only costed $10 I really don't feel like pissing with Amazon and shipping about returning it.

    Plus it matches my system's RGB cosmic theme. I'd be really disappointed if I can't make this work somehow.

    I'll go ahead and mark this issue as solved since I think we've covered pretty much all there is to do about it anyway. I'll keep your last suggestion in-mind if the problem resurfaces (something I bet will happen after a few reboots). I've seen that suggestion elsewhere and I think it's the only thing I haven't done. After that I figure I'm out of options and will have to simply keep trying this "plugging it in to another computer to reset it" thing whenever it happens.

    Thanks.
    Keep fiddlin'.... maybe you'll get it tamed, or figure out it's secrets!
      My ComputersSystem Spec


 

Related Threads
I have been using computers for over 25 years now, and I have never run across a problem like this. Backstory: I built my current PC about a year ago. Everything worked perfectly until about 5 days ago. At that point, it needed to restart. I...
For some reason both my main Windows button and Search buttons don't work. Other buttons on the Task Bar work as usual. Right click on either button gives a white-on-black context menu. Anyone have a suggestion, please?
I have a problem. Two problems to be exact, but the most pressing being that my mouse doesn't work. It is stuck in the middle of the screen, and the cursor is invisible. The original problem I had, prior to developing this new mouse problem, was...
Hi all. I ask for any pointers to start looking at this if you can. This week after some updates from MS in my W10 OS I noticed that clicking the middle button is not working at all. Normally in a browser you can open in a new tab or close a tab,...
Hello everyone! I updated to Windows 10 this morning, and after doing so realized that my side scrolling on my mouse pad (I'm on a laptop) doesn't work anymore. Googled, found out it was a driver issue, and went to download the correct driver. ...

Tags for this Thread

Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 18:12.
Find Us