Windows 10: "New External Device Detected". ?

  1.    19 Jun 2018 #1

    "New External Device Detected". ?


    Hello,

    First, what a great Forum.
    I'd be lost without you folks, for sure.

    When I plug in (via usb) a software defined radio, and for other gadgets also, a screen
    pops up with "New External Device Detected".

    Really annoying.

    I can slide/move the icon of the new device that was
    detected to under the Mac icon, or to under the Windows icon.

    Then, after waiting quite a while, usually, the screen goes away, and the device that
    I have just connected works. Sometimes, I can't get rid of it.

    Do I have to live with this screen ?

    Are my only options to just slide the device icon to underneath the
    Mac or Windows icon, and wait, wait,...

    And, there is an "ALT" button to, apparently select the device, or,...?
    Doesn't seem to do anything.

    Might someone walk me thru how to handle this, please. (and for the ALT button)

    Thanks,
    Bob
      My ComputerSystem Spec

  2.    19 Jun 2018 #2

    Hi, from what I can make out, that is an Apple-related message rather than Windows. (You mention a MAC icon). Are you running Parallels desktop?

    E.g.
    Connecting to the EV3

    There are references to that error message in connection with that.

    Someone familiar with this sort of environment will hopefully be able to advise you.
      My ComputerSystem Spec

  3.    19 Jun 2018 #3

    Hi,

    Yes, I'm running Parallels on an iMac.

    Your comment is very interesting.
    I kinda took it fore granted that it was a W10 generated screen, as it appears when on the Windows side.

    But, perhaps it is from the Mac side, or even by Parallels ?

    Thanks for EV3 Link.

    Bob
      My ComputerSystem Spec


 

Related Threads
After i installed windows 10 on my Asus N53SV, the keyboard doesnt work properly. I look on the internet for help, but it looks like im the only one. I tried uninstall and reinstall almost everything i know. From keyboard driver, touchpad, etc....
I had to buy a new (SSD) HD and had trouble booting from a disc until I enabled Legacy Mode and disabled Secure Boot in BIOS. Now whenever I boot up I get a "No Boot Device Found" message until I hit "Enter" at which point i'm allowed entry into my...
Icon Changer (Damian's Homepage) complains about lack of .net, despite .net 4(.5) and 3(.5) being preinstalled on Windows 10. Does it run on .net 2 or something else ancient?(running Windows 10 LTSB from July 2015)edit: probably better suited in...
I just began getting this error yesterday. :cry: What is the likelihood that another issue besides a failing hard drive is causing error? Secondly, I've already purchased a new hard drive as a precaution. What is the fastest/easiest way to...
i don't know if i am missing something or it is a bug on w10. i click "add new bluetooth device" and then i can pair a lumia, ok. i can see my phone in "join personal area network" window. if i try to pair the phone from "join personal area...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 15:26.
Find Us