Windows 10: Windows 10 Laptop Doesn't Recognize Mouse or Keyboard, Data Retrieval

  1.    18 Jun 2018 #1

    Windows 10 Laptop Doesn't Recognize Mouse or Keyboard, Data Retrieval


    Brief problem overview:

    When turning on my laptop, I get to the Windows lock screen, but my laptop's keyboard does absolutely nothing and neither does my mouse or touchpad. The only thing I can do here is shut the laptop off by holding the power button. Since I can't get into Windows and I have no idea what's wrong, I want to recover the data on the drives somehow. Unfortunately, safe mode didn't work, and when booting from Linux on a USB drive, two of the three drives in this laptop are not recognized (both of which are NVME drives), and I need to retrieve some data from those drives. The SATA HDD is recognized by Linux, but in read-only mode. I don't know what to do to get the data on the two NVME drives.

    The details (there's a bit of a story to this, so hold on tight):

    Last night, I was using Windows 10 Home Build 17134 on my personal ASUS ROG G752VY laptop. I plugged in one of my NCredible PNY 32GB flash drives (that was most likely corrupted in some way because it had write protection unintentionally enabled on it) and I plugged in another one of my functional flash drives (a Verbatim 32 GB drive) to try and move files over from the PNY to the Verbatim flash drive. Only one problem; for some reason, Windows only recognized the PNY drive, and not the Verbatim no matter how many times I plugged it in (I unplugged and replugged the Verbatim drive probably somewhere around 6 to 10 times, including in different USB ports on the laptop), even though one of my older laptops recognized the Verbatim drive with no problems.

    So I thought, why not try the solution to everything; let's restart the computer, right?

    Big mistake. If only I had known what was to come.

    With both the PNY and the Verbatim flash drives still plugged into the USB ports on the computer, I restarted Windows 10. When the lock screen appeared, pressing keys on the keyboard did absolutely nothing (normally pressing a key opens the lock screen and brings you to the field where you enter your password), and no mouse that I plugged in, wired, wireless, or even the touchpad, would move the cursor (the cursor didn't even appear on the lock screen). Plugging in a wired external USB keyboard also did nothing. So the only thing I could do was press and hold the power button to shut it off.

    After waiting a few minutes, I pressed the power button again, turning the laptop back on. Windows booted up, taking me to the lock screen... and still nothing worked. The keyboard does nothing, and neither does any mouse or the touchpad. Desperate, I decided to turn it off and try again.

    This time, when the manufacturer logo appears before booting into Windows, I see the text "Please wait..." at the bottom, and it takes me to Windows advanced recovery options. And guess what! When I'm in here, the mouse and keyboard both work! So this indicates that it's an issue with my specific Windows installation, not with the hardware. So once I'm in here, I try several different options:

    First, I try booting into safe mode. This time, instead of showing me the typical lockscreen with the time, it immediately shows me the field where I enter my password. Unfortunately, even in safe mode, the mouse, keyboard, touchpad, and even external keyboard all still do absolutely nothing.

    Then I tried "startup repair," but it reported that it couldn't do anything, so that didn't help much.

    At this point, it was 3 AM, so I was too tired to continue; I gave up, unplugged the laptop, went to bed hoping that it would be magically fixed in the morning.

    Well, it wasn't; all the same issues persisted this morning, so I decided that the best thing for me to do would be to at least get the files off the drive that I needed quickly. So I put xUbuntu on an external SanDisk Ultra flash drive (using a different laptop to do this), booted into the BIOS on the ASUS ROG laptop (the laptop's keyboard works in the BIOS), and changed the boot priority to the flash drive.

    I didn't fully install xUbuntu; I just ran the "try Linux" option you get whenever you boot from a drive you wrote an xUbuntu ISO to. So now I'm inside xUbuntu (running on the SanDisk flash drive), and my keyboard and mouse are working perfectly. I can navigate around, so I go to check the disks; but guess what; GParted and xUbuntu only see the 1TB HDD inside the laptop, and I can't access the other two drives; it doesn't see the 256GB NVME SM951 drive that Windows is installed in, nor does it see the other, separate 256GB SM951 that I have some important files on (these SM951s were never running in RAID, Windows always treated them as two separate drives). Great. In addition, for some reason, the HDD drive that it does see will let me copy files from the drive, but it won't let me delete any files from it (every file and folder has a lock icon next to it).

    Researching this problem, apparently I need to change the SATA Mode Selection in my BIOS to "ACHI," but of course my BIOS only shows "RAID" for some reason (there's nothing else to select). So that solution apparently won't work. At this point, I honestly don't know what to do.

    Whenever I'm in the advanced startup options, I do see the choice to "remove everything and reinstall Windows," which theoretically should fix the problem based on my observations. However, I do have important files on the C: Drive that I would like to manually back up before trusting that this option won't remove them. Theoretically, everything on the other NVME SSD would be unaffected. I just want to save this as the last resort, though, and only use it after I've got all the data on these drives backed up.

    I could take apart the computer and remove the drives, but don't have the hardware necessary to retrieve data from the NVMe drives outside of that laptop. I also really don't want to spend any money.

    So, it's been a relatively fruitless adventure so far, and I honestly don't know what to do. Does anybody have any idea what actually happened here or what I need to do in order to get the data off the two NVMe drives? Any help is greatly appreciated. Thank you.
      My ComputerSystem Spec

  2. Caledon Ken's Avatar
    Posts : 10,689
    Windows 10 Pro x64 Build 1803
       19 Jun 2018 #2

    Have you tried Kyhi's recovery disk? Hopefully it will have drivers to enable you to read drives and get your data.

    Windows 10 Recovery Tools - Bootable Rescue Disk
      My ComputerSystem Spec

  3.    20 Jun 2018 #3

    I tried it, but for some reason neither of the two NVMe drives showed up, just like with xUbuntu. I'm not really sure what I need to do to get them recognized.
      My ComputerSystem Spec

  4. Caledon Ken's Avatar
    Posts : 10,689
    Windows 10 Pro x64 Build 1803
       20 Jun 2018 #4

    Are the NVMe's your boot media? Think you said they are raided, is that raid 0 or Raid 1

    Interesting there is no RAID setup instructions in manual.

    In your BIOS under the boot tab please disable fast boot.

    On that same page what are your options under "Boot Option priorities"? and Driver Option Priorities?

    Under the Security tab set Secure boot to disable.

    I assume you installed the M.2's, do they show as being present in BIOS?

    One last thing does your device have a removal battery. If so, power down, disconnect everything, remove battery, hold power key for 20 seconds, wait 5 minutes and reassemble.
      My ComputerSystem Spec

  5. Caledon Ken's Avatar
    Posts : 10,689
    Windows 10 Pro x64 Build 1803
       20 Jun 2018 #5

    By the way what BIOS are you on?

    Was reading this long thread and someone mention BIOS only had Raid and need ACHI (which you said).

    https://rog.asus.com/forum/archive/i...p/t-79590.html

    There are other hits, I searched "Can't access m.2 on asus rog laptop"
      My ComputerSystem Spec

  6.    21 Jun 2018 #6

    The NVMe drives actually aren't in RAID, the BIOS simply lists the "SATA Mode Selection" as RAID and won't let me change to anything else.

    Thanks for linking that thread, I haven't tried it out yet but I definitely have never updated the BIOS for this laptop, so I must be on the oldest. That explains why the NVMe drives weren't being recognized in xUbuntu.
      My ComputerSystem Spec

  7. Caledon Ken's Avatar
    Posts : 10,689
    Windows 10 Pro x64 Build 1803
       22 Jun 2018 #7

    Updating BIOS's come with a certain risk and you can read about it on the net. That said I've updated dozens with no issue. The key is to read the instructions, be patient and in the case of a laptop have a charged battery and be plugged in. BIOS updates don't like losing power mid stream.

    So is one of the NVMe drives your boot drive?

    In post #4 I asked some questions did you have a chance to look at them?
      My ComputerSystem Spec


 

Related Threads
Keyboard & Mouse: Acer Desktop Ever since I would say, the past upgrade for Windows 10, my mom's Acer desktop's keyboard has been really laggy. For example, when I go to wake it from sleep to unlock it, the keyboard's Number lock and Caps lock...
I have followed several similar threads and their fixes for this problem with no result. After downloading the Win 10 upgrade, my system then said "loading updates". Then it restarted with a blue login screen saying "Welcome Back!" And a box to...
Hi, I'm new here. Like the headline says my new Asus E200HA (comes default with Windows 10) won't recognize the keyboard and touchpad on windows 8.1. I wonder what is the problem and how it can be solved as Windows 8.1, (tested with external usb...
Hello, that's a problem I actually had since Windows 8: Whenever my laptop goes to sleep, the only way to wake it up is through the laptop's keyboard (pressing any key on the keyboard). But when I press the USB keyboard or the USB mouse, it doesn't...
Solved Windows Doesn't Recognize Ethernet in Network and Sharing
I ran Windows 8.1 on my desktop machine a few months ago, and later upgraded to Windows 10. Everything worked great at that time, but since have replaced Windows with Linux. Now I'm trying to install Windows again, with the same 8.1 disk that I used...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 18:36.
Find Us