Windows 10: Why won't Windows accept a driver that worked some time ago?


  1. Posts : 7
    Windows 10 Education
       16 Jun 2018 #1

    Why won't Windows accept a driver that worked some time ago?


    Hello everyone,

    this will be a rather lengthy post. Please bear with me, as I don't know what information is pertinent to my problem and what isn't.
    I have a Dell Latitude E6410 laptop which has been running 64-bits Windows 10 satisfactorily for quite some time now. However, its original 250 GB hard disk was rather slow, small, getting old and throwing up file system errors a bit too frequently to my liking. So I decided to try to move some disk-intensive Windows functionality onto another medium, like a USB flash drive or a memory card. That's no problem with the Temp directory and ReadyBoost, but if you want to put the page file or the search index onto it, you have to find a way to fool Windows into believing that the medium is permanent instead of removable. Various drivers exist that claim to do this, and after a lot of experimenting, I thought I had it figured out with the filter driver cfadisk.sys, originating from Hitachi. What I did, was:
    - from an elevated command prompt:
    bcdedit /set nointegritychecks on
    bcdedit /set loadoptions ddisable_integrity_checks
    bcdedit /set testsigning on
    - reboot with shift-restart
    - choose option 7 from the startup menu to disable enforcing driver signature checking
    - install the driver
    - reboot and see the driver working as advertised, without further ado.
    Wonderful!

    But then, the hard disk started making trouble, even more frequent file system errors, bad sectors cropping up. It got so bad that I got the message "Missing operating system" at startup, at which point I realized that something was seriously amiss. Luckily, I had a fairly recent backup. So I went and got myself a shiny new 2 TB disk, installed it and restored the backup onto it. No go; the restore went fine, but the PC wouldn't even consider starting up, just showing me a blank screen with a blinking cursor in the upper left corner. After x tries, I gave up and took the laptop to a PC shop, where they emptied the new disk of all its contents and put a clean Win 10 install on it. Back home, I backed that up in case of further trouble. I decided that the recent backup I used earlier was probably corrupt. I then restored an older backup from the broken-down disk, hoping that that one wouldn't be corrupt. It wasn't, and after a few hours I was back in business, wit a MUCH bigger disk .
    But. Since then, I haven't been able to get the filter driver to work! As far as I know, I'm doing exactly the same things I did before, but Windows will not accept the unsigned driver unless I disable driver signature checking with option 7 from the startup menu every time I boot. Obviously, that's not acceptable, ands the BCDEDIT commands should take care of that. If I examine the BCD, the settings are alle there: no integrity checking and so on. So I'm wondering what, if anything, may have changed in my laptop, apart from the new disk, or what, if anything, may have changed in Windows. Some update that enforces driver signature checking even more rigorously than before, perhaps? I don't think it's the PC's BIOS; there is an option to boot in UEFI mode, but there's no Secure boot possibility, so that could not be the problem. And I've always used the Legacy BIOS mode and am still doing that. Also, I've read that Windows 10, when cleanly installed, won't accept unsigned drivers, but that Windows 10, upgraded from a previous Windows version, will. The registry tells me that "my" Windows 10 is an upgrade from Windows 7, which has indeed happened somewhere back in 2015.

    So - I'm stymied. Any ideas? I'd like to get that driver working again; it did fine until, if I remember correctly, mid-March past. I'm not waiting for advice like "Don't mess with unsigned drivers", but if you MUST give it, feel free to do so .

    Regards, Jaap.
      My ComputerSystem Spec

  2.    16 Jun 2018 #2

    Let me say something , maybe it will give some Ideia what is going on:
    Many years ago , maybe 10, I had a PDA with Windows on it. One day it just refuses to Start. What was wrong?! A system Certificate has expired. Fortunatly there was Advice on NET how to recover it, otherwise the PDA had turned Electronic Waste.

    Everyone should be aware that "Security" nightmare from MS has consequences, PC are getting more and more "tied-down".
    I would suggest you to not overcome the "Barriers" or you may fall down very hard.
    Just go back to a Windows Version that you like.
    As a matter of fact, besides the Huge advertising, W10 is worst than W8.1, full of limitations, most visible with the huge limitations of the GUI Colors, user has very little control of it.
    Regards
      My ComputerSystem Spec


 

Related Threads
Don't know why "Repair Disk" has never worked for me. Since I first used it, at least about twenty or thirty times, but I keep trying whenever I need such on any PC am working on. It ALWAYS reports the PC cannot be repaired. I have both 32 and 64...
2 out of my 3 computers were upgraded no issue. My last one is a 2008 with an Asus P5N-MX with a E8400 processor. As stated in the title, I was able to complete the upgrade but I have a black screen if I leave a video cards. I swapped many...
Microsoft Flight Simulator X with MultiCrew Experience voice program was working good in Windows 7 Pro. Now, after installing Windows 10 Pro, FSX will not start and the fsInsider.dll file is named as the problem. Here are the messages that I get...
So this is a original windows 8.1 unit. G585 lenovo. All drivers update from windows update but the wifi driver keeps showing realtek inside of windows 10 but it is a atheros. I have the proper driver but because the date is prior to the windows 10...
Source: Accept payments on the go with PayPal Here on Windows Phone

Tags for this Thread

Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 12:25.
Find Us