Windows 10: Broadcom NetXtreme 57xx Gigabit Controller: Driver initialization fail Solved

Page 2 of 2 FirstFirst 12
  1.    05 Aug 2015 #11

    bahenley61 said: View Post
    Mine is 32-bit, x86-based processor. Driver version is 16.8.1.0. As I said, I uninstalled it through the device manager and reinstalled. Since then it works.
    thanks for info, i did the same uninstall and reinstall and version 16.8.04 was installed not what you have vrsion 16.8.1.0
    drivermax tells me 16.8.04 is te latest version, please could you add attachment in a zip file the driver you are using? that would be helpfull
    thanks

    BTW i saw on broadcom website
    https://www.broadcom.com/support/?gid=9 a new driver for windows 10 version 17.2.0.0 but the driver does not work either
    so last hope to test your driver if you sent it to me, thanks


    BTW i have found the 16.8.1.0 driver and it is working now
    Thanks
    Last edited by jaccies; 06 Aug 2015 at 14:53.
      My ComputerSystem Spec

  2.    16 Sep 2015 #12

    I had a similar problem, my driver updated on it's own recently, and was not working.
    The newest driver available at Broadcom did not work either.

    I thought i'd share a solution that worked for me.

    A simple solution, was to go to the driver information in the device manager and select "rollback driver"
    It went back to the previously working one (which happened to be 10.43.0.0, and it worked fine again) and in a instant (didn't even need to restart) it worked.

    I'll say though, netwrok adapter drivers are the worst thing to stop working... cause you can't just go an get a new one :P

    I guess i'll wait 'til they update the driver again, and try it again when they do.
      My ComputerSystem Spec

  3.    12 Oct 2015 #13

    Hi,

    My Machine is a 4 year old Dell XPS 8300. I upgraded from Win 7 to Win 10 back in the summer.

    This is an issue for me a well. My fix that I found from searching is to use the old Windows 7 driver. My driver is 14.2.0.7 dated 7/20/2010. http://www.dell.com/support/home/us/...driverId=NDC29.

    I still have an issue though with disconnects. Sometimes every few days. Sometimes a couple times a day. However, the Win 10 driver does not work.

    John
      My ComputerSystem Spec

  4.    13 Oct 2015 #14

    Hi,

    Forgot to add that you need to first delete the device, then use the new drivers uninstall tool to unistall the old driver (don't use the uninstall in control panel) then install the Win 7 driver in "compatiblity mode" Win 7.

    John
      My ComputerSystem Spec


 
Page 2 of 2 FirstFirst 12

Related Threads
Solved SM Bus Controller Driver in Drivers and Hardware
I have a driver problem with SM Bus Controller with the driver not being correctly installed, but how do I find out what are the details I need to update the driver. I need to know the manufacturer (I think) and Model (I think) but how do I find...
I have a gigabyte GA-Z77X-UD3H which uses the via chipset for USB (VIA VL800 chip) I have an error in system device for Usb xHCI Compliant host controller I am just wondering what drivers I can use for this? Also I didn't load any other...
I have a dell inspiron N4010 W7 SP1. I am trying to download W10 and message from W10 indicates that I need to download a driver for this adapter; opened the device manager and located the adapter and then tried to update the driver and...
Solved Driver Updates Fail to Install. in Drivers and Hardware
So i went to check for updates, it found 2 updates for my sound and video cards. The new drivers were downloaded... But failed to install, giving me the following error: 0x8024007. If i check for updates again, Windows Update will not find...
I have a Aśus Maximus V Gene mob that has two Sata mob inputs not controlled by the Intel Sata driver. I am having difficulty installing the latest Asmedia driver downloaded from the Aśus support site. With Win 7 there isn't a problem, but win 10 TP...

Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 06:17.
Find Us