Windows 10: Intel RST problem : I'm lost :-( Solved

Page 3 of 3 FirstFirst 123
  1.    1 Week Ago #21

    Hi, I am not sure why you are having issues downgrading from the V.15 Drivers , I have tried them , as my RAID Array Drives are seen as SSD's not HDDs but they didn't help so I downgraded again. Did you try just rolling the Driver Back in D.M.?

    Perhaps try an older Driver like v12.9.4.1000 which is available at WinRaid too and works fine on my system and if it installs then upgrade to the 13.x series Driver. Do NOT install a Driver older than 11.7.xxxx as your system it will likely not boot any longer due to the change in driver Type after 11.7.x.

    Forum - Intel RST/RSTe Drivers (newest: v16.0.10.1104 WHQL/v5.4.0.1462 WHQL)

    Also Note that your .Net Framework must be upto date for the Intel RST Software to work properly but I think you just have the same Issue as me so.... for the secondary Controller (sSATA)

    1. Uninstall the Intel RST software from within the Control Panel > "Programs".
    2. Reboot.
    3. Open the " Storage Controllers" section of the Device Manager and right click onto the listed "sSATA AHCI Controller".
    4. Choose the options "Update Driver Software" > "Browse my computer..." > "Let me pick from a list..."
    5. Check "Show compatible hardware".
    6. Choose the listed "Standard SATA AHCI Controller" > "Next" > "OK".
    7. Reboot.
    8. On Reboot the Controller will now be listed under IDE ATA/ATAPI Controllers as a Standard SATA AHCI Controller and you should be able to reinstall the RST Software again ( same version as Driver on Primary Raid Controller)

    Click image for larger version. 

Name:	Capture1.PNG 
Views:	2 
Size:	119.3 KB 
ID:	191709
      My ComputerSystem Spec

  2.    1 Week Ago #22

    Thanks,

    You might think that I'm a little bit too cautious ! but before proceeding in changing my driver on my secondary controller I have one more question :

    This controller is attached to a DVD, a HD and my Samsung SSD boot disk.
    Is it ok to change this driver having a SSD boot disk attached ? Could my computer encounter problems in booting ?
    And if so, will I be able to revert to the previous settings ?

    Thank you so much.
      My ComputerSystem Spec

  3.    1 Week Ago #23

    I am curious why the SSD boot disk is not on the Main Controller ?

    I have my DVDs and a DATA only HDD on my sSATA Controller, so have not tried this , though I don't think it should be an issue, since it is no different than changing the Intel drivers for another version.

    You could make a Macrium Free Image of the system , making sure to make the Boot Disk too ( very important for recovery ) , so you can recover the System if there is a Driver Issue on Reboot.

    KB.
    Last edited by Kbird; 1 Week Ago at 09:42.
      My ComputerSystem Spec

  4.    1 Week Ago #24

    Ok, I changed the driver on my secondary controller and have now an AHCI SATA standard driver (storahci.sys).

    I have attached my boot SSD on the secondary controller (with the DVD and another HD) because I thought that when you build a RAID on the primary controller, all drives that are connected are concerned ?

    I have still the Intel RST service marked as "not in execution".
    I have tried to install other versions of the Intel RST software but I always got errors when trying to run the installer (software and drivers). (see logs attached):

    When looking at the logs (IntelRST_MSI.log) at line 693, I can read that :

    "Info 1603.The file C:\Program Files\Intel\Intel(R) Rapid Storage Technology\IAStorIcon.exe is being held in use by the following process: Name: IAStorIcon, Id: 3448, Window Title: '(not determined yet)'. Close that application and retry."
    IAStorIcon (32 bits) is listed in the task manager.
    I do not see anything about IntelRST in the appwiz.cpl or in the services.

    Something must be wrong. Is it possible to delete in a clean way this RST software and have it installed again ?
    Intel RST problem : I'm lost :-( Attached Files
      My ComputerSystem Spec


  5. Posts : 33,713
    Triple boot - Win 10 Pro, Win 10 Pro Insider (2) - (and a sprinkling of VMs)
       1 Week Ago #25

    xfred53 said: View Post
    Ok, I changed the driver on my secondary controller and have now an AHCI SATA standard driver (storahci.sys).

    I have attached my boot SSD on the secondary controller (with the DVD and another HD) because I thought that when you build a RAID on the primary controller, all drives that are connected are concerned ?

    I have still the Intel RST service marked as "not in execution".
    I have tried to install other versions of the Intel RST software but I always got errors when trying to run the installer (software and drivers). (see logs attached):

    When looking at the logs (IntelRST_MSI.log) at line 693, I can read that :

    "Info 1603.The file C:\Program Files\Intel\Intel(R) Rapid Storage Technology\IAStorIcon.exe is being held in use by the following process: Name: IAStorIcon, Id: 3448, Window Title: '(not determined yet)'. Close that application and retry."
    IAStorIcon (32 bits) is listed in the task manager.
    I do not see anything about IntelRST in the appwiz.cpl or in the services.

    Something must be wrong. Is it possible to delete in a clean way this RST software and have it installed again ?
    @xfred53

    Do you have the RST Manager running? That has a lock on the .exe. Click the Icon in the taskbar to display the Manager and end the programs, or end it in taskmanager. Click image for larger version. 

Name:	2018-06-13_04h44_54.png 
Views:	2 
Size:	46.1 KB 
ID:	192124

    Click image for larger version. 

Name:	2018-06-13_04h40_03.png 
Views:	2 
Size:	145.6 KB 
ID:	192122Click image for larger version. 

Name:	2018-06-13_04h41_21.png 
Views:	2 
Size:	133.6 KB 
ID:	192123

    If you want to totally uninstall it, bits and pieces and Reg entries to start over, Revo Uninstaller is excellent. It's free, and there is a 30-day free trial.

    Download Revo Uninstaller Freeware - Free and Full Download - Uninstall software, remove programs, solve uninstall problems
    Last edited by f14tomcat; 1 Week Ago at 04:42.
      My ComputersSystem Spec

  6.    1 Week Ago #26

    Drives not included in the RAID array just become non-member drives and use the Intel AHCI Driver instead of the Raid Driver , so there would be no issue with the SSD on the Primary Controller, I usually make sure the OS Drive is on Port 0 of the Primary Controller and the caching drive eg an old 32 or 64gb SSD ( if used for the Array) is on Port 1.

    The RST Software should match the Driver Version , you can download the complete Software and Driver package on WinRaid. The RST software NEEDS the .Net FrameWork ( version 3.5 I think) installed to install and function correctly also.

    Forum - Intel RST/RSTe Drivers (newest: v16.0.10.1104 WHQL/v5.4.0.1462 WHQL)

    I have never used Revo Uninstaller , so I cannot comment on that.

    KB
      My ComputerSystem Spec

  7.    2 Days Ago #27

    Hi everyone,

    I finally used RevoUnistaller Pro and forced uninstallation of the Intel RST.
    I then could install the correct version for my OROM controller (13.1.0), drivers and software (and this was a downgrade from v15 to v13).

    Everything runs now fine, I have no more message (the service could not be started) and the UI of the Intel RST can now be opened.

    I have no idea why I went into this problem. My only clue is that the RST driver version and the RST software did not have the same version. And this could be because I used a software to automatically update all my drivers. Maybe this software did update my driver but not the software that is linked to.

    Anyway, thank you all for your great help.
    Have a nice day
    Francois
      My ComputerSystem Spec


  • Posts : 2,022
    Windows 7 Pro x64 Windows 10 Pro x64
       2 Days Ago #28

    Driver update programs are a No No, there is no reason to use one.
      My ComputersSystem Spec

  •    2 Days Ago #29

    That is good news .....

    I actually wondered how you got on since this weekend my x99 system finally got Win10 1803 and it automatically installed the C600+/C220+ driver on the secondary controller ( version 5.2) and the RST software stopped working for me until I switched it back to the Standard M$ AHCI Controller Driver again.
      My ComputerSystem Spec


  • Posts : 33,713
    Triple boot - Win 10 Pro, Win 10 Pro Insider (2) - (and a sprinkling of VMs)
       2 Days Ago #30

    xfred53 said: View Post
    Hi everyone,

    I finally used RevoUnistaller Pro and forced uninstallation of the Intel RST.
    I then could install the correct version for my OROM controller (13.1.0), drivers and software (and this was a downgrade from v15 to v13).

    Everything runs now fine, I have no more message (the service could not be started) and the UI of the Intel RST can now be opened.

    I have no idea why I went into this problem. My only clue is that the RST driver version and the RST software did not have the same version. And this could be because I used a software to automatically update all my drivers. Maybe this software did update my driver but not the software that is linked to.

    Anyway, thank you all for your great help.
    Have a nice day
    Francois
    Good news, @xfred53, glad to hear Revo helped clean it up for you.

    And agree that Voodoo Driver Update apps are snake oil.
      My ComputersSystem Spec


  •  
    Page 3 of 3 FirstFirst 123

    Related Threads
    Intel problem? in General Support
    Windows 10 machine in church office (intel chip) had persistent problems with latest update failing. Then automatically restored previous version of windows. Today the restore is failing putting up message "no signal". There is internet connectivity...
    Recently, the WiFi on this particular laptop has been sub-par. Downloading the same file, the WiFi downloads at the rate of 70 kbps (pretty bad) while the Ethernet cable is at 700 kbps ~ 1000 kbps. I know that the Ethernet is almost always faster...
    I have been using windows 10 for a few months now and this problem has happened twice now. The computer starts running very slowly and when I click on the start button = nothing happens so there is no way to shut the machine down except to shut it...
    Intel Compute Stick with same problem. in Installation and Upgrade
    Good day to all, This is my first post in this forum and I actually discovered it by searching at the Internet, after having the same problem (installation of Windows 10 new Update 1511- nersion 10586) with my Intel Compute Stick, which was...
    Intel Driver Problem in Graphic Cards
    I am using a laptop so I my only option is to use the provided drivers by the manufacturer for Windows 8.1 (there are no Windows 10 drivers available at the download support site) This error shows 31241 after this "turn off the display"...

    Tags for this Thread

    Our Sites
    Site Links
    About Us
    Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

    Designer Media Ltd
    All times are GMT -5. The time now is 10:23.
    Find Us