Windows 10: After 1803, AV system is microstuttering every few seconds

Page 2 of 2 FirstFirst 12
  1.    29 Jun 2018 #11

    Installing Intel RST May Have Worked


    dalchina said: View Post
    Here's a page of links I created some time ago... ref. my suggestion of searching the forum.. They may or may not be relevant in the context of 1803 of course, as things move on, but something might prompt an idea. There will be some more recent ones on the forum.
    Your .doc file included the possible solution of installing Intel Rapid Storage Technology. My system has a SSD so I found the Intel RST site, did some reading, and proceeded.

    First, checked system requirements:
    System Requirements for IntelĀ® Rapid Storage Technology

    Then followed the advice here to use Intel's Driver Support Assistant
    Download IntelĀ® Chipset Device Software (INF Update Utility)

    Went to the Dell driver page for my model and found the IRST executable.

    I created a Restore point on my system before installing just in case...

    Upon installing (which required running the file as an Administrator), a warning came up that installation required .NET 3.0 or later which the warning suggested was not found on my system. However, I could install just the drivers by continuing. I elected to do that.

    Re-booted and so far audio is smooth. I will come back and post again if I discover any significant issues. I was streaming RadioParadise for about 10 minutes when the audio stopped suddenly. I don't yet know if the issue was on the RP side or in my system. Perhaps something about the new drivers will cause me some WiFi issues...if so, I feel fairly confident I can remedy that. Meantime, listening happily for more than 30 minutes to music from the external drive connected to the laptop that serves as my music server, connected to my home audio system.

    I hope my experience helps.
      My ComputerSystem Spec


  2. Posts : 7
    Windows 10 Professional
    Thread Starter
       03 Jul 2018 #12

    I'm starting to wonder if there really is just something physically wrong with my hard drive, or if my SATA controller is no longer properly supported by the Windows drivers, or something. Because I'm also getting this thing where whatever program I'm using will spike its hard drive usage to 100% and just stay that way for over a minute. That would seem to be consistent with storport.sys acting up.

    What's the best way to diagnose every possible issue a hard drive might be having? I have another computer I could stick it into as a secondary and run the kind of diagnostics that wouldn't work on a drive that's in use, if that helps.
      My ComputerSystem Spec

  3.    04 Jul 2018 #13

    Here's a thread on stutter + storport.sys which might prompt thought.
    DPC Latency with Storport.sys and Wdf0 1000.sys - Windows 10 Forums

    It might be interesting to see what happens in Safe Mode - don't recall if LatencyMon runs in Safe Mode though.

    Please complete your system specs including PC model, disk types, RAM types (see mine for comparison).

    You have a desktop- suggest temporarily disconnecting all non-essential drives.

    Recall this is quite possibly related to the upgrade to 1803 and the drivers supplied with that upgrade.
    You can run through the process of temporarily disabling unnecessary drivers to eliminate those.

    What's the best way to diagnose every possible issue a hard drive might be having?
    Start with Hard Disk Sentinel (trial). You can also perform a surface test (although that's not likely to be relevant).
    You can try benchmarking software e.g. Crystal Diskmark

    See post #3 here:
    Please Help: How to check if HDD inside Windows 10 PC is damaged? - Windows 10 Forums
      My ComputerSystem Spec

  4.    06 Jul 2018 #14

    I get the issue with 2 different sound systems and one of these is a USB sound system. I also have the same issue with local media (mp3) and I do not believe this issue has anything to do with latency. I think something is consuming
    large amounts of CPU or other resources about every 4-5 seconds.

    This is my post on Microsoft forums.
    have exactly the same problem after 1803 install. I spent over an hour with Microsoft telephone support. The tech kept insisting the sound issues was because the HP system on board sound system was not supported on Win10. I pointed out I was using a USB sound device but he would not listen and wanted to close the ticket.

    I think something is pulling large amounts of CPU and that the issue was NOT the sound system at all but just a visible result of the root cause. I would not close the ticket and will try going back to previous build. I will call Microsoft again to see if they can help me solve the issue.
      My ComputerSystem Spec

  5.    22 Jul 2018 #15

    New clue to the help solve the issue !!!!!


    I FOUND AN IMPORTANT CLUE
    I recently did a backup the disk for the 1803 version by using Paragon Disk Copy. I tested it by booting from the copy on an eSATA disk interface so I would not have to open the case and switch drives. It booted just fine AND the sound works just fine. I think it has to do with the disk interface because when I did open the case and booted from the regular SATA interface, it booted just fine BUT the sound was back to stuttering.

    DOES ANYONE HAVE ANY IDEAS WHAT IS CAUSING THIS?
      My ComputerSystem Spec

  6.    22 Jul 2018 #16

    Sounds like the difference in a low level driver such as storport.sys.
      My ComputerSystem Spec

  7.    23 Jul 2018 #17

    dalchina said: View Post
    Sounds like the difference in a low level driver such as storport.sys.
    How can I tell the version number of the driver?
    Can I try to install the driver from my 1709 Win10 build?
      My ComputerSystem Spec

  8.    23 Jul 2018 #18

    Experiencing slight pause every four seconds - Page 4 - Windows 10 Forums
    Go from about post #35.

    In the first part of the thread, which unfortunately became incredibly drawn out, the idea was to back up a set of drivers from 1709 (which was done), then substitute these in an 1803 build to see if this addressed the problem at all. I took a simplistic view- if that worked, we were in the right ballpark.

    From thread #35 follows an analysis using Windows Performance Recorder.

    Of course you can attempt trial and error, but an analysis is much the better way.

    How can I tell the version number of the driver?
    Low level drivers by MS have a version number the same as the build.
    Can I try to install the driver from my 1709 Win10 build?
    Yes - see the thread for examples.
      My ComputerSystem Spec


  9. Posts : 7
    Windows 10 Professional
    Thread Starter
       20 Aug 2018 #19

    Two important updates on this:

    (1) I realized that I have a spare hard drive lying around not being used for anything important (actually, it was "lying around" inside another computer that I was using but can do without). So I popped it in as a secondary drive and installed a fresh copy of Windows 10 onto it from my DVD. And even after updating to 1803, it was working just fine. So that conclusively rules out any fundamental incompatibilities with my hardware. With my main drive recognized as drive E, I started the process of copying over some of my old files and trying to reinstall my programs. I figured, worst-case scenario, I can copy over everything that'll fit, back up the rest, wipe the old drive, ghost the new drive onto it, and then expand the partition.

    (2) It did report that it found errors on my hard drive (which one, it didn't bother to say, because of course Windows 10 never bothers to be specific about anything) and needed to restart to fix them. So I let it restart, but forgot I needed to hit F12 during the BIOS screen to actually boot into that drive. But I guess Windows just marks the bad drive as needing repairs, because the boot process was nonetheless interrupted by a message saying it would spend some time checking the disk. I let it do its thing, and then it finished booting into my regular setup. I got some error messages saying it couldn't run some DLL files; I'm guessing these were stored where the errors on the disk were and got wiped. (Didn't bother to jot down what they were, but it'll probably give me the same errors next time I restart, so I'll do it then.) On a whim I decided to test the sound again... and now it's working fine. LatencyMon isn't spiking, I can watch YouTube videos just fine, the whole nine yards.

    So that means there are three possibilities: (A) The problem was caused by the disk error this whole time, somehow. (B) The problem was fixed by an update that installed the last time I shut down. (C) The problem was caused by one of the drivers it can't load anymore because of the missing files, and I'm not experiencing it because Windows has reverted to a default driver for now, but attempting to re-install the driver will re-introduce the issue.

    Most likely it's not C, since I already tried uninstalling the only non-default drivers I knew I had and that did nothing, and the other install is working fine. I'll keep you posted.

    EDIT: Actually, I do have one question. Why was my new install able to detect the errors on the hard drive, but the old one wasn't? Is it because it can't examine its own boot drive?
      My ComputerSystem Spec

  10.    21 Aug 2018 #20

    It did report that it found errors on my hard drive
    - from your description, the 'dirty bit' was set on the system disk/Windows partition and chkdsk had to be run (on restart). If so, that was a file system corruption problem in the used part of the disk.

    It sounds as if you have two disks with Windows installed on them in your PC??

    Without an analysis of the original cause wondering what the problem was becomes just a guessing game. Maybe something installed or configured on your old build... maybe something carried over when upgrading... maybe you now have a later version of something with a clean install....

    EDIT: Actually, I do have one question. Why was my new install able to detect the errors on the hard drive, but the old one wasn't? Is it because it can't examine its own boot drive?
    Depends on whether any check was ever run.

    Glad it's now working for you although most abhor clean installs.
      My ComputerSystem Spec


 
Page 2 of 2 FirstFirst 12

Related Threads
In 1803 build 17134.1 32-bit (x86) as released on 30th April creating a system image fails with "The RPC server is unavailable. (0x800706BA)". This happens with an upgrade or a clean install. Creating a system image works correctly in 1803 x64,...
Hello. I need Help Regarding my Laptop Freezing Problem. My Laptop Hardware. Intel Core i7 4510U 2.0 GHZ 1TB HDD 8GB RAM Intel Build in graphics card Windows 10 Home x64bit
Windows Defender takes ~10 seconds to open from system tray icon in AntiVirus, Firewalls and System Security
I've noticed that when my computer first boots up, Windows Defender opens almost immediately when I double-click the system tray icon, but after opening it the first time, subsequent attempts take ~10 seconds after double-clicking the icon. Any...
How can one decrease the duration of display to 2 seconds of the (system) messages Win 10 shows: http://i.imgur.com/b7cMcWM.png
As soon as I stop typing, the system goes to sleep after approximately 5 seconds. All my power options is Never Sleep. Any ideas would be very much appreciated. Thank you. :cry:

Tags for this Thread

Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 05:05.
Find Us