Usb 3.0 host controller MSI gaming 970 gaming board

Page 1 of 2 12 LastLast
  1.    23 May 2018 #1

    Usb 3.0 host controller MSI gaming 970 gaming board


    I have an MSI 970 gaming board with windows 10 64bit installed and everytime and mostly all the time with this External 6tb seagate hub drive when plugged in Windows does not see but it is seen in the BIOS also seagate does not have any drivers for it since its suppose to work out of the box with windows 10. i have attached device manager issue. I can not figure out for the life of me why it keeps doing this. is it something in the BIOS? the bios version is 22.4. there are no new bios versions.Click image for larger version. 

Name:	usb 3.0 970 board.jpg 
Views:	48 
Size:	105.0 KB 
ID:	189929
      My ComputerSystem Spec

  2.    23 May 2018 #2

    I have a GA-970A-UD3P with a VIA VL805 USB3 controller in it. Windows 10 uses a default driver that works fine for me, but I have used the VIA driver that gigabyte offers before to see if it improved performance (it did not, but it worked fine) and it showed the same HUB with "!" behavior. It always installs the main driver (xhcdrv.inf) then shows a "!" over the VIA HUB and I have to point that to the driver folder as well and then it installs the second part (ViaHub3.inf). It's a 2 part install for me.

    I'm not sure if you have the VL805 (MSI shows VL806 if I looked at the right board version, it uses the same driver, shows up under WIN7x64 section on MSI's site but Gigabyte shows the same driver for WIN10x64 too), but I'm attaching that driver if you want to try it on yours. I pulled just the driver out of the 11.3 megabyte VIA 4.90a EXE installer package because it installs extra, useless crap and fails to install the HUB driver anyway (did the same on WIN7 and 10). It is not modified in any way, just that it has to be installed with Device Manager rather than clicking an EXE.

    "VIA USB 3.0 eXtensible Host Controller - 1.0 (Microsoft)"
    point that to "xhcdrv.inf"
    "USB Root Hub (USB 3.0)"
    point that to "ViaHub3.inf"

    By "point that to", I mean device manager, update driver, "browse my computer for driver software" and navigate to where the driver INF file is.

    VIA USB3 4.90a 6.1.7600.4903.rar Newer drivers in the next post, but I found them a bit slower, so I'll leave these here too, just in case.

    After that it looks like this:
    Click image for larger version. 

Name:	via.jpg 
Views:	6 
Size:	121.6 KB 
ID:	189984
    Last edited by Quexos; 24 May 2018 at 09:45.
      My ComputerSystem Spec

  3.    24 May 2018 #3

    dont use the above drivers are very old.
    use the newer ones whql:
    -https://www.win-raid.com/t834f25-USB-Drivers-original-and-modded.html (go in via section and download 64 bit drrivers)

    64bit VIA USB 3.0 drivers are dated 07/18/2017, WHQL certified and suitable for the VIA USB 3.0 Controllers
      My ComputerSystem Spec

  4.    24 May 2018 #4

    boombastik said: View Post
    dont use the above drivers are very old.
    True, but they work. I tried the newer ones and they were quite a bit slower for me. 48-52 MB/s vs 72-80 MB/s with Windows default driver. That said, I am not familiar with the source of the newer version, but they do seem legit, installed fine, and worked well enough, maybe better for the OP.
    Last edited by Quexos; 25 May 2018 at 18:31.
      My ComputerSystem Spec

  5.    24 May 2018 #5

    They are legit for sure whql and i use them.
      My ComputerSystem Spec

  6.    24 May 2018 #6

    thanks i will look into it both ..
      My ComputerSystem Spec

  7.    24 May 2018 #7

    Here's another vote for Fernando/Dieter's excellent drivers at Win-RAID.com. I've used them on many of my systems with good results, and have recommended them here at TenForums to many other users who've fared well with those drivers, too.
    HTH,
    --Ed--
      My ComputersSystem Spec

  8.    24 May 2018 #8

    I installed Q's recommendation and there was an issue with accessing the drive it would not respond while moving folders around would take a whiel to respond then crash so i uninstalled them the app host controller 3.0 and they work fine now WTH. i will try the other ones if this one fails thanks fellas.
      My ComputerSystem Spec

  9.    24 May 2018 #9

    Boombastic's newer drivers seem to be the best bet if the Windows 10 built in version won't work for you (they do for me). And some notes from my tinkering:

    1. When switching these drivers Windows wants Windows Update service running (I disable it and got errors until turning it on).
    2. When switching from my older to the newer, or vice versa, you need to uninstall the device(s) (controller and hub) and tick the box for "delete driver" and reboot or Windows tries to ram the other one back in, or one driver version for the Controller and another for the Hub and you get the "!" on it. Ugh. Finicky stuff.
    Last edited by Quexos; 25 May 2018 at 18:32.
      My ComputerSystem Spec

  10.    25 May 2018 #10

    In haswell platform the via usb3 default windows 10 drivers don't work (pcie card addon).
    In a p5q (775 core 2 duo) platform the pcie addon via usb card works without need to install the via drivers.
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
pcie sata controller cards for 2010 board speed. in PC Custom Builds and Overclocking
hi i have question about pcie speed from 2010 board. i have AMD asus m2n sli deluxe and the ports are sata3 (300 mbps) but i have spare pcie-16 x8 slot. right now the harddrive is acer 320gb slow harddrive. now if i got one of those pice sata6...
Roccat Isku FX MM Gaming board in Drivers and Hardware
Anyone out there got one of these keyboards? Having read, and reread the papers I still cant find out how to keep the keyboard lit up. Its on fade/brighten at present.
Hello, Sorry if this post already exist somewhere else, I checked through all of the category's pages and didn't find anything related. Reasoning behind this whole endeavor: I want to separate Programming, gaming and DBA activities from my...
Hello : Since I updated to win 10 . in device manager I'm having a problem with my usb host controllers , looks like I need a update for win 10 .49848
BSOD when gaming and not gaming in BSOD Crashes and Debugging
BSOD persists after fresh install of Windows 10 from windows 8.1, happens when playing heroes of the storm quite often but has happened while browsing pinterest/facebook.
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 11:05.
Find Us