Windows 10: Can't print from any app in Windows 10.

Page 2 of 2 FirstFirst 12
  1.    09 Aug 2015 #11

    Angeltam said: View Post
    How do I upgrade my printer driver in Windows 10? Going to try the Windows 8.1 driver I guess.
    I am assuming the printer is connected directly to the computer? If so, go into Settings>Devices>Device manager. Locate your printer in Device manager and right click. Select 'Update Driver Software...'. In the box, select 'Browse my computer for driver software'. Make sure the box beside 'Include subfolders' is checked. Navigate to the folder where the driver is located and click Next. It should start installing the driver.
      My ComputerSystem Spec

  2.    31 Aug 2015 #12

    The same here. I upgraded to win 10 from Win 7 Ultimate two days ago, my printer is HP ColorJet 3800 connected to other computer on LAN and shared. First the printer did not show at all in printer list (I have let the other computer switched off during update, any importance of this fact?) I managed to get the printer work by playing with deleting the printers with "color jet" in name (somehow appeared there after reboots?) and freshly adding the shared printer with the other computer on. From then on ColorJet started to appear in printer lists in the apps and I could print on it - EXCEPT PDF FROM ADOBE ACROBAT :-((. I open Acrobat Reader XI - Czech ver 11.0.12. I open a PDF, go to File/Print menu, I select the ColorJet from the printers list (it is default anyway), hit Print, and nothing happens. I can print from Word, and I can print from any other app I tried - just Adobe Acrobat dos nothing. This is RATHER ANNOYING.
      My ComputerSystem Spec

  3.    01 Sep 2015 #13

    Solved - installing the shared printer (via Add device, then select shared printer) was just not enough for Adobe Acrobat. I had to install windows 10 universal printer driver for HP printers. This added a printer which now works properly with all apps. The other non-functional HP ColorJet printers that somehow reappear in "printers" after every reboot even when I removed them are still present in printers list, but I can live with that.
      My ComputerSystem Spec

  4.    02 Oct 2015 #14

    Had the same issue, uninstalled Nitro, deleted Nitro from printer list, rebooted and issue seemingly resolved. In my case, Excel refused to <save> new books as well. Issue seems to be resolved now.
      My ComputerSystem Spec

  5.    02 Oct 2015 #15

    Brilliant thanks!!!


    morrizorg said: View Post
    Had the same problem...
    Go Task Manager, look for Spooler Subsystem App and right click - End Task.. do it several times, I did it 6 or 7 times.
    then click start, type troubleshooting, go up left--View All--printer-- Advanced---Run as Administrator..
    then it will let you select printer to update driver.
    Problem solved.



    Edit: only working for Microsoft Print to PDF
    BRILLIANT THANKS that fixed it
    But how did you know that..... why does it have be this way?
      My ComputerSystem Spec

  6.    07 Dec 2015 #16

    Still having this issue although maybe slightly different than others. When i click print in any program from Word to Autodesk the program immediately becomes unresponsive. This happens when I try to export as well. I've reinstalled the programs in question, so it seems to be an error with all printers as it happens before I even can select which printer to use.

    I already tried fixing the spool server thing previously mentioned in the thread. That is not the issue
      My ComputerSystem Spec

  7.    01 Jan 2016 #17

    I'm having same problem with HP Photosmart 5520 and Win 10. Can only print from Google Chrome, Office 2007 and Acrobat Reader DC. Can't print from any Apps, Photo, Edge or IE. Brand new laptop with Win 10 pre-installed. HP says "ask Microsoft", Microsoft says "ask HP", Toshiba says "must be HP or Microsoft problem". When I try to print from WIn 10 designed software the print job is accepted, then stalls. Deleting it still remains stalled and I have to re-start the laptop to clear the printer queue. All solutions gratefully received!

    I have tried all the suggestions from HP and Microsoft and various forums, but still no joy.
      My ComputerSystem Spec

  8.    28 Aug 2016 #18

    hey all, got the same printer nothing happening.. have HPLJ1505 via USB and HP Officejet 7500 via usb. neither work. both show offline. restarting print spooler did nothing to docs hanning in queue. rebooted laptop(win10) and both printers. deleted print queue and tried again. notihng happened.

    fix: found running troubleshooter on both printers in Devices and Printers finally released print jobs.. all working again.

    NICE ONE MS.. :lp

    Hey MS, how about giving users control over drivers and print queues like in Win7? would that be tooo much to ask for?
      My ComputerSystem Spec


 
Page 2 of 2 FirstFirst 12

Related Threads
Solved Print to PDF in General Support
Is this a new feature of W 10? I do not remember adding anything 15532 Edit, guess it is http://wmpoweruser.com/confirmed-windows-10-to-include-native-print-as-pdf-option/
Cannot print Foxit pdf in Drivers and Hardware
Hello I have Windows 10 and HP Photosmart 5520 e-all-in-one-printer readily printing everything from any devices of mine (laptop, iPad mini). But I cannot print Foxit PDF. When I click print icon, or option in the file menu, I do not have "select...
Printer won't print. in Drivers and Hardware
About a month ago I bought a laser printer. It's a Samsung Xpress Multifunction M2070W. Starting today it will not print. I know the reason as a message comes up saying "Out of toner." I believe that there is still toner in it. This printer (and I'm...
hi guys, the printer on my compuer is a Lexmark E360dn, but the printer on the second computer is the OKI C710. I cannot enter preferences to force the colour printer to print in black. Is there any way to alter the printer preferences to...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 14:59.
Find Us