W10 update knocks out epson printer

Page 1 of 2 12 LastLast
  1.    19 May 2018 #1

    W10 update knocks out epson printer


    I have just installed the latest W10 update (version 1803) and can no longer print. I have an Epson EPL-6100 laser which is now 15 years old or so but this morning it was still working OK; now it is not.

    The Bonjour wizard does not help and Windows does not even detect it. What searches I have done have mostly found buggy sites and from Epson all I can see is that they have nothing for W10!

    Any ideas on how to get going again (short of a new printer!).

    Thanks.
      My ComputerSystem Spec

  2. Barman58's Avatar
    Posts : 2,802
    Windows 10 Pro x64 1803 - 17134.5 XP/Vista/Win7/Win8.1 in VM for testing
       19 May 2018 #2

    AFAIK Bonjour is an Apple product that is included with windows installs for working in Mixed networks (PC & Mac), so should not be an issue.

    It is sometimes the case that a major upgrade like 1803 will Disable/Remove some drivers, the usual way to solve this issue is simply to reinstall the driver. If you have the driver installer that was working with the last version of Windows 10, try that first, if this gives problems or you do not have access to it, the Epson Drivers are available at the link below ...

    Support & Downloads - Epson EPL-6100 - Epson

    This link has multiple options and should allow you to obtain a working system :)
      My ComputerSystem Spec

  3.    19 May 2018 #3

    Thanks for that. I have already been through the page you mention but it reported that no W10 drivers were available for the EPL-6100.

    The last driver update in the early days of W10, was a generic bodge of some kind on which I do not have any information.

    Annoying, though....
      My ComputerSystem Spec

  4. Barman58's Avatar
    Posts : 2,802
    Windows 10 Pro x64 1803 - 17134.5 XP/Vista/Win7/Win8.1 in VM for testing
       19 May 2018 #4

    That's not good, only thing I would suggest is to switch off the printer and then remove the existing driver, use the Device manager and select the remove all option, if offered, (if you do not have a specific entry in the add/remove programs),

    Once this is done make sure the printer is disconnected and reboot the system, once up and running normally connect the printer and switch it on - hopefully this will trigger the inbuilt driver installer and find the best available driver (which may be only a compatible device but at least will give you some usage), when this is complete if you have a "working" printer then wait a week or so and try to update the driver, if not your only option is probably to contact Epson (microsoft only supply drivers made by the manufacturers), and they sometimes lag behind changes in the OS.

    The problem is most companies have a support cut off date and large corporation are not really going to set this beyond around ten years as used by Microsoft and most business clients
      My ComputerSystem Spec

  5.    19 May 2018 #5

    As you say, not good. I did what you suggested but there was no (on screen) recognition of any new device when I plugged in the printer. Searching to 'add printer' came to nothing as the printer was not recognised at all. So end of the line?

    Thanks for your comments/help.
      My ComputerSystem Spec

  6. Barman58's Avatar
    Posts : 2,802
    Windows 10 Pro x64 1803 - 17134.5 XP/Vista/Win7/Win8.1 in VM for testing
       19 May 2018 #6

    I would give it a week or two just in case there is an Epson Driver released, 1803 was only officially fully available to the public on 8th May so it's still early in it's life cycle or try getting a reply from Epson to a specific query about support
      My ComputerSystem Spec

  7.    19 May 2018 #7

    Try this:

    (assuming you've done everything Barman suggested)
    With the printer Off and disconnected from PC, go to Control Panel > Devices & Printers > click on any printer shown (like MS Print to PDF) > on the top look for and click on Print Server Properties > click on the Driver Tab > look to see if you see the problem printer listed. If so, delete the driver > close Devices and Printers.
    Restart the PC and then try connecting the printer again. See if Windows finds it now.

    If not, try using the Add A Printer option in either Devices & Printers or in Settings > Devices > Printers & Scanners.
    Be sure you have your original Printer CD loaded or copied to Desktop to point the installer to.

    Or, try using the original printer driver CD or download to install the printer according to their instructions. But when you execute the installation file, run it in Compatibility Mode for Windows 7 or even XP.

    Hope that helps
      My ComputerSystem Spec

  8.    19 May 2018 #8

    Thanks for your suggestion. I did everything you suggested but I could not delete the driver for my old printer as it was 'currently in use'. This may be a file that did not print when I tried to do so after updating.

    Is there some way I can clear this logjam?
      My ComputerSystem Spec

  9.    19 May 2018 #9

    You may have to click "View", "Show hidden devices" in Device Manager to see the "Printers" entry. Also, don't let Device manager search for drivers. Instead, click "Browse my computer for driver software", then "Let me pick from a list of drivers on my computer".

    Ben
      My ComputerSystem Spec

  10.    19 May 2018 #10

    "I could not delete the driver for my old printer as it was 'currently in use'. "

    Do a Clean Boot (see Part 1 of this tutorial, pay attention to Step 5, picture is opposite of what you want) -
    Perform a Clean Boot in Windows 10 to Troubleshoot Software Conflicts

    After you restart with everything non-MS disabled, you should be able to delete print driver. Then re-install your Epson software but follow 'TV2's suggestion to run the setup.exe in Compatibility mode (r-click the setup to open dialog window) choosing the oldest OS, likely XP, and test install. If working, restart and re-enable the System Config items and choose the startup items that you REALLY need, in order to speed up start. Good Luck
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
I am using an EPSON printer on WIN 10 Pro. How do I change the printer port protocol from LPR to RAW. It seems to be better to use RAW not LPR. Just changing the protocol as shown in the attached graphic will not work. It stops with an...
Epson Printer Drivers for Win 10? in Drivers and Hardware
Hi does anyone know or think the 64 bit 8.1 drivers for my printer may work for Win 10? (64 bit) Epson does not offer Win 10 drivers Some sites offer the drivers but I try not to download things from sites I do not trust It could be the 8.1...
epson printer driver wont install in Drivers and Hardware
i've updated to windows 10 on my pc and i'm unable to download the driver for my epson sx235w printer to my pc. i've tried the install disc and also via the drivers online. each time it starts to download the drivers it gets stuck on the download...
cannot uninstall Epson Printer in Drivers and Hardware
Following upgrade to 10 I need to uninstall Epson Printer and reinstall. have initiated uninstall but it will not complete the process. Anyone any ideas how to achieve this please?
hi I have recently took the free upgrade to windows 10 from windows 8 how ever now my Epson dx8400 all in one printer will not be recognized by 10 worked fine on 8 just plugged usb in and set up automatically 10 wont pick up at all ive downloaded...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 01:55.
Find Us