Windows 10: 'No pen or touch input is available for this display' after reinstall

  1.    17 May 2018 #1

    'No pen or touch input is available for this display' after reinstall


    'No pen or touch input is available for this display' after Win10Home reinstall



    After five solid days of bashing my head against a wall* trying to get Win1709 to update to 1803 on my Tesco Connect Win 10 Home tablet, I finally resorted to doing a reinstall from an ISO/usb from Media Creator. (The old version of Win 10 worked fine, but new security updates were backed-up behind a repeated failing/redownloading 1803 update and never installed).

    .

    The fresh installation won't respond to any touchscreen access (also is stuck in portrait mode), which is pretty useless for a small tablet with no external mouse or keyboard.

    Hardware is Tesco Connect 8, manufactured by Viglen (both reasonably big-name companies here in the UK), otherwise I don't have much info on the hardware.
    Atom processor; 1GB RAM, 32bit Win 10 Home, 32GB SSD, with a slot for a 32GB microUSB card

    .

    I found these drivers, but they don't help.
    download.viglen.co.uk - /files/Tablet_PC/Connect 8/

    .

    I have looked for other drivers via a Windows "Check for updates". Windows found a few minor ("Defender", MST etc) updates and a couple of intel drivers, which didn't help.




    Windows>System>About shows:
    Device Specifications: Pen and Touch: No pen or touch input is available for this display

    (the older (1709) version said "Limited Touch Support with 10 Touch points")

    .

    The machine is stuck in portrait mode (it used to rotate to landscape with the machine was rotated). The Action centre has no button for "Rotation Lock" and Windows> settings doesn't have an option to add it to the Action Centre. I can toggle 'tablet mode' on and off, but still no touch-screen.

    .

    I have rigged-up an external mouse via the microUSB/charger port (that is the only port, plus the uSD slot); The Accessibility on-screen keyboard works, so I can limp around to do some basic diagnostics, but can't (for example) do anything in Bios except look at the first page, as it needs an external keyboard, which I don't have.

    .

    I do have a Macrium image of the old, "won't do updates" 1709 version of Win10, so I could roll back to that if really necessary, but is there anything I can do to make the touchscreen on this new 1803 install work?



    TIA

    ------------------------


    * don't ask! - Stuff I tried to get the old version to update before giving up on it (probably redundant here, but included just-in-case):


    regular positive path update gives 0x800706ba

    Updates Troubleshooter gives 'Potential Windows UPdate Database error detected', not repaired.

    Standalone troubleshooter (file: (20170905.cab) gives "Ununexpected error has occurred. The toubleshooting wizard can't continue".

    sfc/scannow did not find any integrity violations

    Media Creation tool: 'We couldn't install... 0xC1900101 - 0x2000D

    0x800706BA - 0x20003 The installation failed in the SAFE_OS phase with an error during INSTALL_UPDATES operation

    new w10 install tool (Windows10Upgrade9252.exe) run from C: gives "Something went wrong, 0xc190020e"

    Resetting PC (from W10 Recovery menu) gives "There was a problem resetting your PC. No changes were made


    Deleted all user data and apps gaving about 9GB freee disc space. Shrunk pagefile.sys from 2.GB to 1.xGB

    Dism.exe /online /Cleanup-Image /StartComponentCleanup had no impact on WinSxS folder size

    Tried using an 32GB microSD card to run all external installers/diagnostic tools. Windows didn't want to use any of the free space on it.


    Fresh Start ("Refreshing your PC") gives "There was a problem resetting your PC. No changes were made


    .
    Last edited by BobSter2; 17 May 2018 at 07:38.
      My ComputerSystem Spec

  2.    19 May 2018 #2

    I've given up and gone back to Win10Home 1709 (using macrium) now'. version 1709 has a Human Interfaces Devices driver that 1803 didn't:

    "KMDF HID Minidriver for Touch 12C Device"

    Please, what I do need to backup that driver from v1709 and install it on a (otherwise useless) v1803 ?

    thanks

    .
      My ComputerSystem Spec

  3.    19 May 2018 #3

    Try this TenForums tutorial, and use it to back up the "missing" driver in 1709. Then, after you install 1803 you can follow the same tutorial to add it back in. Backup and Restore Device Drivers in Windows 10.
    HTH,
    --Ed--
      My ComputersSystem Spec

  4.    19 May 2018 #4

    thanks ed, I've bookmarked it for when I've regained the emotional strength to tackle it again!
      My ComputerSystem Spec

  5.    19 May 2018 #5

    Actually, looking at it closer, I said the driver is missing in ver 1803. Infact, maybe it is the device which is 'missing' (maybe because the driver is missing ??).

    (Also, "HID compliant touch screen")

    From the linked Tutorial, I can't see how i would install the driver without the device (the touchscreen) being visible in Device Manager ???

    Click image for larger version. 

Name:	SideBySide.jpg 
Views:	17 
Size:	36.8 KB 
ID:	189464

    .
    Last edited by BobSter2; 19 May 2018 at 17:00.
      My ComputerSystem Spec

  6.    20 May 2018 #6

    Have you tried clicking the "Show hidden devices" item in the View menu in Device Manager? It should show you anything that's been present on your machine in the past, but may not be currently "reporting in" during the last OS bootup. You should find it when you turn that view on.
    Let us know, please!
    --Ed--
      My ComputersSystem Spec

  7.    21 May 2018 #7

    EdTittel said: View Post
    Let us know, please!
    --Ed--
    I went back to 1709. Now Windows Update stopped forcing 1803 on me (which was the original problem I was trying to solve), so I was inclined to just leave it.

    Out of morbid curiousity, I have today tried the 'ISO on a USB' method which previously got me to the '1803, but no touchscreen' status described in the first post.

    It failed to update (five times, with slight variations on how I did it, each time, to experiment) - error; 0x800706BA - 0x20003.

    For the last couple of days Windows Update has been saying I'm Up to date on 1709, so I'm going to leave it at that until something changes, I think....

    btw, if anyone has a similar problem in the future and stumbles across this thread, I found a (long) thread here, which has a few pointers from people who were trying to deal with the same issue back at 1511, including a downloadable full set of drivers for the (16GB drive version) of this device (on page 9).
    Black Friday - Windows 10 Connect 9 Tablet - £49 (Half Price) @ Tesco Direct - HotUKDeals

    .
      My ComputerSystem Spec

  8.    03 Aug 2018 #8

    I have issue 1803 will not install on that tablet. Found this thread today Cant install April updates 1803 - Microsoft Community After fighting the device for most of the day; managed to get latest Win10 preview installed. May try to downgrade it to 1803; only issue that I can think of is licensing - might have to acquire another license. In any case the current latest preview <finally> installed. Haven't checked the other errors you saw, Bob. If I downgrade to 1803 I'll let you know if I see anything .

    Ok - update. Attempted downgrade to 1803 but failed with same error message as 1709 to 1803. So I'll stay on the preview 17728.rs5 for the time being, which seems to work OK. Also, on attempting the downgrade it was going to do a fresh install.
    Last edited by zingy09; 03 Aug 2018 at 15:48.
      My ComputerSystem Spec

  9.    05 Aug 2018 #9

    yer, i'm still on 1709. I'm happy there. Everything else is too stressful.

    At least they have stopped trying to force 1803 on me.
      My ComputerSystem Spec


 

Related Threads
Taskbar and touch input in General Support
Recently I have noticed that the taskbar will not respond to ANY touch input, but works perfectly fine with the mouse. I only noticed this in the past week, I have gone so far as to reset the system and wipe all data to reinstall, and the issue was...
Windows 10 touch feature is not optimized for smartboard and touch input does not work properly. Tapping on icons or on GUI does not work but moving works. Tapping, pinch zoom and scroll works perfectly on Google Chrome. When i pick up a pen, it...
I just upgraded from Windows 7 and I realized in Windows 10 the input method is bundled with the language. What I want is to display in English but have a default input method of Chinese. But in the language settings they are bundled and when I...
Machine -- Dell Previously using windows 7 before I was forced to update to windows 10. After allowing the machine to update, it reboot itself to start. What showed up is a blank screen with the message: Analog input cannot display this video...
My new PC has a blank screen with the message : 1. Analog input, cannot display this video mode. I recently upgraded from Win8.1 to Win10 on my new Dell Inspiron. I have an older PC right next to it with WinXP. Both are using Dell flat panel...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 12:20.
Find Us