Page 1 of 2 12 LastLast

  1. Joined : Jul 2015
    Posts : 4
    Windows 10 Pro 64 bit
       31 Jul 2015 #1

    Upgrade from 8.1 to 10: Hard drive no longer recognized.


    I just upgraded to Windows 10 as I planned to use the weekend to sort out any issues I might encounter during the upgrade. Well boy did I ever. My Seagate 3TB drive decided it no longer wanted to be recognized by Windows anymore. It shows up as a failed/deactivated drive in Disk Management as seen here: https://i.imgur.com/5EOU4Jf.png It also shows up in Speccy as a physical drive. I currently have 2TB of data on there (including an OS image I did just before the upgrade as an extra prep step), so reformatting the volume is not an option until I get the data off.

    Any advice on how to recover my data?
      My System SpecsSystem Spec


  2. Joined : Aug 2015
    Posts : 3
    Windows 10
       03 Aug 2015 #2

    Check these links. I can't remember which one but this is an emerging problem and one of these posters solved it.

    http://answers.microsoft.com/en-us/w...6-1f0d7792e60b






    http://answers.microsoft.com/en-us/w...1-7790aec7b2f3




    http://answers.microsoft.com/en-us/w...c-cc3c510d5f26
      My System SpecsSystem Spec


  3. Joined : Aug 2015
    Posts : 3
    Windows 10 64-bit
       04 Aug 2015 #3

    Win 10 cannot recognize large hard drives


    This definitely is an emerging problem, and it appears to be confined to large hard drives.
    My 64-bit Win 7 machine had two hard drives:
    Hitachi HDS721075KLA330 (Boot Drive)
    Seagate ST4000DM000 (4 TB data drive)
    This config worked very well in Win 7. When I upgraded to Win 10, BIOS still recognized the 4 TB drive, but Win 10 did not. I spent hours troubleshooting, and finally got Disk Management to see the 4 TB drive, but it reported it as 2 TB RAW, though I know for sure it was formatted 4 TB NTFS.
    No matter which of the four parallel ports I plugged the 4 TB drive into, it would not work.
    Fearful that I had lost my data, I installed the 4 TB drive into another computer (Win 7), and all the data was there, and it was clearly formatted NTFS.
    I then installed a 2 TB Hitachi hard drive in the Win 10 machine. Same problem, and this time Disk Management would not see either drive, even after waiting 45 minutes.
    Finally, I installed a 750 MB drive in the Win 10 machine, and it an very well. Unfortunately, I need the data on my 4 TB hard drive, so it looks like I might have to reinstall Win 7 until Microsoft fixes this.
    So, it seems very clear that Win 10 cannot handle large hard drives, at least in my particular hardware configuration.
      My System SpecsSystem Spec


  4. Joined : Jul 2015
    Posts : 22
    Win 7 x86_64 Enterprise, Win 10 Pro
       04 Aug 2015 #4

    Did you try flashing your BIOS? Just in case you don't have the latest version.
      My System SpecsSystem Spec


  5. Joined : Jul 2015
    Posts : 62
    10
       04 Aug 2015 #5

    Had this occur recently with a seagate 4tb but don't remember the OS having trouble with it (7, 8.1 or 10). Took the drive to my machine and it was recognized properly. I backed it up then ran diskpart clean. Took it to the machine having trouble and used disk management to create the volume and all 4 TB were recognized and it worked fine thereafter.
      My System SpecsSystem Spec


  6. Joined : Aug 2015
    Posts : 3
    Windows 10 64-bit
       04 Aug 2015 #6

    Skalli said: View Post
    Did you try flashing your BIOS? Just in case you don't have the latest version.
    Thanks for your response. My BIOS has no newer version. The 4TB drive works very well with Win 7 and Win 8.1, but when I install it in a Win 10 machine, no joy! Disk Management hangs endlessly and can't find it.
    Same for a 2TB drive I also tried in this machine.
      My System SpecsSystem Spec


  7. Joined : Aug 2015
    Posts : 1
    Windows 10
       04 Aug 2015 #7

    Similar issue here, I have two of the same computers - installed Windows 10 on both. I have all kinds of drives attached to both via USB 3.0 On one computer everything works fine, on the other it will not recognize a 1TB external drive. It's not listed in Disk Management or anywhere. I've unplugged/replugged, tried different ports, restarted, etc it just doesn't see it. I have plugged it into my other computer and it pops right up. I don't understand this and it's a big headache.
      My System SpecsSystem Spec


  8. Joined : Jul 2015
    Posts : 22
    Win 7 x86_64 Enterprise, Win 10 Pro
       05 Aug 2015 #8

    Hey again,

    I just remembered something when I was posting in another forum.
    Take a look into that KB article: https://support.microsoft.com/en-us/kb/2581408

    See this:
    Known Issues/Limitations

    Because the transition to a single-disk capacity of greater than 2 TB has occurred fairly recently, Microsoft has investigated how Windows supports these large disks. The results reveal several issues that apply to all versions of Windows earlier than and including Windows 7 with Service Pack 1 and Windows Server 2008 R2 with Service Pack 1.

    To this point, the following incorrect behavior is known to occur when Windows handles single-disk storage capacity of greater than 2 TB:
    • The numeric capacity beyond 2 TB overflows. This results in the system being able to address only the capacity beyond 2 TB. For example, on a 3 TB disk, the available capacity may be only 1 TB.
    • The numeric capacity beyond 2 TB is truncated. This results in no more than 2 TB of addressable space. For example, on a 3 TB disk, the available capacity may be only 2 TB.
    • The storage device is not detected correctly. In this case, it is not displayed in either the Device Manager or Disk Management windows.

    Many storage controller manufacturers offer updated drivers that provide support for storage capacities of more than 2 TB. Contact your storage controller manufacturer or OEM to determine what downloadable support is available for single-disk capacities that are greater than 2 TB.
    So, waiting might be the best option right now.
      My System SpecsSystem Spec


  9. Joined : Jul 2015
    Posts : 4
    Windows 10 Pro 64 bit
       07 Aug 2015 #9

    Okay guys a bit of a late update. Been busy and almost forgot I posted here. I did solve my issue but it involved having to purchase Seagate's data recovery software (which recognized my seagate 3tb drive), a 2nd 3tb HDD, and dumping the 'recovered' data onto the 2nd 3tb HDD. After that was finished, I re-formatted my old seagate drive as a GPT NTFS drive which allowed it to be recognized as one 3tb logical drive. The result now is that I do have a second 3tb drive (making my total storage space 7.75tb) although I did have to spend almost $300 for all of this.

    I really hope Windows 10 can figure out a way to fix this issue for future upgraders who run into the same issue. Not everyone can just go out and buy another 3tb hard drive.
      My System SpecsSystem Spec


  10. Joined : Aug 2015
    Posts : 3
    Windows 10 64-bit
       07 Aug 2015 #10

    Problem solved by Win 10 Update


    Microsoft sent out a big update to Windows 10 last night. Win 10 now recognizes my 4 TB hard drive, so all is well
    Thanks to those of you who responded to this thread.
      My System SpecsSystem Spec


 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
CD/DVD drive not recognized
I installed Windows 10 as an upgrade to Windows 8. My Dell laptop does not see the DVD drive. I had no success getting the drive to work in Windows 8 and (maybe of course) it doesnt see it now. This seems to be a common problem I have tried numerous...
Drivers and Hardware
CD/DVD writable drive not recognized by OS after Win10 upgrade.
I have a SATA-1 TSSTcorp TS-H653 (not sure whether it is an F, G, H etc.) CD/DVD writable drive in an Inspirion 537s. I recently upgraded to Windows 10 Pro from Windows 7 Ultimate, but the drive is not recognized by the OS. However, the drive does...
Drivers and Hardware
W10 caused sound to not work, now sound card no longer recognized
When I first went from W8.1 to W10, everything worked except the sound. Now after several updates, the icon speaker in task bar has an x by it, and when I hover mouse over icon the message states that "no audio output device is installed." When I...
Drivers and Hardware
SSD drive no longer available in boot selections.
On start up I get a message that no OS can be found. The SSD drive, id'd as drive zero, is present in the advanced sata configuration secton of bios (3402). It is also available in the boot override portion of the boot section. It does not show...
Installation and Setup
What is the Best Hard Drive?
Read more: https://www.backblaze.com/blog/best-hard-drive/
Windows 10 News
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:55.
Find Us
Twitter Facebook Google+



Windows 10 Forums