Windows 10: Samsung SSD 850 Evo Performance

Page 1 of 2 12 LastLast
  1.    13 May 2018 #1

    Samsung SSD 850 Evo Performance


    I recently bought a Samsung SSD 850 Evo which i cannected to my MS Surface Pro 2 running Windows 10 Pro using a Type C usb Sabrent Cablrle. After formatting the drive i tried to invoke Rapid Mode but failed. The Magician software does not allow me to do so. I have downgraded Magician to V4.4 but the same happens. Any ideas?
      My ComputerSystem Spec

  2.    13 May 2018 #2

    So are you trying to run the 850 externally?
      My ComputersSystem Spec

  3.    13 May 2018 #3

    Yes thank you
      My ComputerSystem Spec

  4.    13 May 2018 #4

    Its designed to be an internal drive.
      My ComputersSystem Spec

  5.    13 May 2018 #5

    Thanks for the prompt response,

    Why is that? Are you saying that Rapide is only working with internal disks or that the disk is to be used as an internal disk?

    I have seen so many videos showing the disk used as an external disk.

    BTW Amazon are selling the bundle Sabrent USB Type C cable and the Samsung EVO 850 1TB SSD.
      My ComputerSystem Spec

  6. Anak's Avatar
    Posts : 429
    10 Home 64-bit | v1803 | Build -17134.345
       13 May 2018 #6

    What type of enclosure are you using? If you're going to cobble this together you have to make sure everything is compatible.

    There are just a couple things you’ll want to look out for:
    1. Ensure it’s designed for 2.5" drives.
    2. Make sure it supports UASP, which allows SSDs to transfer files faster over USB.

    Source: https://gear.lifehacker.com/build-yo...age-1763354004
    Is that bundle the "Sabrent USB Type C cable and the Samsung EVO 850 1TB SSD" the one you're using; Do you have a link for it?


    Have you tried Magician 5.2.0? There's supposed to be some minor bug fixes. If you haven't tried 4.9.7 click on the "Read more" button to see the D/L link.

    I'd try to use the 4.9.7 first if you haven't tried it, according to this Samsung Forum thread v5 on up uses server verification where v4.9.7 down doesn't: Samsung 850 EVO "This Drive is Not Supported" with Magician 5? SOLVED v4.9.7 still has some bugs but works better than the others. See accepted solution below the thread starter's post.
      My ComputersSystem Spec

  7.    13 May 2018 #7

    Dear Anak,

    I don't use any enclosure. The SSD connects to the cable's one end via a 1x15 PIN and 1x7 PIN. At the other end the cable has a Type-C USB end, which I connect to my laptop.

    I did try Magician, both V4.4 and V5.2 and none seem to allow me to deploy Rapid Mode. In both cases the Rapid Mode buttons are greyed out.

    Is it possible, that the software does not recognise the combo's ( cable and Samsung 850 EVO SSD ) capabilities?

    Cheers

    Nick
      My ComputerSystem Spec

  8.    14 May 2018 #8

    I don't think Magician supports Rapid mode except when you have a super-speedy M.2 or mSATA (depending on the drive -- yours is mSATA) connection. It's because you're accessing it via USB that you can't turn this feature on.
    HTH,
    --Ed--

    PS: As it happens, I've got that Sabrent device with an mSATA 850 EVO 1 TB SSD plugged into it. I just went into Magician to check and here's how it looks:
    Click image for larger version. 

Name:	image.png 
Views:	3 
Size:	40.0 KB 
ID:	188631
    As you can see it shows up as USB, so no support for Rapid mode is allowed.
      My ComputersSystem Spec

  9. Anak's Avatar
    Posts : 429
    10 Home 64-bit | v1803 | Build -17134.345
       14 May 2018 #9

    Apologies on the late reply, I didn't get an email note saying there were postings. Nice find Ed!
      My ComputersSystem Spec

  10.    14 May 2018 #10

    Thank you
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
Solved Samsung 960 EVO NVMe performance... in Performance & Maintenance
My new system is based on the Asus Prime Z370-A MB, that has two PCIe (x4), M.2_1 and M.2_2. Both of the sockets are populated with Samsung SSD 960 EVO 250 GB M.2 cards. Windows 10 setup had selected the M.2_1 drive and installed without any...
Not sure why this happened, but got a BSOD when running the benchmark I've run several times before as I've tweaked my new build. Any insight that can be provided would be appreciated.
Source: CES 2017: Samsung unveils new gaming PC — the Samsung Notebook Odyssey - Windows Experience Blog
Trying to install Samsung SmarThru office V2 for my printer/scanner, but Windows 10 reports the signer of the executable is not trusted, I downloaded from the Samsung website and the signer is shown as Samsung. There seems to be no way to bypass...
I have just upgraded to Windows 10 and am getting extremely slow performance from my Samsung 850 Evo SSD. Running Samsung magician to test my benchmark performance, I am getting: Random read/write (IOPS) of 16483/17594 respectively Seq...

Tags for this Thread

Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 02:14.
Find Us