Windows 10: M.2 NVMe SSDs in Raid 0 array? Solved

Page 1 of 2 12 LastLast
  1.    10 May 2018 #1

    M.2 NVMe SSDs in Raid 0 array?


    ASRock Z370 Professional Gaming i7 LGA 1151 mobo
    Samsung 960 PRO M.2 NVME PCIe SSDs
    M.2 drives in M.2 slots 1 and 3 on mobo


    Can a RAID 0 array be created with the 2 drives?

    Is it advisable to do so?

    (I have learned over the years that not everything that CAN be done SHOULD be done - )


    ETA - thanks for moving to proper place!
    Last edited by 24c; 10 May 2018 at 13:35.
      My ComputersSystem Spec

  2.    11 May 2018 #2

    A friend of mine got me the instructions from an ASRock source - we'll see what happens - insert 'prayer' emoji here
      My ComputersSystem Spec

  3.    11 May 2018 #3

    Hi there
    no reason in theory -- note though in a RAID 0 array the whole thing is lost if one of the disks in the array becomes defective. However provided you have backup Disk failures are fortunately rare these days - at least at the home user level. So you have to judge whether the (usually massive) increase in speed for RAID 0 is worth the extra risk of having to perform data recovery from backup.

    Also your machine might not be able to give you maximum I/O throughput of 2 SSD's in RAID 0 -- depends on CPU and mobo.

    For Software RAID 0 in Windows define the 2 SSD's as a storage pool with no redundancy and use the total pool as a storage volume. This is effectively Software RAID but Windows doesn't call it that.

    As far as hardware RAID cards are concerned - consumer grade RAID cards are usually HIDEOUS - you are better off using Software RAID (in Linux run mdadm to create and set up RAID at the level you want). Decent hardware RAID cards are quite expensive as are things like SAS too.

    If you do use hardware raid on your boot device the drivers need to be loaded at boot time so if you create macrium stand alone backups you will need to ensure the RAID driver is loaded when you create the bootable media.

    Also if installing Windows on the RAID device(s) you will need to ensure at Windows install time the RAID driver is loaded or Windows won't see any HDD's.

    Cheers
    jimbo
      My ComputerSystem Spec

  4.    11 May 2018 #4

    jimbo,

    the guy who wrote the instructions never met my mobo - - things are not turning out well.
    If you check my comp specs, you'll see I have a pretty nice set up that should handle the 2 SSDs in Raid.

    Over the years I have had anywhere from 2 to 5 SSDs in RAID 0 - BUT- this is my 1st try with the M.2 drives.
    Since I have an array of computers to use, I can let the ASRock one sit there while I try to figure out what I did wrong.
    I just hate it when I follow the instructions step by step and it doesn't work - oh well - not 1st time - probably not last.
      My ComputersSystem Spec

  5.    11 May 2018 #5

    Hi there @24c
    what's not working.

    what hardware card have you got for RAID0 or are you using software -- and what if using software are you using.

    RAID is usually pretty easy to set up although I think I saw somewhere that W10 won't boot on HDD's that are part of Storage Spaces.

    I tend to use Linux though for holding large amounts of data - software RAID there works without any problems at all.

    If the hardware card is OK with correct drivers then in theory Windows should boot provide at install time you "inject" the RAID driver. You'll need to do a clean windows install though for this to work properly (if it works at all -- Windows might detect RAID and refuse to boot -- I don't have a hardware card so I can't say).

    Anyway post back - as I'd be interested in this -- I can get a decent RAID card (don't ask where !!!!!!) later to test with.

    As well as defining the RAID array it will initially have to be formatted with a valid file system for windows boot. You might have to do that with a bootable usb / disk from the card manufacturer as that needs to be in place BEFORE any windows install. It's unlikely you can do it from within windows itself.

    Cheers
    jimbo
      My ComputerSystem Spec

  6.    11 May 2018 #6

    I am not using a RAID card - there are 3 M.2 slots on the mobo - slots 1 & 2 have Samsung 960 Pro 512 GB drives - slot 3 has a Samsung 960 EVO drive .
    I can create a RAID 0 array using the 2 960 Pro drives - but it is not recognized in the Boot options.
    Strip size was changed to the suggested 128KB after this pic was taken
    I have been messing with the BIOS all night trying to figure this out - no luck


    Click image for larger version. 

Name:	1.jpg 
Views:	1 
Size:	156.4 KB 
ID:	188236Click image for larger version. 

Name:	2.jpg 
Views:	1 
Size:	140.5 KB 
ID:	188238
      My ComputersSystem Spec


  7. Posts : 10,985
    Windows 10 Pro and Windows 10 Pro Insider
       11 May 2018 #7

    See if this helps

      My ComputersSystem Spec

  8.    11 May 2018 #8

    Hi there

    How are you attempting to create the RAID array, format it with a file system and start it.

    I see from the Bios that there's RAID config in it - but it still needs a file system to be formatted on it.

    See what GPARTED shows when booting a stand alone partition manager -- GPARTED is downloadable anywhere (and free).

    Windows won't boot RAID unless it sees a "single Disk" in the case of RAID 0 so you will need to have this array formatted and bootable .

    If windows can't see the boot sectors / boot efi partition in case of efi then it won't boot.

    Test it also with a Linux Live distro - you don't have to know anything about Linux just boot and see from the file manager if the HDD's (SSD's) are seen either as 2 discrete disks or a single volume -- if you get into command mode on the Linux live distro just type lsblk -- this will show if the RAID 0 array is reachable,

    Cheers
    jimbo
      My ComputerSystem Spec

  9.    11 May 2018 #9

    @essenbe - thanks for the video - it was pretty much the same instructions I had - with the addition of the d/l folder - I installed the drivers as suggested - ended up with the below pic - Drive 2 - unallocated space is the RAID drvie - out of frustration I decided to format the drive and when it finished the "can't install" deal was still there - again out of frustration - I hit NEXT and Windows installed to the drive <- Good News/Bad News -> Windows will not boot and the drive is not listed under boot options - BUT - progress is being made -break time -

    Click image for larger version. 

Name:	1.jpg 
Views:	1 
Size:	1.06 MB 
ID:	188255
      My ComputersSystem Spec

  10.    11 May 2018 #10

    booted to Windows install USB - repair start up - Windows 10 installation is listed - can't repair - tried 3 times

    boot up error: File\Windows\System 32\winload.exe
    error code: 0xc000000e

    booted to Acronis True Image - was going to install back up to new RAID0 - drive wasn't listed as a destination option.

    The Array is there - Windows seems to be installed on it - BUT - it is not a viable boot option
      My ComputersSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
Got a bug here that is driving me crazy. I had Windows 10 Pro V1709 32bit running on RAID1 (mirrored). This PC was running very slow after KB4074588 (but that is another story), so I decided to replace the two mirrored 500GB HDDs with a 500GB SSD. ...
I built my system with a Samsung 950 PRO m.2 NVMe SSD as the Windows 10 boot drive (C:), plus a pair of old-fashioned SATA-III hard drives configured in RAID1 as my data drive (D:). The SSD is plugged directly into one of the m.2 slots on my...
System: Dell XPS 8300, i7-2600, 3.4 GHz, 16 GByte memory running Windows 10 PRO. Currently the boot device is a Samsung 850 EVO 500 GB. The motherboard is a Dell 0y2mrg containing an H67 Express Sata/6 controller(chipset). The performance is very...
Having gone from windows 7, to 8 to 8.1 to 10 without a reinstall I've started to have a few issues so I've just reinstalled windows to a new drive. Trouble is, I didn't think too much and left the old RAID array connected so the recovery and EFI...
Solved Recreating RAID 5 Array AMD in Drivers and Hardware
I updated to Windows 10 Pro with a clean install and had issues with my RAID array showing up as raw format. I was able to take a backup of it from my W7 drive then rebooted into W10 deleted the array in Disk Management, deleted the array in the...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 20:39.
Find Us