Epson V300 not working properly after April update

Page 1 of 4 123 ... LastLast
  1.    08 May 2018 #1

    Epson V300 not working properly after April update

    After the April Windows 10 update, my Epson V300 scans one page as usual. When I click on the scanner icon to scan another page, the top of a box with Epson in the caption flickers at the bottom left of the screen, and the Epson scanning utility displays Not Responding. Closing the Epson utility does not restore scanning. I have to reboot to scan one more page. Otherwise, I am not having problems with the April update and would rather not revert back.

    I uninstalled my printer and scanner and all associated software, and reinstalled them. This made no difference. I'm running the latest Epson software from the Epson website.
      My ComputerSystem Spec

  2.    08 May 2018 #2

    When you uninstalled them....were they powered off and the cable connecting them to the PC was unplugged?
      My ComputerSystem Spec

  3.    08 May 2018 #3

    Yes. USB cables unplugged and powered off.
      My ComputerSystem Spec

  4.    08 May 2018 #4

    The only other alternative would be a clean install.

    I went the upgrade path myself from 1709 t0 1803 just to see what would work and what would work on my system along with my peripherals. My USB/3.5mm sound adapter doesn't work now. So I'll be doing a clean install with in the next 2 to 4 weeks.
      My ComputerSystem Spec

  5.    08 May 2018 #5

    I seem to have solved the problem. After a reboot, I scanned a page, then I tried to scan a second page. When the Epson software froze, I closed the program. I forgot to mention that the scanner also was locked on and couldn't be turned off when the Epson utility froze. To turn off the scanner, I unplugged it, and I also disconnected the USB cable. Then, without rebooting, I plugged in the scanner and connected the USB cable. It's now working fine.
      My ComputerSystem Spec

  6.    09 May 2018 #6

    Update: My "solution" only holds during the same session. When I reboot, Windows hangs during bootup. Hitting the reset button causes the computer to boot normally. Scanning then works on one page only. To continue scanning, I have to close the Epson utility when it freezes on the second attempt, then unplug the scanner and plug it back in. Thereafter, scanning works normally until I reboot, when I have to go through the above procedure again.

    This is a nuisance, but better than a clean install, since I don't scan every day. I did a clean install when I upgraded from Windows 8.1, and it's something I will put off as long as possible.
      My ComputerSystem Spec

  7. Compumind's Avatar
    Posts : 502
    Windows 7 Pro, 10 Pro, Various Linux Builds, Internet Security
       09 May 2018 #7

    Hi john999 -

    Just chiming in... Let's try something simple...

    1) Have you called/emailed Epson support about this?

    2) Does Epson have a "clean uninstall" tool for you to run? (remove errant registry entries and drivers.)

    3) Disconnect the V300 when the computer is powered off, then boot. Look in Device Manager and see if there are any entries left under USB devices/Printer/Scanner. If there is any entry left over by the V300 delete it and reboot again. Then plug-in the scanner first and see if the device PnP's on it's own. Test.

    If OK, install the Epson software for your build of W10 and test again. Reboot to be sure.

    Please let us know.

    Cheers! :)
      My ComputerSystem Spec

  8. Phone Man's Avatar
    Posts : 920
    Windows 10 Pro 1803 64 bit
       09 May 2018 #8

    My Epson v300 Photo was also messed up. I uninstall the 3 software items in Program and Features.
    Downloaded and installed new software.

    Driver 1st then Event Manager and then Copy Utilities.

    The Driver lets you do a normal scan.
    Event Manager controls the 4 buttons on the scanner.
    Scan, PDF, Copy, E-mail
    Scan saves file.
    PDF saves scan as a PDF.
    E-Mail opens a new E-mail and adds the scan file.
    Copy lets you send to a printer.

    Mine is working fine now.

      My ComputerSystem Spec

  9.    09 May 2018 #9

    Re Compumind suggestions: I haven't contacted Epson support. They don't have an uninstall tool online.

    I followed your suggestion to delete the entries under USB Devices in Device Manager and also uninstalled the scanner and printer again to the best of my ability. Now the situation is better in some respects but overall worse. When I actually get to Windows 10, the scanner works fine on most but not all bootups. The problem is that it takes many resets to get a bootup that doesn't hang. I keep resetting until I get to Preparing Automatic Repair, then wait for the screen advising that Automatic Repair failed. (It always fails.) Continuing to Windows 10 works sometimes but not always. When it doesn't, I keep resetting until I get back to Preparing Automatic Repair.

    A clean install would be sheer misery, but so is the current situation.
      My ComputerSystem Spec

  10. Compumind's Avatar
    Posts : 502
    Windows 7 Pro, 10 Pro, Various Linux Builds, Internet Security
       09 May 2018 #10

    @john999 -

    Certainly not a simple problem. I would contact Epson Technical Support, rather than banging your head.
    When/if this is resolved, perform a bare metal backup in case you have to restore your entire system.

    Acronis True Image is a good product or you can use EaseUS Todo Backup Home. Free trials.

    Let us know how you do! :)

    P.S. Do you have another W10 system of the same build to test the Epson software?
      My ComputerSystem Spec

Page 1 of 4 123 ... LastLast

Related Threads
I have a sades spirit wolf 7.1 headset and since the recent feature update it doesn't work at all when plugged in, as audio just continues out of my speakers. I've uinstalled and re-installed all related devices and drivers with no solution in...
Hi everyone! I noticed some months ago that Windows Update was not working properly. While fully connected to the internet, it told me: "we cannot connect to the updateservice ..." Looking at my internet connection, I noticed that inside Windows...
Hi there I have a folder / key in Regedit that I want to delete -- have given all privileges Exit regedit enter regedit again -- previous entry STILL in the registry -- same after reboot/ How do I SAVE changes -- if this tool is broken...
After the Anniversary update (version 1607 via Windows Update), Search doesn't work properly. (I have re-started again). If I enter a search term ("Restore") on search bar next to the Start Button I get Best match: "Recovery, Control Panel" at the...
start not working properly after update in Windows Updates and Activation
After i have installed the last set of updates, i can no longer left click on start. When i click on the option to choose start up apps, everything is greyed out.
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 03:20.
Find Us