Windows 10: Epson V300 not working properly after April update

Page 4 of 4 FirstFirst ... 234
  1.    2 Weeks Ago #31

    I had the same issue -- Epson V500 scanner, Windows 10 x64. It worked fine up until around April 2018, when I started to see Epson Scan freeze while starting up, freeze in the middle of a scan, or "cannot communicate with scanner" errors. Reinstall/reboot didn't help.

    What DID help was hasappra's solution posted earlier in this thread: i.e. changing C:\Windows\twain_32\escndv\escndv.exe to Windows XP SP3 compatibility mode for All Users. I've managed to scan 3 pages already, where I couldn't get through a single page before.

    Thank you! Wish Microsoft and Epson support was as useful as this forum.
      My ComputerSystem Spec


  2. Posts : 3
    Windows 10 64-bit
       1 Week Ago #32

    I can confirm this occurs on seemingly all Epson scanners that use the original Epson Scan (which in my opinion is still the easiest especially for scanning negatives and films since it auto-crops etc). I have tried V300, v600 and V700. Epson Scan has not technically been updated since 2009, which is a problem. The new "Epson Print & Scan" app from the Windows store is a complete joke and lacks every feature including the ability to set save location, image format or anything above 300 DPI.

    Setting the program to Windows XP SP3 compatibility mode will generally solve the crashing, but that causes other fatal problems (e.g., if you use the "Browse" to set a save location the options dialog will never close and the program still must be terminated). Process Explorer indicates that DWM crashes at the same time Epson does, which is relating to the Windows visual composition features that can't really be disabled in Windows 10.

    I am experimenting with running as admin + "disable fullscreen optimizations" + "Windows 7" compatibility. It seemed to be working OK for multiple scans including when minimizing, restoring and so forth. But after closing and reopening it crashed again as always (and when it does you see a small Epson window flicker at the bottom-left, sometimes it rises all the way to the top of the screen and then back down before everything locks up).

    According to others who have contacted Epson they have escalated the matter since it affects most of their products. Yet they haven't really updated the Epson Scan software in many years so I'm skeptical if they'll be the ones to push out an update but i hope so. I work with some non-profits in the historical/archiving sector and they have been affected by this since applying the Windows 10 update.
      My ComputerSystem Spec

  3.    1 Week Ago #33

    I had the same problem with my HP printer after the 1803 update. The only way I could get the printer reinstalled was by using the built in Administrator account and installing using the H.P. CD. For some reason the local User and Admin accounts were blocked from reinstalling software. I'm not sure if the problem was initiated by recent Defender definition updates.
      My ComputerSystem Spec


 
Page 4 of 4 FirstFirst ... 234

Related Threads
I have a sades spirit wolf 7.1 headset and since the recent feature update it doesn't work at all when plugged in, as audio just continues out of my speakers. I've uinstalled and re-installed all related devices and drivers with no solution in...
Hi everyone! I noticed some months ago that Windows Update was not working properly. While fully connected to the internet, it told me: "we cannot connect to the updateservice ..." Looking at my internet connection, I noticed that inside Windows...
Hi there I have a folder / key in Regedit that I want to delete -- have given all privileges Exit regedit enter regedit again -- previous entry STILL in the registry -- same after reboot/ How do I SAVE changes -- if this tool is broken...
After the Anniversary update (version 1607 via Windows Update), Search doesn't work properly. (I have re-started again). If I enter a search term ("Restore") on search bar next to the Start Button I get Best match: "Recovery, Control Panel" at the...
start not working properly after update in Windows Updates and Activation
After i have installed the last set of updates, i can no longer left click on start. When i click on the option to choose start up apps, everything is greyed out.
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 05:35.
Find Us