Windows 10: Epson V300 not working properly after April update

Page 2 of 4 FirstFirst 1234 LastLast
  1.    09 May 2018 #11

    Thanks for the help. I don't have another system to test the Epson software. The current Epson driver dates from 2009.
      My ComputerSystem Spec


  2. Posts : 150
    Windows XP, 7, 10, Linux - Various Builds -
       09 May 2018 #12

    john999 said: View Post
    The current Epson driver dates from 2009.
    I looked your product up on their website. Just amazing that Epson doesn't update their software.
    They say Windows 10 x32 and x64 compatibility, but I have my doubts.

    Epson Perfection V300 Photo | Perfection Series | Scanners | Support | Epson US
      My ComputerSystem Spec

  3.    09 May 2018 #13

    I've had the scanner for about 10 years, and it has lasted much longer than expected. I wonder if my Windows problems would go away if I replaced the scanner with a more recent model that is known to work in Windows 1803? Does anyone have a suggestion?
      My ComputerSystem Spec


  4. Posts : 823
    Windows 10 Pro 1803 64 bit
       09 May 2018 #14

    After installing the latest software my v300 works great and I am on 1803.

    Jim
      My ComputerSystem Spec


  5. Posts : 150
    Windows XP, 7, 10, Linux - Various Builds -
       10 May 2018 #15

    Phone Man said: View Post
    After installing the latest software my v300 works great and I am on 1803. Jim
    Well, that's good. Perhaps a few bits are messed up somewhere and john999's system just needs a reset. :)
      My ComputerSystem Spec

  6.    10 May 2018 #16

    Clearly all I need is a full uninstall of leftover old software bits, not a new scanner. I submitted a support request to Epson. For now, the scanner works after I close Epson Scan for not responding, wait a few minutes, then click Scan, and sometimes close the popup window asking if I want to use Troubleshooting Assistant (which is useless) one or more times. The computer booted up normally this morning for the first time after several bootup attempts went to Automatic Repair, which reported that the computer could not be repaired but proceed to boot up after I chose Continue.
      My ComputerSystem Spec

  7.    10 May 2018 #17

    I'm having the same problem with my V300 scan after updating windows to version 1803. Scans one page fine, but as soon as I try to scan another one it flickers at the bottom left of the screen and the epson scan utility becomes unresponsive.. I've tried uninstalling and reinstalling the software and drivers, nothing has changed. It only works fine with the Windows Store Scan App.
      My ComputerSystem Spec

  8.    10 May 2018 #18

    After deleting my scanner and printer and all associated software again, I reinstalled my HP printer and got it working properly with the new driver with help from HP Support. Then I installed the three Epson software packages -- Epson Scan, Event Manager, and Epson Copy. Then I connected my scanner. This time I was unable to scan even one page. On the first attempt, the box flickered at the lower left, and Epson Scan displayed Not Responding. After several attempts to restart it failed, I rebooted.

    The computer booted slower than it had before I reinstalled the scanner, but at least it didn't hang during bootup, as it had after earlier attempts to reinstall the scanner. I tried a scan and it worked. Then I tried another scan and it worked. And so on. Maybe the problem has been fixed. If it's still working after a couple of more bootups, I will come back and mark this as solved. The only difference between prior attempts to reinstall the scanner is that I'm using a newer HP driver for the laser printer. The Epson software is the same.
      My ComputerSystem Spec


  9. Posts : 2
    Windows 10 1803
       10 May 2018 #19

    Just wanted to chime in here and say that I am also experiencing this issue with the EPSON Scan utility after updating to Windows 10 version 1803. Make sure you file a report in the Feedback Hub about this!
      My ComputerSystem Spec

  10.    11 May 2018 #20

    I have marked this as solved because I have had no further problems since my last reinstall.
      My ComputerSystem Spec


 
Page 2 of 4 FirstFirst 1234 LastLast

Related Threads
I have a sades spirit wolf 7.1 headset and since the recent feature update it doesn't work at all when plugged in, as audio just continues out of my speakers. I've uinstalled and re-installed all related devices and drivers with no solution in...
Hi everyone! I noticed some months ago that Windows Update was not working properly. While fully connected to the internet, it told me: "we cannot connect to the updateservice ..." Looking at my internet connection, I noticed that inside Windows...
Hi there I have a folder / key in Regedit that I want to delete -- have given all privileges Exit regedit enter regedit again -- previous entry STILL in the registry -- same after reboot/ How do I SAVE changes -- if this tool is broken...
After the Anniversary update (version 1607 via Windows Update), Search doesn't work properly. (I have re-started again). If I enter a search term ("Restore") on search bar next to the Start Button I get Best match: "Recovery, Control Panel" at the...
start not working properly after update in Windows Updates and Activation
After i have installed the last set of updates, i can no longer left click on start. When i click on the option to choose start up apps, everything is greyed out.
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 05:52.
Find Us