Windows 10: 4TB external disk is shown as MBR formatted. How is this possible? Solved

  1.    07 May 2018 #1

    4TB external disk is shown as MBR formatted. How is this possible?


    The reason for my question is as follows.

    I had a 4TB Samsung D3 Station external disk that suddenly stopped working. I determined that the problem must have been with the external enclosure and I therefore bought a replacement. Upon trying to connect the drive Hard Disk Sentinel reported that "the partition on this hard disk created (sic) with 4K physical sector size but the current physical sector size is 512 bytes" and "it is recommended to re-connect the hard disk as previously connected (probably with different USB adapter, enclosure, docking station or so to access the partition with ll stored data - otherwise data loss may occur".

    To cut a long story short, I eventually reformatted it as the data on it were already backed up elsewhere. However, I ended up with two partitions and I couldn't merge them, apparently because the size of one of them exceeded 2 TB. I finally used a program from AMOEI and I created a single partition on the disk, equal to nearly 4 TB.

    The partition now is GPT type. However, the previous partition on this disk, also 4 TB, was type "Basic MBR". So how come it was 4 TB Basic MBR in its original (new) form whereas I was restricted to partitions below 2 TB later on when I wanted to have a single MBR type disk up to 4TB? Does it have anything to do with the enclosure, that is the original enclosure from Samsung compared to the new enclosure that I bought?
      My ComputerSystem Spec

  2. jumanji's Avatar
    Posts : 759
    Windows 7 Ultimate 32bit
       07 May 2018 #2

    Yes, your good old 4TB Samsung D3 Station external disk was an advance formatted MBR drive.

    A normal MBR disk can address only 4,294,967,295 physical sectors. The normal sector size is 512 bytes. That works out to 4,294,967,295 sectors ( that can be addressed) * 512 bytes/sectors = 2,199,023,255,040 bytes or 2.2TB.

    To make larger than 2TB drives compatible with Windows XP, ( Windows XP is GPT blind and GPT came much later than large capacity drives) eight 512 bytes physical sectors were combined into one 4096 bytes per sector ( logical sector size). That way MBR could address 2.2TB*8 = 17.6TB drives. (
    4,294,967,295 sectors ( that can be addressed) * 4096 bytes/sectors = 17,592,186,040,320 bytes or 17.6TB).

    The SATA to USB bridge in those advance formatted drives consists of a special Drive Translation Circuitry which takes in eight of the usual 512 byte data stream - with the clock/synchronising bits at the beginning and end - combines it and converts it into a 4096 byte stream ( shifting the clock/synchronising bits to the beginning and end of the 4096 byte) and writes into the 4096 bytes per sector. While reading the drive the same circuit breaks the data coming from the 4096 bytes in each logical sector , and presents it as a 512 bytes /sector data to the OS.

    When you put the HDD into a new case, the drive translation circuitry is absent in the SATA to USB bridge in it and the drive is seen in its original 512 bytes/sector size. You can only see 2TB if you initialise and format it as an MBR drive.. Rest of the space will be inaccessible. Initialise it as a GPT drive and format it, you can see and use the full capacity.

    We had a few cases requiring data recovery on the HDD taken out from such cases, and we had used TestDisk to read the HDD as a 4096 byte/sector size and recover the data. ( software Drive Translation :))

    One such successful recovery here after changing the sector size from 512 to 4096: Hard Drive seems corrupt. 1 Partition now showing as 3 Partitions?
    Last edited by jumanji; 10 May 2018 at 22:53.
      My ComputerSystem Spec

  3.    07 May 2018 #3

    Thank you very much for the explanation!
      My ComputerSystem Spec

  4. jumanji's Avatar
    Posts : 759
    Windows 7 Ultimate 32bit
       08 May 2018 #4

    Most welcome.
      My ComputerSystem Spec


 

Related Threads
I have this USB disk that is formatted using Linux system (I believe it is ext2 or ext3). It is used to save TV-recordings. I use Linux Reader to copy these recordings onto my Windows pc. Am looking for a portable tool, similar to Linux Reader,...
Solved Raw formatted my external in Drivers and Hardware
Ok so I recently accidently made my external USB drive into a raw, I was wondering if I could some how get it back, I think it still has the files on it, I got it so windows finally recognizes it but all it wants to do is format it. I want to keep...
Solved Disk order shown in disk Management in Drivers and Hardware
140970 I read somewhere that the C directory disk should ideally be Disk 0 - as you will see, my three internal disks do not follow this pattern. Do I need to swap the signal leads at the motherboard end to correct this - or does it not really...
Hello all. Glad to be here. I know this or similar threads might have happened to another already or several but basically I was super tired and tried to save the windows 10 setup media creator onto my 500GB external HDD. And yes I realize now there...
Hello, I have a 750Gb external drive that was originally NTFS. Windows shows it as 698Gb. I formatted it to fat32 yesterday, and now windows reads it as 185Gb. In disk manager, as you can see in the screenshot link (from remote desktop) that I have...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 00:18.
Find Us