Windows 10: Internal SATA Drives show up as removeable media

Page 1 of 2 12 LastLast
  1.    07 May 2018 #1

    Internal SATA Drives show up as removeable media


    After clean install of Win 10 ver 1803 two (2) internal hard drives now appear in taskbar as removable and in fact can be removed....neither are the primary drive but backup drives....anyone else having this situation...have attempted registry changes as outlined below but does not resolve issue.

    https://support.microsoft.com/en-us/...moveable-media


    BIOS updates not possible due to age of mobo….everything worked fine prior to ver 1803
      My ComputerSystem Spec

  2. slicendice's Avatar
    Posts : 3,435
    Windows 10 Pro x64 v1803 Build 17134.228 (Branch: RS4 Release Preview)
       07 May 2018 #2

    Does your MB support hotswap/hotplug. Please check this in BIOS and disable it.
      My ComputersSystem Spec

  3.    07 May 2018 #3

    thks nope, an old ASUS P6T SE mobo….
      My ComputerSystem Spec

  4.    25 May 2018 #4

    Having the same problem, using the above link to MS does not provide a working solution. Have posted feedback about this, hopefully they will provide a working solution?

    Edit: The solution on that page is 3 years old, not very relevant.
      My ComputerSystem Spec

  5.    25 May 2018 #5

    If you use generic Standard SATA AHCI Controller driver (storahci.sys, see in Device Manager - Properties - Driver - Details), you can use the following regfile (do not forget to restart):

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\storahci\Parameters\Device]
    "TreatAsInternalPort"=hex(7):30,00,00,00,31,00,00,00,32,00,00,00,33,00,00,00,\
    34,00,00,00,35,00,00,00,36,00,00,00,37,00,00,00,00,00


    Or try to modify it according to your real disk controller driver (replace the "storahci" string with the name of your driver).
      My ComputerSystem Spec

  6.    26 May 2018 #6

    I had a look in [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\storahci\Parameters\Device] and most of the entries looked as if they were either corrupt or missing information. This might have been due to an earlier attempt at fixing it using another registry fix that didn't work or things were screwed up from the get go.

    I decided to start from scratch, I deleted the existing ahci drivers and data and performed a Windows reset. This solved the problem. It might have been a bit more drastic but at least it solved the problem.
      My ComputerSystem Spec

  7.    26 May 2018 #7

    Glad you resolved it. And for WildOne, TreatAsInternalPort value should look like this:

    Click image for larger version. 

Name:	storahci.png 
Views:	3 
Size:	54.6 KB 
ID:	190237
      My ComputerSystem Spec

  8.    26 May 2018 #8

    This is the reason why I am reluctant to take an unknown registry snippet as it probably would be better to download the generic achi driver and try to repair it that way. My entries now under storachi are as follows:

    (Default) REG_SZ (value not set)
    DisplayName REG_SZ @mshdc.inf,storachi_ServiceDescription%; Microsoft Standard SATA ACHI Driver
    ErrorControl REG_DWORD 0x00000003 (3)
    Group REG_SZ SCSI MiniportImage
    Path REG_EXPAND_SZ System32\drivers\storachi.sys
    Owners REG_MULTI_SZ mshdc.inf
    Start REG_DWORD 0x00000000 (0)
    Tag REG_DWORD 0x0000001f (31)
    Type REG_DWORD 0x00000001 (1)

    Edit: My bad, I didn't go down deep enough, it still looks like a sloppy mess in Device. Now mine looks like yours except for the last entry that you added, however; my hard drives are no longer listed as removable, which is a good thing.
      My ComputerSystem Spec

  9.    26 May 2018 #9

    Ethyrdude: No need to download generic AHCI driver because it is storahci.sys itself, which is included in Windows. This driver has to work with majority of SATA controllers and disks, that is why it needs some parametrization. So for major differences in device behavior are created Multistring values and each of them includes list of affected controllers or disks (determined by PNP ID or by other identifier). Do not worry about these cryptic values in the picture, they are pretty normal.
      My ComputerSystem Spec

  10.    02 Jun 2018 #10

    Thks muchomurka, regrettably your solution of adding ports to "TreatAsInternalPort" did not work for me...attached is pic of registry file prior to adding your solution...Click image for larger version. 

Name:	Screenshot (3).png 
Views:	8 
Size:	150.2 KB 
ID:	190936
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
I've tried to find answers to this issue using Google and this forum's search feature. I'm sure this must have happened to others but I can't find any information. It's possible I haven't used the correct search terms as I'm unsure how to describe...
My motherboard has two SATA controllers. C: and D: are connected to a separate controller from the other two hard drives and one DVD burner. C: and D: show on the remove/eject menu. How do I get them off that? The last, and only other, time I...
Hi, My motherboard is: GIGABYTE p55a-ud3p As you can see below, Windows 10 detected all 4 HDDs: 76043 And they are enabled in the BIOS (I think?): 760457604676047
I just spent a long time trying to find the best answer for this and wanted to save people some time... this is specifically for Windows 10. (So, the answer is basically here: http://superuser.com/a/961242 Add a new "Multi String Value" called...
Hi, first post here. Looking for some help on a crazy issue where none of my other internal SATA hard drives are mounting and showing up in Explorer. I have 4 of them that are powered up, show up in Disk Management, but I cannot do anything with...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 14:01.
Find Us