Windows 10: TV Analog Video Capture Broken after 1803 Upgrade Solved

  1.    04 May 2018 #1

    TV Analog Video Capture Broken after 1803 Upgrade


    I have a Hauppauge WintTV-HVR-2255 that was working fine before the Windows 10 1803 update. The digital ATSC tuners work fine, but the analog tuners (and the analog inputs) have stopped working. When I scan for the inputs using NextPVR I get an error "Unable to Locate Capture Filter."

    Any thoughts?
      My ComputerSystem Spec

  2.    04 May 2018 #2

    Uninstall the driver for it and turn off system. With the power off pull the card and reboot....the the system completely boot up...then download a new copy of the driver. Next, power down again, reinstall the card and boot up and install driver and check for issue.
      My ComputerSystem Spec

  3.    04 May 2018 #3

    Plankton said: View Post
    Uninstall the driver for it and turn off system. With the power off pull the card and reboot....the the system completely boot up...then download a new copy of the driver. Next, power down again, reinstall the card and boot up and install driver and check for issue.
    I had already done this, but tried your recommended process again. The analog tuners in the card are not being found. Some additional information: WinTV shows the error "Failed to attach capture filter (0x800040005)" when launching.
    Last edited by PJLLB; 07 May 2018 at 08:59.
      My ComputerSystem Spec

  4.    10 May 2018 #4

    I have a solution. I never looked at the privacy settings for a camera which are disabled by default since I don’t have a one. But it's the privacy settings for the camera which were reset with the April 2018 update that is the cause of the analog tuner and sources not working. In the Privacy settings “Camera access for this device” needs to be on, and “Allow apps to access your camera” needs to be on. The specific app that needs to be given access is “Win32WebViewHost.” Then a full restart (not shutdown startup) needs to be done, twice for some reason, along with restarting the Hauppauge services in computer management.

    The analog tuner and sources are now working normally. Apparently Windows treats the analog tuner and sources as regular capture devices like a camera.
      My ComputerSystem Spec


  5. Posts : 5
    Windows 10 Home ver. 1709 OS Build 16299.309
       10 May 2018 #5

    PJLLB said: View Post
    I have a solution. I never looked at the privacy settings for a camera which are disabled by default since I don’t have a one. But it's the privacy settings for the camera which were reset with the April 2018 update that is the cause of the analog tuner and sources not working. In the Privacy settings “Camera access for this device” needs to be on, and “Allow apps to access your camera” needs to be on. The specific app that needs to be given access is “Win32WebViewHost.” Then a full restart (not shutdown startup) needs to be done, twice for some reason, along with restarting the Hauppauge services in computer management.

    The analog tuner and sources are now working normally. Apparently Windows treats the analog tuner and sources as regular capture devices like a camera.

    Thanks for posting your fix. This also worked for both of my computers running Avermedia M780 tuner cards. Avermedia Center wouldn't even start but now everything works as it did pre-1803.
      My ComputerSystem Spec

  6.    11 May 2018 #6

    Hip2u77 said: View Post
    Thanks for posting your fix. This also worked for both of my computers running Avermedia M780 tuner cards. Avermedia Center wouldn't even start but now everything works as it did pre-1803.
    YW. Glad it helped.
      My ComputerSystem Spec

  7.    11 May 2018 #7

    Hi there
    Not a fix for your problem but another solution can work really well especially if analog TV (it already has here) has gone the way of the dodo).

    Use an HDMI splitter and output from cable box / satellite TV box into a hardware video capture device. This works for up to 1920 X 1080 resolution standard 1080p -- for 4K UHD there are still issues. Analog TV I think in any case only transmits at DVD standard (576) so running directly from the cable / satellite box will give you better resolution.

    I'm using a startech usb3 box as the capture device -- works a treat -- and for the HDMI splitter the cheap Chinese unbranded ones always seem to work up to 1080p resolution.

    Of course like all these things you are still recording in Real Time though.

    I like to record series and then watch on computer later or when travelling -- problem with using the cable / sat box as recording device --there's no way to off load the recordings on to a computer. Netflix allows limited downloading but it never seems to allow the programs I want to watch "offline".

    Cheers
    jimbo
      My ComputerSystem Spec


  8. Posts : 1
    Windows 7 and Windows 10
       14 Aug 2018 #8

    PJLLB said: View Post
    ..... it's the privacy settings for the camera which were reset with the April 2018 update that is the cause of the analog tuner and sources not working. In the Privacy settings “Camera access for this device” needs to be on, and “Allow apps to access your camera” needs to be on. The specific app that needs to be given access is “Win32WebViewHost.”
    I signed up to this forum just to thank you. This fixed my problem completely. It was the privacy setting that was preventing my software from accessing the video capture card.

    My capture card was the Avermedia C027 PCI-E card but what you said fixed my problem as well.

    I guess that camera privacy setting got more aggressive on what it blocks because before the win10 build 1803 version i had no problems having that setting enabled.

    Thanks again, your post has helped many people!
      My ComputerSystem Spec


 

Related Threads
Background Apps broken in 1803? in Software and Apps
After performing a clean install of 1803 on W10 Pro x64, I've noticed that the "Background Apps" toggle underneath Settings > Privacy > Background Apps keeps turning itself on upon every restart. Additionally, the "Choose which apps can run in...
Hi folks I have a video capture program (VIVA studio) which captures a 1920 X 1080p HD video signal from a hardware capture device via HDMI. The HDMI splitter simply splits signal from a SKY Q box or am Amazon fire stick - depending on what I...
bt878 video capture in Win 10 x64? in Drivers and Hardware
Has anyone been able to get any bt878 based video capture cards working in Windows 10 x64? I have a Leadtech WinFast TV2000 PCI card. I don't care about the old NTSC TV tuner on it, just want to get the S-Video input working. Why this old card?...
BSOD screen capture of video in BSOD Crashes and Debugging
I was doing a screen capture of a video on You Tube when this bsod occurred;1st since updating to windows 10 Pro. This bsod was a light blue color with very little writing, but didn’t get error code/report as to why it happened but did disable auto...
Machine -- Dell Previously using windows 7 before I was forced to update to windows 10. After allowing the machine to update, it reboot itself to start. What showed up is a blank screen with the message: Analog input cannot display this video...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 13:56.
Find Us