Windows 10 Synaptics Driver

  1. Posts : 2
    Windows 10

    Windows 10 Synaptics Driver

    I successfully upgraded yesterday from 8.1 and this morning I was looking at the new "desktop switcher." I was looking for an OSX style touchpad gesture to switch between them. I followed the instructions on the second part of Get Mac-Like Scrolling and Gestures on a Windows Laptop to try and get a custom synaptics driver working. In the course of this, I uninstalled the factory synaptics drivers using "Programs and Features" in the control panel. When trying to install the new custom drivers, I got the error:

    "A newer version of the Synaptics Pointing Device Driver is installed.

    If you want to install the older version of the Driver, please uninstall the current Synaptics driver by selecting "Synaptics Pointing device" from the "Add/Remove Programs" Control Panel, then run Setup again."

    At this point, my touchpad no longer works at all. So I tried to restore the driver to what it was originally.

    My first thought was to get windows update to update it for me. I got "Lenovo synaptics touchpad driver" to appear in the list of updates. When trying to update, it threw the error:
    "Synaptics driver update for Lenovo Pointing Device - Error 0x80070002"

    After rebooting and attempting again with no success, I turned to Lenovo's website. I found the support page for my device:
    Laptops and netbooks :: IdeaPad Y Series laptops :: IdeaPad Y510p Notebook - Lenovo Support (US)
    Seeing no Windows 10 driver, I tried to download the 8.1 driver. It appears to run, even copying files into Program Files, but when I hit "Finish" in the msi style installer, a windows 10 notification appears saying

    "This app can't run on this PC
    Realtek bluetooth suite doesn't work on this version of windows"

    that links to this page: Your app doesnt work with Windows 10 - Windows Help when clicked.

    In a final attempt to get the touchpad working, I went to the Synaptics website (Drivers – Synaptics) to download a generic driver. I once again downloaded the one listed for windows 8. Attempting to run this, I ran into the same error as the custom synaptics driver I started with ("A newer version of the Synaptics Pointing Device...").

    I then pulled up the trusty device manager, and seeing the Touchpad listed under Pointing devices, I uninstalled it thinking that I could maybe get the generic driver to work with it uninstalled. I later realized this was a mistake, because the lenovo drivers no longer appear in Windows Update. Needless to say, I didn't get any change out of the generic driver, or the custom one for that matter.

    Using the Device manager, was able to select the new "Unknown device" and use windows update to find drivers, but during the installation of those drivers, the error: "This device cannot start. (Code 10)" occurred. Now, the device status is listed as "This device cannot start. (Code 10) The specified request is not a valid operation for the target device."

    Here are the event logs for the device, if those are of any help.
    Dropbox - TouchpadLogs.evtx

    All I want at this point is to be able to use my touchpad.

    Thanks in advance.
      My Computer

  2. Posts : 173
    Windows 10 Pro
      My Computer

  3. Posts : 2
    Windows 10
    Thread Starter

    I have a different situation to that user. I am unable to install new drivers. I think it's due to the fact that the old ones are still around, but not listed in the "Uninstall a program" dialog (because I tried to uninstall them).
      My Computer

  4. Posts : 1
    Windows 10 Family

    Same issue here

    I'm upping the thread hoping for help. The three finger movements are not recognized, only the three-finger tapping (Cortana) and four-finger tapping (Notifications) are working.

    Same computer and specs, roughly.
      My Computer

  5. Posts : 56
    Windows 10

    I assume that you are sure that your device is Synaptics and NOT Alps or Elan.. if such what you need to do is the following:

    1- From Control Panel, Uninstall your current Synaptics driver and reboot.
    2- Install the Synaptics driver you wish to use, you will notice in the dialogue box that it may fail installing one or all the drivers, reboot the computer.
    3- Re-install the same Synaptics driver again, this time you will notice that the installation went successfully, reboot.
    4- configure through Synaptics settings, that's all.

      My Computer

  6. Posts : 4
    Windows 10

    YellowBerry said:
    I'm upping the thread hoping for help. The three finger movements are not recognized, only the three-finger tapping (Cortana) and four-finger tapping (Notifications) are working.

    Same computer and specs, roughly.
    Im having the exact same issue and really want the three finger swipe gestures working. Hope someone can help!
      My Computer


  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 20:51.
Find Us

Windows 10 Forums