Sound Volume problem when using digital audio (s/pdif) listening devic


  1. Posts : 22
    Microsoft Windows 10 Pro 64-bit
       25 Apr 2018 #1

    Sound Volume problem when using digital audio (s/pdif) listening devic


    I am having a problem with my sound. Whenever I play a video with A52 or DTS codec, I cannot control the volume with the player or with Windows volume control, other than muting the volume. The sound plays straight through the speakers.Now for a little background:This past weekend I wiped my hard drive that still had Windows 10 build 1511. For the past year and a half, I have not been able to upgrade, and in the past few months have not been getting updates either. I now have 1709. And that is when the volume problem began. I am using the on-board sound (VIA HD). I have used the drivers for VIA and the generic Microsoft drivers. The volume problem occurs with both drivers. I am connected to a VIZIO 5.1 Sound Bar with an Optical Digital Audio Cable. When listening through the sound bar, the playback device is digital audio (s/pdif). When listening through the headphones, I choose the speakers playback device. When listening through the speakers device/headphones, I can control the volume normally. Before reinstalling Windows, I did not have this problem.
      My ComputerSystem Spec


  2. Posts : 22
    Microsoft Windows 10 Pro 64-bit
    Thread Starter
       27 Apr 2018 #2

    No one else has had this problem?
      My ComputerSystem Spec

  3. slicendice's Avatar
    Posts : 3,806
    Windows 10 Pro x64 v1809 Build 17763.288 (Branch: RS5 Release Preview)
       27 Apr 2018 #3

    ShdwKnght said: View Post
    No one else has had this problem?
    I recognize this issue from other people with similar issues. I don't use optical nor digital output so, I can't help much...

    I think your driver/audio output is set to passthrough rather than going via some sort of mixer or similar. Please check all audio tools and control panels available from the driver package and Windows built in audio applications that manages sound. Maybe there is a switch in wrong position!?


    OH, and another thing...since you are having the problem when you use multi channel audio, I think you are missing the proper codecs.
      My ComputersSystem Spec


 

Related Threads
Hi there. So I have been having this problem for a while now with my internal laptop speakers. They very infrequently play sounds and when they do, its only for about a minute. No problems with headphones and playback devices switch as they...
Hello I have a recurring problem with bsods some say kernel security check failure and others say driver irq not less or equal type of stuff ,but I never get them when I have set to listen to my microphone with full volume so I constantly have to...
I have homebuilt core i7 930 running an asus p5 premium. Whether I use onboard sound (realtek), sound blaster pcix titanium, or sound blaster omni usb, I get strange behavior where the sound will drop out while I'm watching a tv app (hdhomerun, or...
No matter what I do the volume setting is always lowered at startup. I hope there's a setting somewhere that I'm missing. Could it be a Realtek setting/problem? Any ideas?
Yesterday my optical audio was working just fine. I had it going through to a denon avr-2105 receiver w/ 5.1 surround sound. Today, there is no audio going though. Here is the problem: I used another digital audio device and troubleshoot both the...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 14:30.
Find Us