Cannot install RST on ASUS UX52

  1.    16 Apr 2018 #1

    Cannot install RST on ASUS UX52

    I have an ASUS UX52 running Windows 10 Home, and I'm trying to install Intel RST on the machine to make use of the 24GB SSD for caching - but for every version I've tried I get the error "This platform is not supported". Does anyone know what I'm doing wrong here?
      My ComputerSystem Spec

  2.    16 Apr 2018 #2

    Hi DangerousDave2k,
    Please try this driver Intel RST
    Only update from Device Manager.
      My ComputerSystem Spec

  3. bobkn's Avatar
    Posts : 1,995
    Win 10 X64 Pro 1809 17763.55
       16 Apr 2018 #3

    Why aren't you doing it by using the ExpressCache utility that's a free download from Asus?
      My ComputersSystem Spec

  4.    16 Apr 2018 #4

    All the instructions I've read have said you need both RST and ExpressCache for it to work - but having said that, ExpressCache may actually be working on its own - at least it says the SSD is 'mounted' (but didn't ask me how much of it to use like RST does).
      My ComputerSystem Spec

  5. bobkn's Avatar
    Posts : 1,995
    Win 10 X64 Pro 1809 17763.55
       16 Apr 2018 #5

    In my ignorance, I assumed that if RST was required, Asus would also have a suitable version for download. (They don't.)

    I also didn't ID the chipset in the laptop, and whether Intel supported RST on it. (And, if so, which version.)
      My ComputersSystem Spec


Related Threads
hello everybody i have asus zenbook pro UX501VW with windows 10 OS, after i tried fresh installation with media creation tool, F9 doesn't function and 'reset PC' from windows bring me restore of the fresh installation. the original recovery...
Was running Win10 with bluetooth perfectly well until a virus hit. Used Malwarebytes recovery and it found a couple thousand issues. Told it to fix everything and computer bricked. Took it to a local tech while on vacation in Mexico. Had a clean...
Right. I bought this laptop, the spec is decent and the price was cheap. I realized it was so cheap because it didn't have a windows OS installed on it. I thought "That's fine, you're decent when it comes to computers. Just buy windows 10 and...
Well, after I updated Win 7 to Win 10, I "lost" the Smart Gesture program. I downloaded the recent Smart Gesture from ASUS support website that should be working for Win 10. Alas, I reach the end of the installation when I get this message: "There...
Asus U43J Windows 10 won't install in Installation and Upgrade
I am having an issue with Windows 10 on my laptop. I have installed Windows 10 on various machines from laptops to desktops without any issues. I have used USB and DVD media as well as done clean installs and upgrades. This is the first problem like...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 00:33.
Find Us