Windows 10: USB 3.0 hub showing as 2.1

Page 2 of 2 FirstFirst 12

  1. Posts : 347
    Windows 10 Pro 1709 16299.309
       3 Weeks Ago #11

    loosenut said: View Post
    I don't think that's the issue - otherwise the USB flash drive would be running at 3.0. Does that make sense?
    Well we are trying to isolate the problem you are having. It could be a mislabel product and its really is only a USB 2.0 device ? Looking at the HUB #'s, The HUB states is only running at USB 2.1 speeds on a USB 3.0 connection ? I question why it isn't showing a 3.0 speed ???

    Just trying to help.
      My ComputersSystem Spec


  2. Posts : 12
    Windows 10 build 10532
    Thread Starter
       3 Weeks Ago #12

    storageman said: View Post
    Well we are trying to isolate the problem you are having. It could be a mislabel product and its really is only a USB 2.0 device ? Looking at the HUB #'s, The HUB states is only running at USB 2.1 speeds on a USB 3.0 connection ? I question why it isn't showing a 3.0 speed ???

    Just trying to help.
    I appreciate your help! I'm attaching the two Tree View files, one with nothing connected to the Hub, and one with the USB 3 Flash Drive connected to the Hub. As I reminder, the USB 3 Flash Drive shows as USB 2 on all ports, of the Hub or when plugged in directly to the computer.

    However, I just plugged the USB 3 drive into my laptop, and it does show as USB 3. When I plug the Hub into the laptop, it shows as USB 2.

    So, that's all pretty weird.
    USB 3.0 hub showing as 2.1 Attached Files
      My ComputerSystem Spec

  3.    3 Weeks Ago #13

    Nothing jumps out at me from the logs.

    You can try booting to a Ubuntu live USB drive and seeing if USB 3.0 is negotiated in Linux (by running lsusb -v). That way you can see if it's a Windows issue.
      My ComputerSystem Spec


  4. Posts : 347
    Windows 10 Pro 1709 16299.309
       3 Weeks Ago #14

    I believe the OP has a bogus USB 3.0 HUB. I decided to hook up a 3.0 hub on a 3.0 port and also plug in a USB 3.0 memory stick. I also have attached on a 3.0 port a USB 2.1 HUB and it has a couple USB 2.0 devices The following screen prints document the USB 2.0 HUB and its connection speed, followed by the USB 3.0 and its connection speed and finally the USB 3.0 Memory stick and its connected speed. I'm sorry but from what you have shown in this thread, it looks like its a 2.0 HUB.

    Opps it looks like the attachments were inserted backwards from how described them above so the first one is the 3.0 USB stick.
    Attached Thumbnails Attached Thumbnails USB30_1.jpg   USB20.jpg   USB30.jpg  
      My ComputersSystem Spec


  5. Posts : 12
    Windows 10 build 10532
    Thread Starter
       3 Weeks Ago #15

    storageman said: View Post
    I believe the OP has a bogus USB 3.0 HUB. I decided to hook up a 3.0 hub on a 3.0 port and also plug in a USB 3.0 memory stick..
    I'm going to go with that. Time to contact returns. I appreciate everybody's help on this. Cheers!
      My ComputerSystem Spec


  6. Posts : 12
    Windows 10 build 10532
    Thread Starter
       3 Weeks Ago #16

    Actually, before we close the thread, I'll post the results from plugging the device into Ubuntu on my laptop. The diff is pasted below. "bcdUSB 2.10" seems to indicate that it is USB 2.

    Code:
    Bus 008 Device 002: ID 05e3:0610 Genesys Logic, Inc. 4-port hub
    Device Descriptor:
      bLength                18
      bDescriptorType         1
      bcdUSB               2.10
      bDeviceClass            9 Hub
      bDeviceSubClass         0 Unused
      bDeviceProtocol         2 TT per port
      bMaxPacketSize0        64
      idVendor           0x05e3 Genesys Logic, Inc.
      idProduct          0x0610 4-port hub
      bcdDevice           92.26
      iManufacturer           1 
      iProduct                2 
      iSerial                 0 
      bNumConfigurations      1
      Configuration Descriptor:
        bLength                 9
        bDescriptorType         2
        wTotalLength           41
        bNumInterfaces          1
        bConfigurationValue     1
        iConfiguration          0 
        bmAttributes         0xe0
          Self Powered
          Remote Wakeup
        MaxPower              100mA
        Interface Descriptor:
          bLength                 9
          bDescriptorType         4
          bInterfaceNumber        0
          bAlternateSetting       0
          bNumEndpoints           1
          bInterfaceClass         9 Hub
          bInterfaceSubClass      0 Unused
          bInterfaceProtocol      1 Single TT
          iInterface              0 
          Endpoint Descriptor:
            bLength                 7
            bDescriptorType         5
            bEndpointAddress     0x81  EP 1 IN
            bmAttributes            3
              Transfer Type            Interrupt
              Synch Type               None
              Usage Type               Data
            wMaxPacketSize     0x0001  1x 1 bytes
            bInterval              12
        Interface Descriptor:
          bLength                 9
          bDescriptorType         4
          bInterfaceNumber        0
          bAlternateSetting       1
          bNumEndpoints           1
          bInterfaceClass         9 Hub
          bInterfaceSubClass      0 Unused
          bInterfaceProtocol      2 TT per port
          iInterface              0 
          Endpoint Descriptor:
            bLength                 7
            bDescriptorType         5
            bEndpointAddress     0x81  EP 1 IN
            bmAttributes            3
              Transfer Type            Interrupt
              Synch Type               None
              Usage Type               Data
            wMaxPacketSize     0x0001  1x 1 bytes
            bInterval              12
      My ComputerSystem Spec

  7.    3 Weeks Ago #17

    Yes, that would indicate it's connected through USB 2.0.

    That weird thing is that only USB 3 devices would use bcdUSB==2.10 (that version number was introduced in the USB 3 spec). So the hub is probably USB 3 but maybe there's a wiring issue.
      My ComputerSystem Spec


 
Page 2 of 2 FirstFirst 12

Related Threads
USB HDD Not Showing Up? in Drivers and Hardware
Hey guys, I've got 4 external USB HDD's connected to my PC. 3 of them are working fine, however the 4th isn't showing up. It shows up when I right click the USB icon in the bottom right corner of my screen and its name is "My Book" but it doesn't...
I was updating my graphics driver and had to restart the pc. When it started booting back up it took like 10 minutes to get to the windows login screen. Then I noticed that some of my program icons were missing. So when trying to figure out why I...
Okay so this is the second time I have come across this issue. The first time I ran deep virus and malware scans to no avail, ran CCleaner and updated all drivers as well as checking startup items and finding nothing unusual. I ended off having to...
Hi! In my PC I have a 3TB Seagate Barracuda HDD. Recently, the drive has been stopping showing up in Windows, and it's normally fixed by unplugging all drives, rebooting, plugging the drives back in and then turning it on again. Today, the drive has...
USB showing as CD? Any fix? in Drivers and Hardware
http://i65.tinypic.com/25qfb6r.png Look , is there a way I can do it like a USB should do? The F: is the USB

Tags for this Thread

Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 22:52.
Find Us