Windows 10: Win10. Seagate HDD not seen by Win10.

  1.    4 Weeks Ago #1

    Win10. Seagate HDD not seen by Win10.


    I have this Seagate SATA HDD that win10 doesn't see. Not anywhere. Device manager, disk management, nowhere.

    But run Seatools on the computer and it sees it okay and gives it a clean bill of health.

    Except it doesn't list it as 'ready to test' like it does all the other drives.

    I know it is a good drive because I can move it to another win10 computer and it shows up and works fine.

    What can I do?
    Last edited by abrogard; 4 Weeks Ago at 15:14.
      My ComputerSystem Spec


  2. Posts : 6,879
    Windows 10 Pro x64 Build 1709
       4 Weeks Ago #2

    This wouldn't be a boot drive out of the other Windows 10 computer (The Win 10 computer that can see the drive.)

    If it is please put it back into the Win 10 computer that can see it. Boot, hold the shift key and click shutdown. Then move it and see if you can see it.
      My ComputerSystem Spec

  3.    4 Weeks Ago #3

    No, it is not. It was a data drive on this computer and clearly visible. When it went missing I thought it must have died and took it to another computer to check - found it was clearly alive.

    What is a shutdown with the shift key pressed?

    I'm in correspondence with ASUS and I'm going to update the BIOS - just a glitch right now where I don't find in BIOS what they're telling me to find.

    But I can't see how that'd really be the problem, given it was visible. Unless BIOS allows for SATA ports to come and go of their own accord.
      My ComputerSystem Spec


  4. Posts : 6,879
    Windows 10 Pro x64 Build 1709
       4 Weeks Ago #4

    Shift and shutdown does a complete shutdown.

    Depending on board some sata ports don't work if you have m.2 drive. Please check documentation.
      My ComputerSystem Spec

  5.    4 Weeks Ago #5

    The board is an ASUS H170 Pro Gamer.

    The Seagate HDD is not an M.2 device, I think. It used to work on this machine. For quite some time.
      My ComputerSystem Spec


  6. Posts : 6,879
    Windows 10 Pro x64 Build 1709
       4 Weeks Ago #6

    Thanks for board number.

    Wasn't saying your HDD was an M.2. Was saying if you have an M.2 then in some Asus boards certain Sata ports are disabled.

    I assume you tried a different port and cable.
      My ComputerSystem Spec

  7.    4 Weeks Ago #7

    Yep. Shouldn't have posted the question without putting details of board and whatever I guess. Ah well.

    Yes, I've tried different cables and different ports. I've been corresponding with ASUS and I'm going to update the BIOS today, I hope. That might help. Mine is version 0703, their latest is something like 3000. Been a lot of updates.

      My ComputerSystem Spec

  •    4 Weeks Ago #8

    Hey abrogard,
    Probably a long shot, but when you checked Device Manager did you Show Hidden Devices (View > Show Hidden Devices) to see if that might shed some light on on your missing drive?
      My ComputersSystem Spec

  •    4 Weeks Ago #9

    Good thought but I'd already tried that one. Didn't work. Too bad
      My ComputerSystem Spec


  •  

    Related Threads
    Hi,I transferred (cut and paste) a very important video that I took this morning via USB cable from Samsung Galaxy Edge 7 to Win 10 Pc. I played it once on Win10 and went away from PC. When I came back the file was gone. I can see the link in...
    OK, maybe this was really stupid. I had a 32GB flash drive formatted with the Win10 media upgrade image on it (bootable). I was going to use it to upgrade another system but in the meantime I wanted to copy some programs between two systems. I...
    Hi, My disk contains 5 partitions: part1 = ntfs-win10 free upgrade of win home premium (primary) Part2 = ntfs-win7 home premium (primary) Part3 = ext3-Extended (logical) Part4 = ext3-LM rafaela (extended) Part5 = swap (extended) This setup...
    I hope somebody can either explain to me what I'm missing or point me to an explanation. I have two 256 Gig SSDs on which I'd loaded different operating systems but virtually identical applications. One was Windows 8.1 and one was Windows 7. ...
    My machine has two boot volumes. vol3 (win7 now win10) and vol5 (win8 tp10). After automatic upgrade of win7p to Win10p(64) on vol3, all appeared to be well. It activated just fine (good network) and Edge and Chrome work fine. However, IE11,...
    Our Sites
    Site Links
    About Us
    Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

    Designer Media Ltd
    All times are GMT -5. The time now is 01:09.
    Find Us