Windows 10: USB Port Issue - Power Surge on Hub Port

Page 2 of 2 FirstFirst 12
  1.    05 Apr 2018 #11

    Original Title:USB DEVICS EXCEEDED THE POWER LIMITS OF ITS HUB....POWER SURGETHE USB DEVICS HAS EXCEEDED THE POWER LIMITS OF ITS HUB....POWER SURGE....this is what the error message that was displayed everytime i put my pendrive...so i did something ,the error message stopped but cant use any pendrive...when i put a pendrive,getting notifications at some ports...but explorer not opening the device....Please help
      My ComputerSystem Spec


  2. Posts : 614
    Win 10 pro Upgraded from 8.1
       05 Apr 2018 #12

    paulyjustin said: View Post
    I have 2 usb ports on my dell xps 15 9550 laptop. One on the left and one on the right. The left one i plug the usb for my wireless mouse. The usb port on the right, i plugged the 4 port usb into it. Thus in that 4 port usb, i would plug in say my keyboard, usb flash drive and anything else into it.

    this one if powered it has its own 2.5 amp power supply https://www.amazon.com/Sabrent-Indiv...ed+4+port++usb


    This is the one i just bought. The old one i have is basically like the same thing in looks.

    https://www.amazon.com/Sabrent-4-Por...rds=4+port+hub



    So yes its self powered? Basically you connect it to the usb port on laptop and then click on individual buttons to enable it. When you do that, theres a blue light. You turn it off by pressing it etc. I mean aren't all port hubs mostly like this? I don't know why you would assume its not self powered?


    The thing is when i plug the flash drive into the new 4 port hub i bought and plugged it into my laptop usb port, it recognize it like it should. But after say x amount of time, you hear that sound where it mean the usb flash drive is not working. Thus i click my computer and the F drive for this usb flash drive doesn't show up. This is same thing that happened with the old 4 port usb hub. The thing is the other usb ports when plugged in such as wired keyboard... they work and have no issues even when the usb flash drive doesn't work. Thus after a while, it would say windows malfunction with usb port message. But its only the usb flash drive... not the keyboard.


    So when i click on that button to power off that 3rd usb port on the 4 port hub and then click it right back to power it on, it recognizes it as when i go to my computer, it shows the flash drive.


    So based on that, isn't this 100% my usb flash drive and not my laptop usb port nor those 4 port usb hubs?
    This is a powered hub it has it own 2.5 Amp power supply https://www.amazon.com/Sabrent-Indiv...ed+4+port++usb I have no idea why anyone would want switches on a hub but here they are and has the power supply. your computer port only put out 500 ma when you split that 4 ways you only have 125ma with the self powered hub each port has the maximum power allowed I'm thinking 500ma for USB 2 and 1amp for USB 3.0
      My ComputersSystem Spec


  3. Posts : 614
    Win 10 pro Upgraded from 8.1
       08 Apr 2018 #13

    I'm sorry I don't believe I can explain your problem to you so that you can fix it. Perhaps someone else will step in with more experience.
      My ComputersSystem Spec


 
Page 2 of 2 FirstFirst 12

Related Threads
I have an Acer E5-575G laptop with Intel Core i5 7200U, running Windows 10 Pro. Recently my USB 3.0 port is not working as usual. It's behaving as a USB 2.0 port and the transfer speeds are really low. Even my external hard drive, which shows blue...
W10 Eng + Port Keyboard = Bug in Drivers and Hardware
Hi. This is the problem. With Windows 10 and Portuguese (Brazilian) keyboard (ABNT2) things doesn't work properly. For example: Typing SHIFT+^ to have the mark ^ after hit the SPACE BAR comes like this ~ And twice SHIFT+^ before SPACE BAR, like...
I'm using a Dell U3415W monitor. My video card is AMD Radeon RX480. The monitor is connected via DisplayPort to my computer. The monitor is connected via HDMI to my work laptop. When I want to switch over to HDMI, it acts as if I shut off the...
How to Stealth Port 139? in AntiVirus, Firewalls and System Security
When I run ShieldsUP! It says port 139 is closed but not stealth. How I fix this please? FAILED: Name: https://www.grc.com/image/transpixel.gif netbios-ssn https://www.grc.com/image/transpixel.gif
I hope this is the right spot for this question but, I was wondering if anyone has any good recommendations for a quality ups/power surge protector? *some additional info * BenQ XL2430T (1920x1080@144Hz EVGA | 850W 220-G2-0850-XR R. ( The...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 09:11.
Find Us