Windows 10: Touchad Not Working

Page 1 of 3 123 LastLast
  1.    11 Mar 2018 #1

    Touchad Not Working


    Guys i am in real agony hear so if someone can help me i will really appreciate it.

    i have a TOSHIBA Satellite P50-C and touchpad is not working at all on it. And when i go to device manager & mice and other pointing devices , only HID-complaint mouse is showing there. I tried to install synaptics driver specific for my laptop from the Toshiba support page but whenever i try to install the driver, the driver window just disappears. It only happens with the Synaptics and elan touchpad drivers for my laptop, all other drivers from support page installs normally.

    I have tried installing the different versions of windows from 7 to 10 but this issue is not going away. And i know my touchpad is not broken because it works means i can use the cursor in bios setup while clean installing the windows but as soon as the windows setup starts it stops working.

    So if someone knows what really is going on with my laptop, please help me out.
      My ComputerSystem Spec

  2.    12 Mar 2018 #2

    Hi, does your touchpad work in Safe Mode?
    If you look in Device Manager, what do you see for the touchpad? Is any driver installed?
    (Look in both Safe and Normal modes).
    In normal mode, do you see any yellow triangles in Device Manager (not just for the touchpad?)

    What happens if in Device Manager you click Action, Scan for hardware changes?

    You would expect a driver to be installed automatically.

    Which edition of Windows did it originally come with? There are many variants of this laptop.
    Could you post the URL of the driver page you're looking at?
    Is it this?
    http://www.notebook-driver.com/toshi...river-utility/
    And presumably you have x64 Windows installed?

    If the only problem is the Synaptics driver, have you tried
    a. installing in compatibility mode
    b. making sure UAC is not off?
      My ComputerSystem Spec

  3.    12 Mar 2018 #3

    @dalchina no the touchpad doesnot even work in the safe mode.

    And in device manager under mice and others only HID-complaint mouse is showing even in the safe mode. And there is no yellow triangle on any driver.

    My pc came with windows 10 home edition

    And here's the link from where i downloaded the touch pad driver.
    https://support.toshiba.com/support/driversResults?freeText=8F247087C&osId=26

    And yes, i have tried installing installing the driver in compatibility mode and uac is on. But, still no success.
      My ComputerSystem Spec

  4.    12 Mar 2018 #4

    Noted you have posted this here
    Latest Synaptics Touchpad Driver for Windows 10 - Page 7 - Windows 10 Forums

    as well.
    Forum Rules - Windows 10 Help Forums
    - number 2. (I believe that means the subforums here)
      My ComputerSystem Spec

  5.    12 Mar 2018 #5

    I created the new thread because after posting in that thread , i noticed that thread is quite old and its not specific to the problem i am facing. Any way i have deleted that post, sorry for the mistake.
      My ComputerSystem Spec

  6.    12 Mar 2018 #6

    OK, thanks - certainly worth scanning that or searching for anything similar here.
    It's an odd situation. Just one thought for now- if you create Kyhi's bootable Win 10 disk (a very handy item for your toolkit) available from the top of the Software and Apps section here, you could see if your touchpad works with that Win 10 build.

    Hopefully someone will have a suggestion for you..

    Presumably there's no hardware button to disable your touchpad- I recall one laptop I had which had one. There is a way to disable your touchpad using the keyboard, but that wouldn't explain why you can't install the driver anyway. Hard to see why it works in BIOS but not Windows.
      My ComputerSystem Spec

  7.    12 Mar 2018 #7

    Ryan1991 said: View Post
    I created the new thread because after posting in that thread , i noticed that thread is quite old and its not specific to the problem i am facing. Any way i have deleted that post, sorry for the mistake.
    Do you have an option in BIOS to switch to Advanced mode? You could try going to BIOS settings, check in Main tab whether the option is available, if you have, click Touchpad and switch to Advanced mode.
    Click image for larger version. 

Name:	PIC_2203.JPG 
Views:	16 
Size:	66.9 KB 
ID:	180589
      My ComputersSystem Spec


  8. Posts : 5,006
    Win10 Home and Pro, Win10 Insider Preview, WinXP Home Premium, Linux Mint
       12 Mar 2018 #8

    My wife uses a Toshiba Notebook [actually her second one in 10 years] and it has an Fx key used to toggle the Touchpad On or Off. She prefers a USB wireless mouse. Her first Toshiba had a small switch between the Touchpad and Keyboard to do the same. Either function was hardware based so if turned Off Windows didn't know about its status.
      My ComputerSystem Spec


  9. Posts : 774
    Windows 10
       12 Mar 2018 #9

    FN+F5 is the touchpad on/off.
    F5 with Toshiba Function key driver.
    My Synaptics touchpad is listed under "Mice and other pointing devices" in Device manager same as the Mouse.

    However your hardware may well be different. I presume you know whether it is Synaptics or Elan.

    With the driver file TCxxxxxxx.EXE file is a self-extracting ZIP(icon).
    Run that should install the driver(it unzips to a temp folder somewhere then installs).

    Other Toshiba drivers you may need are, System Settings Utility, System Driver.
      My ComputerSystem Spec

  10.    12 Mar 2018 #10

    @dalchina yes, the part where it works in the bios and not the windows is making me go nuts. If it was not even working in bios then i would have known that its a hardware issue and have replaced the whole touchpad myself but strangely its not the hardware thing hence all this chapter.
      My ComputerSystem Spec


 
Page 1 of 3 123 LastLast

Related Threads
Hi, I am using Windows 10 with all the latest updates. Copy and Paste has stopped working. I am not able to copy and paste from anywhere e.g. In Notepad highlight a line and copy it and paste it. It will not paste anymore. In PyCharm as well,...
So my laptop stops working suddenly and then randomly starts working after 15-20 days for about 2-3 months. This has happened to me 3 times now. No lights come on in the system, I cannot enter BIOS mode, I tried to drain the residual battery and...
Windows Spotlight isn't working, I've tried like all steps found in the Internet to fix it but I just can't get it to work. It was working great on TH2 but since I clean installed RS1 it hasn't worked not once! Anyone got any solutions I could try?...
I cannot eyefinity 3 Monitor (Dell 22'') AMD Radeon HD 6570 Model Graphich Card Graphich Card have Port3: 1.VGA - 2. DVI - 3.HDMI 1. Monitor connected VGA -----to------VGA 2. Monitor connected HDMI -----to------HDMI 3. Monitor connected DVI...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 16:43.
Find Us