Windows 10: Adobe Photoshop CS6 print function is extremely slow!


  1. Posts : 305
    Windows 10 64-bit Home v1709 (OS Build 16299.192)
       08 Mar 2018 #1

    Adobe Photoshop CS6 print function is extremely slow!


    (*Monitors please note: I wasn't sure if posting here was correct or not so please move to the appropriate location if necessary.)

    Lately Adobe Photoshop CS6 print function is extremely slow. It takes several minutes to prompt the print window up, then it's very sluggish while setting print preferences. Once "Print" is selected it once again takes a long time to send to the printer via a wired network.

    Odd thing is I have other Adobe software, Lightroom 6 & Photoshop Elements 2018, that can print the same file without issues.

    Not sure how to troubleshoot this. Please help.
      My ComputerSystem Spec


  2. Posts : 305
    Windows 10 64-bit Home v1709 (OS Build 16299.192)
    Thread Starter
       08 Mar 2018 #2

    It seems to print at a normal speed now. I noticed in Lightroom 6 & Photoshop Elements 2018 the default printer was listed as Artisan 710 (Network). In Photoshop CS6 the printer was listed as EPSON510488. I checked the dropdown menu & Artisan 710 (Network) was listed there as well. When Artisan 710 (Network) was selected as default in CS6 all printed normal.

    I have no idea why the same printer is listed twice with different names & why it made a difference when
    Artisan 710 (Network) was selected but it does.
      My ComputerSystem Spec


  3. Posts : 305
    Windows 10 64-bit Home v1709 (OS Build 16299.192)
    Thread Starter
       29 Mar 2018 #3

    Adobe Photoshop CS6 print function is extremely slow again. It takes several minutes to prompt the print window, then it's very sluggish while setting print preferences. Once "Print" is selected it once again takes a long time to send to the printer via a wired network.
    Odd thing is I have other Adobe software, Lightroom 6 & Photoshop Elements 2018, that can print the same file without issues. Other software has no print issues as well.

    I have uninstalled / reinstalled Epson software & drivers. The printer shows as Epson Artisan 710 (Network) & not connected with USB but through our wireless network.

    In Device Manager there isn't a printer listed but is a Print queues.
    Not sure how to troubleshoot this. Please help.
    Attached Thumbnails Attached Thumbnails Capture.JPG  
      My ComputerSystem Spec


 

Related Threads
FORUM ADMINISTRATORS: If you need to relocate this post please do so. My problem dealt with Software & Apps & self solved so I wrote it here think it may help someone else. I recently upgraded my somewhat dated PC recently with a new MB, CPU, RAM...
Just thought I would share my experiences with CS6 Master Suite on Windows 10 Pro (64) I performed a clean install of Windows 10 (64) on my main image/video editing system (I'm a pro photographer). I installed it on a Samsung 250pro SSD which I...
I must admit, when I heard of another new image editor coming to Windows a few weeks ago I didn't really pay much attention because in the past they usually always seem to be too consumer orientated or crippled in some way. I.E. No 64-bit version,...
I tried to install my trusty CS2 into W10 in a VM but it didn't want to play, CS3 on the other hand installed without a hitch. I was just wondering if anyone had successfully installed CS2 in W10 yet? Or even tried?
Source: Windows 10 UWP app templates for Adobe Photoshop | Building Apps for Windows
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 13:12.
Find Us