Windows 10: SATA III PCI-e 2.0 x1 Card not working after 1709 update Solved

  1.    02 Feb 2018 #1

    SATA III PCI-e 2.0 x1 Card not working after 1709 update


    Hi all,

    I am currently on Windows 10 Pro 1607 and I have 3 HDDs and 1 optic drive plugged into my SATA III PCI-e 2.0 x1 Card. Everything is moving along just fine.

    I did the painfully long update (not by choice) to 1709. After it completed, this card stopped working (or Windows is not recognizing the drives plugged into it, I'm not sure which - it displays in Device Manager). I have updated the card drivers to V1.2.0.1047 but no joy there. BIOS sees the card and identifies the devices plugged into it. Once Windows loads, again, no joy.

    I've tried having Windows' Disk Management refresh and rescan but it never locates them. I've also done the usual steps of removing the card drivers completely and reinstalling after a restart.

    At this point, I've done a rollback to 1607 and have set updates to deferred in the hopes that will give me time to find a solution before having to make the jump to 1709 again.

    Current build
    Ryzen 1700
    ASRock AB350
    G. Skill Flare X 16GB DDR4 2400
    Primary: Crucal 256GB SSD
    Secondary (Profile drive): WD 640GB
    nVidia 980 GTX 4GB

    Any help is greatly appreciated.

    Thank you in advance!
      My ComputerSystem Spec

  2.    02 Feb 2018 #2

    Install the device driver from below website.

    2 Port SATA III PCI-e 2.0 x1 Card

      My ComputerSystem Spec

  3.    02 Feb 2018 #3

    What's the make/model of your SATA III PCI-e 2.0 x1 Card?

    Question: Why don't you plug your drives directly to the sata ports on the mobo?
      My ComputerSystem Spec

  4.    03 Feb 2018 #4

    FreeBooter - thank you. I had already downloaded those drivers.

    Plankton - Originally that is what I had but needed 1 extra SATA port which is why I purchased the card. I was trying multiple devices to see if it was the device itself not being recognized or the card.

    So, I decided to reinstall Windows 10 Pro again from a different 1607 build (Mar 2017 1607 image from Microsoft's website vs my MCT created 1607 from Dec 2016). Installed the same drivers for the SATA card, upgraded to 1709 and everything works fine.

    Not sure what the cause is unless the alter 1607 build laid down a better base? Have no idea.

    Thanks for the assist!
      My ComputerSystem Spec

  5.    03 Feb 2018 #5

    We are glad to hear your issue has been resolved, thank you for letting us know that all is now well!
      My ComputerSystem Spec


 

Related Threads
Only is enough to Creative explain that can't fix sound from SBZxR and I will back to Windows 7, We think about living on other planet, 1st software company on planet not capable to optimize own updates with hardware. We are doomed, our species...
I have sata 3 drives, but the mother board is sata 1 which is slow. MB is Aspen MSI 7548 MSI MS-7548 (Aspen) motherboards specifications The mb has a free PCIEx1 version 2 slot open. I have read you can buy an add on sata3 card to work with...
VIA USB 3.0 eXtensible Host controller card don't work after update til Fall Creators update. No errors, but either USB 2 nor USB 3 devices can be seen on the USB 3 ports on this PCI-e card. Have tried to find new drivers for it, but no succes....
I have an R-Driver III USB 2.0 to SATA IDE Cable (Comes with an AC adapter) and a SODIAL USB 3.0 to SATA III Cable (USB power only). I have tried to format 2 IDE drives on the 2.0 cable and one drive on the 3.0 cable. Using the 2.0 cable I have...
Hello folks, I cloned my C drive and updated to windows 10 a week ago. Yesterday SATA ports 2 and 3 stopped working (on MOBO gigabyte GA-Z77M-D3H-MVP). I think it is a windows 10 problem because I have: swapped my drives between SATA ports....
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 18:15.
Find Us