Windows 10: New External Drive not visible in "This PC" Solved

Page 3 of 4 FirstFirst 1234 LastLast
  1.    26 Jan 2018 #21

    Restart your computer see if you can disconnect external HDD from Safely Remove Hardware icon.
      My ComputerSystem Spec

  2.    26 Jan 2018 #22

    That used to work, but now I get this popup, although all programs are closed. The Task Manager shows there's nothing running.

    Click image for larger version. 

Name:	popup.jpg 
Views:	16 
Size:	49.2 KB 
ID:	174248
      My ComputerSystem Spec

  3.    26 Jan 2018 #23

    Some program have a open handle on the external HDD that can't be closed make sure antivirus program is not configured to scan the external drive see if this will resolve the issue but you will need to restart after configuring antivirus program.
      My ComputerSystem Spec

  4.    26 Jan 2018 #24

    My guess is that Avast is causing the problem. I see no option for excluding an external drive. I turned off Avast Shield Control and the external drive chirped a few times, but I still could not eject it via the Safely Remove Hardware tray icon. Since Quick Removal is activated for the drive, can't I just turn it off without ejecting? Can I trust Quick Removal?

    I tried one more thing: I turned off Safe Removal for the external drive, hoping I'd get an eject option when right-clicking in This PC. No joy. Isn't it weird that there is no eject option?
    Last edited by battlezone; 26 Jan 2018 at 03:31.
      My ComputerSystem Spec


  5. Posts : 19,226
    windows 10 professional version 1607 build 14393.969 64 bit
       26 Jan 2018 #25

    Find another computer and connect the external hard drive.
    Report into the thread your findings when viewing:
    a) disk management
    b) device manager > disk drives
    c) file explorer > this PC
    d) ability to properly disconnect the external hard drive.
      My ComputerSystem Spec

  6.    26 Jan 2018 #26

    I plugged the drive into my laptop, which is configured identically to my desktop. I got this right away:

    Windows is unable to stop the device 'USB Mass Storage Device.' Don't remove this device while it is still in use. Close any programs using this device and then remove it.

    Per the Task Manager, no program was running.

    a, b, c, d, all show identical to the desktop.

    The drive had a different drive letter when I plugged it into the laptop. It showed as F, while I assigned it Z on the desktop.
      My ComputerSystem Spec


  7. Posts : 19,226
    windows 10 professional version 1607 build 14393.969 64 bit
       26 Jan 2018 #27

    Until the problem is solved these are some options:
    1) use task manager
    2) log off
    3) shut down the computer
    4) use 3rd party software

    When Windows refuses to eject mass storage: 5 ways to safely remove a USB drive | PCWorld

    How to Fix Problem Ejecting USB Mass Storage Device| Solved
      My ComputerSystem Spec

  8.    26 Jan 2018 #28

    1. In the Task Manger, I do not see "." I also tried with Process Explorer.

    2. I logged out of both accounts - no go.

    3. Did it. No go.

    4. I installed USB Disk Ejector. Same popup as with Safely Remove Hardware icon.
      My ComputerSystem Spec


  9. Posts : 19,226
    windows 10 professional version 1607 build 14393.969 64 bit
       26 Jan 2018 #29

    Turning off the computer has to work as it is safe to remove the drive when the computer is off.
    With task manager > click the details tab > look for WUDFHost.exe
    It is the WUDFHost.exe that disappears and reappears each time I connect and disconnect a drive.
    See if ending this task works.
      My ComputerSystem Spec

  10.    26 Jan 2018 #30

    I clicked end task (WUDFHost.exe) in the admin account, but it didn't end the task. Still running.

    I also tried this, per a suggestion I read on a Microsoft help forum:

    In Disk Management, I right-clicked the drive and changed the setting from Quick Removal to Better Performance and rebooted. Supposedly, the eject option should become available when right-clicking the drive in This PC. The eject option did not show up.

    I also uninstalled Avast to see if that would help. It didn't. I still get the "a program is still using" popup.

    Nobody has yet commented on the default Quick Removal setting. Can it be trusted or not?
    Last edited by battlezone; 26 Jan 2018 at 18:04.
      My ComputerSystem Spec


 
Page 3 of 4 FirstFirst 1234 LastLast

Related Threads
Hi I have recently updated to the creator version My files end up in unintended destinations. When I click in the documents tab in the sidebar of the documents screen, it takes me to a “Documents” folder that appears in “One Drive” group. Any...
After last night i have re-turn on my computer about five minutes ago............ i see on "My Computer" i have a new "strange" system drive named F: (C and D it's my HD... E it's dvd burner) whit label "SYSTEM" and i have tryed to access and result...
My hard drive not showing in "my computer" or "Disk Management" but is showing under device manager. I got the hard drive from a friend and his dad had put a Password encryption on it. Any Ideas?
This thing: 72222(in Portuguese-Portugal) It's showing 3 Internets Explorers instead of the other 3 browsers that I most use. My OS is Windows 10 and I usually use Google Chrome to browse in the web. Sometimes I also use Microsoft Edge and...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 14:03.
Find Us