The media is write protected on internal HDD

Page 1 of 2 12 LastLast

  1. Posts : 4
    Windows 10 Enterprise

    The media is write protected on internal HDD

    After installing an mSata SSD as my main boot drive for Windows 10 Enterprise I can no longer write to the internal HDD.
    I have checked the read only status in disk part and everything is correct.
    If I pull the drive from the laptop and insert it into a usb dock I can write files to just fine.
    I am running out of space in the SSD and it really bugs me not being able to use my HDD.
    Thanks for any input.
      My Computer

  2. Posts : 4,224
    Windows 10

    Have you tried switching the internal HDD to a different SATA port when using it inside the PC enclosure/case? I'm curious if this is a property of just one SATA port or all of the available ones in your machine. If you can try plugging it into (or switching cables to use) a different SATA port, it may solve your problem (in which case you'll know it was the port) or not (in which case the drive becomes a more interesting suspect -- "interesting" because you can write to it when plugged into an external dock). For the nonce, you might want to just use it in your dock so you can write to it while we're getting this figured out.
      My Computers

  3. Posts : 445
    Win 10 Pro 64

    This should or maybe I should say could help with your problem...

    Step 1.

    From All Programs….select “Windows System”………Right Click and select “Run as Administrator” on “Command Prompt”…….when the cmd prompt window opens go to the next step…

    Step 2.
    Type "diskpart" at the prompt and press the "Enter" key. The Diskpart tool launches.

    Step 3.
    Type the "list volume" command, without quotes, then press the "Enter" key. The volumes attached to the computer are listed.

    Step 4.
    Type "select volume X" (omitting quotes and replacing "X" with the letter of the volume to modify) and then press "Enter."

    Step 5.
    Type "attributes disk clear readonly" (again omitting quotes) and then press "Enter" to make the specified disk writable.

    Step 6.
    Type "exit" to close the Diskpart utility.

    Hope you get it figured out....
      My Computers

  4. Posts : 4
    Windows 10 Enterprise
    Thread Starter

    Thanks for the input guys.
    I will hunt down an HDD caddy to try the other sata port for the DVD drive as there is only one HDD bay on this laptop.
    And I tried the attribute clear command but this did not resolve the issue.
    Thanks, again.
      My Computer

  5. Posts : 4,224
    Windows 10

    Something funky with the internal SATA connections, if the diskpart suggestion makes no difference. This one keeps getting more interesting but (and alas) not in a good way. Do keep us posted. I'm going to learn something from this, and I hope it's something valuable.
      My Computers

  6. Posts : 4
    Windows 10 Enterprise
    Thread Starter

    I may have made some progress?
    Ok, so when I go into my computer and right click and "format" the drive, as soon as it pops up in the "this pc" window I am able to partly transfer a folder to the drive before it kicks back with the "write protected" error.
    This is weird and I discovered this by accident.
      My Computer

  7. Posts : 4
    Windows 10 Enterprise
    Thread Starter

    Did some more googling and found this Second hard drive says write-protected

    This regedit resolved my issue!

    Ran diskpart clean after editing the registry and all is well.
    Time to offload my full solid state!
    And thanks for all input!
      My Computer

  8. Posts : 4,224
    Windows 10

    Thanks for following up. How on earth did you figure out what to search for? Great job!
      My Computers

  9. Posts : 2

    This regedit resolved my issue!

    Thanks this seems to have been what I needed. Saw several other posts suggesting changing other registry setting but this seems to be what I needed.
      My Computer

  10. Posts : 42
    Win10 Home, ver 21H1 build 19043.1052

    TheRagnarok said:
    After installing an mSata SSD as my main boot drive for Windows 10 Enterprise I can no longer write to the internal HDD.
    Is your mSata SSD encrypted like with Bitlocker?
      My Computers


  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 20:49.
Find Us

Windows 10 Forums