Windows 10: Logitech Setpoint Runtime Error Fix

  1.    21 Jan 2018 #1

    Logitech Setpoint Errors and some Fixes Fix


    I had an Issue with the latest Version of the Setpoint Software a few days ago with it crashing with a Runtime Error about every 5 minutes , you click okay and the Logitech Software auto restarts , but 5 mins later it crashes again , this happens Over and Over , and cannot be fixed in some cases by Reinstalling Setpoint. This is because it turns out it Uses C++ 2015 and if Windows Update has already installed the 2017 Version, 2015 C++ can fail to install because there is a newer version already installed.

    Click image for larger version. 

Name:	logitech Crash.JPG 
Views:	27 
Size:	28.7 KB 
ID:	173698

    The "Fix" is to Close the Logitech Software ( right Click taskbar icon >Exit) and goto Control Panel and Remove the 2017 Versions (x86/x64) of the Microsoft C++ Redistributables temporarily and reinstall them after the 2015 Version if you have a Program that needs them.

    There is a Offline C++ Installer made by a User on SoftPedia that Worked for me for the Re-installation
    ( 2017 C++ Still needs removing 1st ,
    there is a bug in the 2017 Installer apparently that doesn't set a registry entry correctly)

    Visual C++ Runtime Installer Download

    Direct link to the 2015 version is here though (ignore the Surface Advertising :

    Download Visual C++ Redistributable for Visual Studio 2015 from Official Microsoft Download Center


    MicroSoft has some of the other C++ Redistributables on this page too

    https://support.microsoft.com/en-ca/...al-c-downloads

    SEE POST NO#2 for the 2nd part of the Fix Please.



    KB
    Last edited by Kbird; 05 Feb 2018 at 22:07.
      My ComputerSystem Spec

  2.    05 Feb 2018 #2

    This is CRITICAL to the Above FIX so thanks and Credit to TairikuOkami

    Found at the Logitech Forums , here: (Forums)

    I had forgotten I had also done this but I had to reinstall SetPoint today , so it would see my T-RB22 again and this Problem had started again....

    KB



    The problem is caused by the old DLL, probably due to DEP.

    %ProgramFiles%\Logitech\SetPointP\msvcp110.dll

    (terminate Setpoint.exe beforehand deleting it, right click Taskbar Icon>exit)


    Remove the file, it will force Setpoint to use the DLL located within Windows


    del "%ProgramFiles%\Logitech\SetPointP\msvcp110.dll" /s /f /q

    ( I simply went to C:\Program Files\Logitech\SetPointP and deleted the File )


    Restart and it is done. ��



    Last edited by Kbird; 06 Feb 2018 at 15:05.
      My ComputerSystem Spec

  3.    05 Feb 2018 #3

    Uninstalling and Reinstalling Setpoint caused me to once again lose the Mouse Images in SetPoint for my Marble Mouse and Optical Trackman Mice, one cause of this is that previously you disabled Automatic Updates ( Setpoint hasn't been updated in 2 years now so why have it on?) and this setting seems to remain in Windows even if you uninstall and reinstall SetPoint, so try re-enabling Automatic Updates and Installation 1st ( Tools Tab) and hopefully a few Reboots later it will be Fixed, once Setpoint has contacted the Device Image Server and downloaded the required Images. (They are not included in the Setpoint Software for Every device ever made)

    Next thing to try is getting the Mouse Image Files for your Particular Mouse..... which is usually done by asking about this Issue on the Logitech Boards and hoping a Moderator Answers with a link for you Particular Mouse or Keyboard,
    but over the years I have Collected a few of these Files for Various Mice and Keyboards so I have zipped then all together for download and added them here:

    Missing Mouse Images.zip
      My ComputerSystem Spec

  4.    05 Feb 2018 #4


    One Fix For Setpoint Missing TAB Issues


    1. Open Task Manager with CTRL-SHIFT-ESC and select Processes.
    2. Right click on Logitech KHAL Main Process and Logitech SetPoint Event Manager (UNICODE), select End task to close each of them in turn, and then close the Task Manager.
    3. Go to C:\ProgramFiles/Logitech/SetPointP.
    4. Scroll down to SetPoint.exe.
    5. Right click on it.
    6. Select Run as administrator, and Ok
    7. Restart Setpoint or Reboot.


    Update:

    If you create a desktop shortcut to SetPoint.exe like I did, you won’t have to continually drill down into Program Files. All you have to do is right click and select Run as administrator after exiting the SetPoint icon in the Task Manager.


    Or:
    Solved - Logitech Setpoint | Eight Forums

    Or:
    Fix Setpoint Mouse Tab Missing in Windows 7 or 8 via CMD and Setpoint 4.24

    KB.
      My ComputerSystem Spec


 

Related Threads
I have two Logitech mice (M570 and M720.) Been using 570 as my all around mouse, and just got 720 for photography editing. I have been using setpoint 6.67.83 with 570. I have tried and tried to use Logitech's support forum for the following...
Latest Logitech SetPoint Software in Drivers and Hardware
Latest Logitech SetPoint Released Date: September 8th 2015 Software Version: 6.67.83 Updated Description: Support added for Windows 10 Bug fixes
Hi all, I'm desperate here. I've been using Logitech Setpoint for years. That is software that allows you to customize your Logitech Mouse or Keyboard. I've had my share of problems with Setpoint, but this is a new one. I had a drive failure, and...
Did a clean Windows 10 install yesterday, and installed the latest Logitech setpoint. After the installation it stated that I can edit settings for my mouse or keyboard by clicking the setpoint tile in the start menu. Well it is not there, and I...
Hello, On my old PC running W7, I used it with a Logitech MK 300 wireless Keyboard and with atheir Wireless Mouse. Worked just fine. Would like to use them both with my new W10 PC. The Wireless Mouse works just fine. I cannot get the...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 22:19.
Find Us