Latest Logitech SetPoint Software

Page 5 of 10 FirstFirst ... 34567 ... LastLast
  1. TairikuOkami's Avatar
    Posts : 3,806
    Home 1903 x64 10.0.18362.267

    alikocholo said: View Post
    1-I checked that when i uninstall set point , windows normally shutdown or restart
    Interesting, I have noticed something holding up shutdown, but I just ignore it, good to know why though. You could use commands to lower waiting time for shutdown, 1000 = 1 sec.

    reg add "HKCU\Control Panel\Desktop" /v "AutoEndTasks" /t REG_DWORD /d 1 /f
    reg add "HKCU\Control Panel\Desktop" /v "HungAppTimeout" /t REG_SZ /d "5000" /f
    reg add "HKCU\Control Panel\Desktop" /v "WaitToKillAppTimeout" /t REG_SZ /d "10000" /f
    reg add "HKLM\System\CurrentControlSet\Control" /v "WaitToKillServiceTimeout" /t REG_SZ /d "10000" /f

    alikocholo said: View Post
    2-I have another problem that set point program cant detach my mouse and keyboard icon in program ,just show normal keyboard and mouse in set point program , but when I go to control panel ---device and printers ----I can see Logitech performance mx and keyboard k800
    By any chance have you used a privacy tool to: Prevents device metadata retrieval from the Internet.
      My ComputerSystem Spec

  2. Posts : 53
    Windows 10 Pro x64 version 1809

    Cliff S said: View Post
    The last one fixed some stability problems with my keyboard, but nothing for my mouse. It was have freezing/lag problems. I haven't really had any problems since but I'll take this one too, and If nothing further happens, I'll stay with it for the lifetime of my hardware. I'm not big on updating non-video/non-codec drivers,
    I installed 6.67.83 on my Windows 10 1511 system and after a reboot, my USB 2 ports did not work any more (My one USB 3 port did work!).
    The USB 2 ports hang of an Intel 6 Series/C200 Series Chipset Family USB Enhanced Host Controller.
    Intel's driver update utility could not find an update.

      My ComputerSystem Spec

  3.    #43

    I just lost my keyboard with the last update 1511.17 and I don't know how to get back my pc. My mouse works and I just downloaded the latest setpoint to install once I can get to my main pc. Any help would be highly appreciated. Thanks


    MK700 keyboard problem with Win10 pro - build 10586.17

    I'm using MK700 keyboard problem with Win10 pro64bit - build 10586.17 and SetPoint center 6.67.83, control version 5.90.41.

    My keyboard says active, but I'm not able to type or use it. At this moment I'm using On Screen Keyboard from Windows.
    Please let me know if there is a solution to this problem.
    Thank you.

    Last edited by ered; 06 Dec 2015 at 04:50.
      My ComputerSystem Spec

  4. RWOne's Avatar
    Posts : 491
    Windows 10 Pro (Mix of Builds) / Linux Mint

    I just got my rig back together, and although still on 78 at the moment, going back to 10, the new setppint is working for my DiNovo, but it took out my BT stack - I think they are all working in wifi mode.

    On one hand I'm upset, not that it matters that it's BT, I got many years out of it in that mode.

    It may be better to leave it as it is an unsupported product, or try to get the BT going again once back on 10?

    wifi ops vs BT, mind you I never used the BT hub for more than the DiNovo ...
      My ComputerSystem Spec

  5.    #45

    Ever since I upgraded to Windows 10 Pro I have experienced serious issues with my Logitech Performance MX Mouse (wireless) and my Logitech K 740 Illuminated Keyboard (wired) and below is a list of my issues:-

    1. Moving icons/desktop items is extremely eratic and prone to serious error. For example, previously I could simple right click on Explorer and simply drag it some where else of to a second monitor (I use a dual monitor setup). Now, it can take me several attempts to get the right click to attach to Explorer and then begin the move process. One I start to move the object then I am in "unknown territory". Sometimes the "grabbed" object will follow me to my intended location but, more often than not, the object is simply dropped. If I am lucky it drops where I can see it and so I can start again. However, often it is dropped onto an unknown desktop object over which I havebeen dragging the object! Now I have a problem finding out where it has gone.
    2. When I attempt to right click a file and move it somewhere else it will work only rarely. More often than not the file mysteriously disappears. A more reliable method is "cut and paste" but that too is often flaky.
    3. When I am working with photos and Adobe Photoshop it is vitually impossible to make adjustments because the mouse repeatedly jumps to an unintended place.
    4. I often take screen/object prints using either the OneNote facility built into Office 365 or, for more sophisticated work I use Snagit. Now, neither of these methods work correctly.
    5. Playing Football Manager 2016 it is often necessary to move players from one position to another. Now this task is horrendously difficult.
    6. Moving images into Microsoft Word is now about 25% successful.
    7. You can only imagine how my productivity has dropped!

    I have tried uninstalling/reinstalling setpoint Version 6.67.83 64 bit but that makes no difference. I have also gone back to setpoint 6.32 and, although it is marginally better, it is still very bad.

    I have reported the matter to Logitech and was advised that there was nothing wrong with their products or with setpoint and the problem was that Windows 10 was riddled with bugs which would, eventualy, be fixed. That made some sense because a visit to Microsoft Insider Forums showed that hundreds of people were complaining about the same issue but none had found a reliable solution and Microsoft never acknowledged responsibility.

    Like may people I simply dcided to await developments. With every update to Windows 10 I hoped for answer but none has come yet.

    Yesterday I had some urgent work to do and it required extensive drag and drop activity and converting web pages to pdf files using Adobe Acrobat DC. The task drove me mad because of numerous failed attempts and the time pressure was such that I HAD TO DO SOMETHING TO SORT OT THIS PROBLEM. Since ALL of my issues involved my mouse then I ignored my work task and I tried the following to solve the problem:-

    1. I uninstalled my Logitech mouse and keyboard and removed SetPoint software.
    2. I rebooted my PC
    3. I then attached a wired microsoft keyboard and mouse.
    4. I allowed Windows 10 to install native drivers for both thes devices and I rebooted my PC.
    5. Then I tried my usual drag & drop tasks...................................... wow, everything worked first time and flawlessly.
    6. Then I tried converting web pages to pdf files using Adobe Acrobat DC - it worked flawlessly.
    7. Then I played Football Manager 2016 and it too worked flawlessly.

    So, it would appear that ALL of my problems were caused by Logitech device/software. It follows that in order to become productive once more, and to stop myself having a blood pressure issue, then I have abandoned Logitech.

    I hope my story is helpful to others.
      My ComputerSystem Spec

  6. Posts : 626
    Windows 7 Home Premium x64

    wow I feel bad for you Chevalier. Logitech does not seem to get their drivers & software working right under Windows 10, even with the newest version of Setpoint installed.

    I'm using older versions of the Logitech hardware (Logitech Cordless Desktop Express > keyboard MN: Y-RQ57 and mouse MN: M-RR95) that connect to old style PS2 ports on my custom built PC and will try to reproduce the problem on a Win10 OS and using the latest version of Setpoint.
      My ComputersSystem Spec

  7.    #47

    Howdy All,
    I've got a simple issue after upgrading to Windows 10 (from 7); simple but is still an issue.
    My Logitech M510 mouse doesn't hold my custom Setpoint settings. I don't even have to re-set them each time I boot up, just open the Setpoint options window and the mouse starts working the way I expect.
    Yep, I upgraded the driver first thing, but I have pinned Setpoint to my taskbar to initiate the settings whenever I start my computer.
    Might anyone have thoughts on a fix?
    My appreciation for reading this and your suggestions!
      My ComputerSystem Spec

  8.    #48

    I am using latest Logitech setpoint with M510 mouse and K350 keyboard.

    For a while they both didnt work together using the unified USB stick., I quit using the keyboard and used a wired USB keyboard.

    I came across an article which gave me an idea to try.

    I pulled out the USB unifying stick, dug out a short (3') USB Male/female cable plugged the Unifying USB stick in one end, plugged the cable in a port and placed the other cable end about 2 feet from the computer.

    Since then I don't have any problems with the keyboard and mouse together.

    I got the info from here:
    K350 lag - Page 4 - Logitech Forums
      My ComputerSystem Spec

  9.    #49

    Now the 7th September and the above fix is working fine, why I don't know.
      My ComputerSystem Spec

  10.    #50

    SetPoint6.67.83_64 i think this one gives issues on my windows 10 Home x64.
    i get blinking screen since lately with latest Nvidia WDDM 2.1 drivers , all of them.
    so i doubt Nvidia is to blame.

    something is bugging my drivers and causing app crashes.
    did many fresh installs , went back to previous build i know was fine.
    problem stayed.

    i had my suspicion on the Logitech drivers before.
    since i noticed these audio things added.

    i don't have Logitech audio devices , but a Creative SoundBlaster Omni and sennheiser.

    the screen blink is very rare.
    and reporting no errors in logs.

    this Logitech software, i cannot normally uninstall it without freezes, except in safe-mode no problem.
    also without the setpoint , windows 10 installs the Logitech USB input ,
    and Logitech unifying receiver drivers.
    so i guess i don't need the drivers for my keyboard. unless i want to control the button layout.

    also when i got rid of the driver software of setpoint , my CPU fan dropped RPMs
    so i am not installing this version again for sure.
      My ComputerSystem Spec

Page 5 of 10 FirstFirst ... 34567 ... LastLast

Related Threads
Latest Intel Chipset Device Software in Drivers and Hardware
Latest Intel Chipset Device Software WHQL Intel Chipset Download Link WHQL version: 10.1.17765.8094 Release Date: August 24, 2018 Download: Intel Chipset Device Software 10.1.17
Solved Logitech C920 Webcam in Drivers and Hardware
- I did an upgrade from Window7 to Win10(9926) - all went well, apart from a few glitches.. - the Logitech webcam doesn't function with Skype - anybody found a solution?
Source: Ready for Windows 10? So is Logitech - BlogBlog
Logitech Mouse M705 in Drivers and Hardware
I have this mouse with a Logitech K750 keyboard. Windows 10 recogises the Keyboard & installs the solar update but the mouse itself isn't fully functional as left/right scrolling with the wheel doesn't function. Have tried installing the...
I have an old installation of the Logitech Webcam Software on my PC, which is stubbornly refusing all attempts at removal.. it may be the remains of an earlier installation made under Windows7 and the recent upgrade to Windows10 is possibly...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 12:13.
Find Us